Hansel R. Gaete S.

Send private message

You must be logged in to send a private message.

Friends

No friends yet.

Group membership

Activity

  • Hansel R. Gaete S. replied on the discussion topic fresh install no mail send
    emmm i try test php mail sender and this works fine, but elgg ... no, help !! try again : this is the test on my gmail inbox ...  webmaster@elgg.sic.cl 18:58 (hace 2 minutos) para mí  If you can read this, your... view reply
  • Hansel R. Gaete S. replied on the discussion topic fresh install no mail send
    version 2.3.1new error (automatic registration) : [Sun Feb 19 22:47:06.852598 2017] [proxy_fcgi:error] [pid 17023] [client 190.45.22.105:34822] AH01071: Got error 'PHP message: WARNING: Metadata and annotations store only integers and strings.... view reply
  • Hansel R. Gaete S. added a new discussion topic fresh install no mail send in the group Elgg Technical Support
    Hi, im instaling some plataforms testing. with this plataform i get this error :  [Sun Feb 19 18:23:51.172911 2017] [proxy_fcgi:error] [pid 16874] [client 190.215.128.4:59924] AH01071: Got error 'PHP message: ERROR: Unable to send...
    • WARNING: Metadata and annotations store only integers and strings. boolean given.

      This is only a warning and doesn't affect sending of emails (or in your case the failure of email sending at the moment).

      So, the test for email sending suggested at http://learn.elgg.org/en/stable/appendix/faqs.html#missing-email works for you? If not, the Mail Transfer agent (MTA) isn't fully configured / not working. Elgg itself does not set up anything special for email sending. If the MTA is correctly set up, mail sending will work. Otherwise it won't. The site email address (used as FROM when sending mails) also needs to be accepted by the MTA.

      The only config option within Elgg that might be relevant with mail sending is $CONFIG->broken_mta that you can configure in the settings file (elgg-config/settings.php). Maybe it helps to set it to true. No more ideas otherwise.

    • emmm

      i try test php mail sender and this works fine, but elgg ... no, help !!

      try again : this is the test on my gmail inbox ... 

      webmaster@elgg.sic.cl
      18:58 (hace 2 minutos)

      para mí 
      If you can read this, your email is working.

    • Is the email address you are using as Elgg site email address from the domain your Elgg site is installed on? If not, the mailserver on your server might simply reject sending the mails. The mail sending test script does not set the From field used in the email header, so the mailserver falls back on a default address instead. Apparently this works. But if your site email address is from another domain it might not. The mailserver config could be adjusted to accept another email address (if you are allowed to change the mailserver config). But it surely is easier to just use an email address from the Elgg site domain instead as site email.