Release Notes

1) Resolved permission issue

2) Removed extra slash from setting.php view file.

  • Hi, I am trying to use Group Chat but having enabled it I see no sign of it anywhere?  I have changed the Elgg data directory permissions to 777 and changed all the Group_Chat directories similarly.  but no sign of any Group Chap on my site?  Any ideas please anyone? I am a rookie by the way.....

    Thanks

  • hi, rookie...

    you can see group chat pop-up on group page...

  • Many thanks for your help miteshsc.  I can see it now ok. However it comes up with this error message. Any ideas?  Thanks again.

    ERROR: Vars in views must be an array: group_chat/chat_process_engine



  • Also the same problems as others before i.e. no text showing on chat box.  Are there specific files or folders which need permission changes?

    Thanks again.

  • @StreetRJ: Seems like ELGG version is causing the problem.. May i know which version of ELGG you are using???

  • Thanks for your help in this. We are on 1.8.14

  • @StreetRJ: I ll have to check for 1.8.15 first then only i can say something.. Pls give me sometime.. ill get back to you for the same.

  • Sorry i mean, 1.8.14 version

  • Thanks again for your help.

  • Hello,

    First good job on the plugin!

    Though, there is a 2 main problems with the code. So here is the solution that solves the white page :

    • the plugin can't access the historic file because of en url error in the start.php in the get_chat_content function (line 59)

    $filepath = $CONFIG->data root.'/group_chat/'.$guid.'/'.$filename;        

    and it must be : (delete the first / in front of group_chat)

    $filepath = $CONFIG->dataroot.'group_chat/'.$guid.'/'.$filename;        

    • in the process.php file (action folder), the creation and set up of the directories in elgg-data are wrong (permission must be a number and not a string for example) -> from line 46

    $dataroot = $CONFIG->dataroot;
        if(!is_dir($dataroot.'group_chat')){
            mkdir($dataroot.'group_chat', '0777');  -> 0777 should not be a string but a number!
            chmod($dataroot.'group_chat', '0777');  -> chmod already set up in mkdir command. so this line is not needed.
        }
        $groupEntityId =  get_input('groupEntityId');
        if(!is_dir($dataroot.'group_chat'.'/'.$groupEntityId)){ -> your checking here if it is a directory and not if it exist. Which is better I think.
            mkdir($dataroot.'group_chat'.'/'.$groupEntityId, '0777');  -> 0777 should not be a string but a number!
            chmod($dataroot.'group_chat'.'/'.$groupEntityId, '0777');  -> chmod already set up in mkdir command. so this line is not needed.
        }

    so it must be like that: 

        $dataroot = $CONFIG->dataroot;
        if(!is_dir($dataroot.'group_chat')){
            mkdir($dataroot.'group_chat', 0777); 
        }

        $groupEntityId =  get_input('groupEntityId');
        if(!file_exists($dataroot.'group_chat'.'/'.$groupEntityId)){
            mkdir($dataroot.'group_chat'.'/'.$groupEntityId, 0775)
        }

    Hope this quick fix will help others.

    I still  havent found the fix for the "Vars should be in an array" error. Will post here if I find a solution.

     

miteshsc

Highly interested in social media plugin development and have been working on my own concept social website.. Hope fully will execute it pretty soon :)

Stats

  • Category: Communication
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 6027
  • Recommendations: 19

Other Projects

View miteshsc's plugins