News for 1.8 v1.8.3-12.05.02b

Release Notes

/** * @version 1.8.3-12.05.02b */- settings for restricting news to admins

  • Hi there,

    can this be use at the front page and 3 column?

  • @Voiprats you have to tweak a few code parts but all in all its possible.

  • is this someting you would like to do?3 colomn front page would be a killer - Let me know, Thanks

  • Getting this while trying to activate the plugin, can you help? Thanks

     

    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/content/70/8190470/html/ahead/elgg/mod/phloor_news/start.php on line 84

    Warning: Unexpected character in input: '\' (ASCII=92) state=1 in /home/content/70/8190470/html/ahead/elgg/mod/phloor_news/start.php on line 84

    Parse error: syntax error, unexpected T_STRING in /home/content/70/8190470/html/ahead/elgg/mod/phloor_news/start.php on line 84

  • hm.. what php version do you have installed? it has to be >= 5.3.0!

  • Ok i have

    PHP Version: PHP 5.2 - so that could be the problem then.
    Could you help me have your plugin display at the frontpage?
  • I want THAT, I am using elgg 1.8.8, I can't activate this plugin , Please help me how I can make it work for elgg 1.8.8.

    Can't activate the plugin says

    This plugin has unmet dependencies and cannot be activated. Check dependencies under more info.

    TypeNameExpected ValueActual valueComment
    Requires Elgg version >= 1.8.8 ok
    Requires Plugin: phloor any -- error
    Requires Priority After phloor phloor is not installed ok
    Provides Plugin: phloor_news 1.8 -- ok


  • @kiss, do you have the phloor framework downloaded and activated?  if so it must be above the news plugin

  • Dear @costakisc, Thanks for the reply, no I did not install phloor framework yet. I only installed this news plugin and could not activate. Do I have phloor framework to run this news plugin? 

    As I am trying to keep mini plugins on my site becoz I think more plugins make site more slow. 

    Is phloor framework plugin safe ? What else phloor framework will do for me If I install that? 

    Once again many thanks for ur reply, and hope u r also trying to fix my that register domain thing as well :)

    Have a nice day ahead

    Kindest Regards

  • @kiss, yes you have to have phloor_framework to use any of phloors plugins, and it is safe one of the good developers on this site, and will look a little at the domain register today, been busy for the last few days. will send you a pm when i get it figured out.  Oh, and phloor framework by itself does nothing, just a framework for the rest of the phloor plugins, should look through those plugins, some good stuff, i use a couple myself

     

  • @costakisc  THANK YOU SO MUCH, very well noted and gonna try this  phloor plugins 

    Take care my nice and first friend here on elgg.

    Regards

  • @ kisss4ever,

    you yourself can create a news plugin... Just rename the blog or Blog to news or News in each and every php pages.. also change the folder names to news or News accordingly...

    I created one like that..

     

  • Testing this plugin the following problems appear:

    - creating a news: sidebar gone

    - and the excerpt field can be craeted with editor? (should it be like this?)

    (php5.3 & elgg 1.8.13) 

  • It works so far. But errorlog file is growing and growing...

    <br />, referer: ...

    PHP Warning:  Module 'mcrypt' already loaded ...

    PHP Warning:  Module 'imagick' already loaded ...

    PHP Warning:  Module 'pdo_mysql' already loaded ...

    PHP Warning:  Module 'mysql' already loaded ...

    <b>Deprecated</b>:  Directive 'register_long_arrays' is deprecated in PHP 5.3 and greater ...

    <b>Deprecated</b>:  Directive 'register_globals' is deprecated in PHP 5.3 and greater ...

    ... thought for this release it has to be php 5.3 ? :/

  • lol, didnt somebody warn you about this a week ago?

     

  • i guess some people are really dependent on the phloor framework

  • rjcalifornia 3 days ago

    @xsurf What? I don't even... what?

    So let me get this straight:

    You changed the "news" wording to "phloor_news" to import old "news"? I don't know but that could create some future plugins conflict.

    Still, very confusing.

    ---------------------------------------------------------------------------------

    xsurf 3 days ago

    @costakisc

    Thanks, already done. I found this 'trick' in another thread.

    @rjcalifornia

    Which conflict? It works without phloor_framework and didn't use the grid-function and I disabled the icon-function. If I am not wrong, there should come no conflicft

  • Yes, right, no conflict with other plugins, exactly so as I wrote, and writing some useless things just won't change this fact...

    Just one little problem: when using the changed 'blog to -> news' plugin - changing the word blog by the word phloor_news, and I hope I must not explain this again...:) - and saving the news, a white page appears. The news is saved anyway, but the white page has not to be. I therefore will find a solution, anyway, with the help from nice people. Thanks.

    I tested the latest phloor_news, yes I did that, so what ... .... do have with your useless provoking comments?! Feel virtual mighty? LOL!

    Btw @all: there is a solution for the problem with phloor_menuitem, too.

    1) Use Menu Builder from Cold Trick

    2) Create dropdown menus for topbar and sidebar on your own:

    Look there, please, if you need this functions: http://elgghacks.com/full-edit-sidebar/comment-page-1/#comment-12508

    Pleased to meet you, ...

     

  • @xsurf

    and saving the news, a white page appears

    That's a plugin conflict.

    I tested the latest phloor_news, yes I did that, so what ... .... do have with your useless provoking comments?! Feel virtual mighty? LOL!

    It is not about provoking, it is about safety. We don't know what else the phloor framework will cause. It is already making a huge error log, and that could be just the tip of the iceberg...

  • My errorlog  file shows all mentioned errors made by the phloor_news plugin , not from the phloor framework plugin - I thought so. So the errors are not created by the phloor_news plugin, but from the phloor framework plugin, only - refering - from the phloor_news plugin?

    Ok, thanks, I learned to understand this now.

  • The errors are being made by the phloor framework, so I will encourage you to either:

    -Fix the Phloor Framework

    -Deactivate Phloor Framework

    Those 'deprecated' notices are not from the 'phloor_news plugin', are from the framework. The white page after creating a news, is a plugin conflict.

    I hope that helps.

  • Yes thanks, that' exactly my plan:

    - do not fix that framework, because I can't

    - find the conflict (find my faulty code) in the 'block -> to phloor_news' changed plugin

    - deactivate phloor framework

  • Ok. So we hope that the developer of the phloor_news read these posts (as he wrote, he still follows the posts) and tell us, how to manage this.

    Thanks.

Stats

  • Category: Uncategorized
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 2564
  • Recommendations: 9

Other Projects

View 13net's plugins