Videolist v1.8-beta3

Release Notes

 

Bugfixes and enhancements:

  • Now you can disable videolist for a group, from group options.
  • There is a better way to give support to a new video platform (thanks mrclay!).
  • Hey guys, I just installed this plugin in my elgg site and it's working well, Thank you ^^

    But I wanted to know if there is a way to create a "default size" for the videos inside the videolist, because some are small, and some others are too big...

     

    Thanks since now and keep the great job.

  • Is it possible to have in simple steps clear instructions what need to be done to get the snapshot working for the video from you tube. I just have series of broken images. I have upgraded to elgg version 1.8.13 and after the upgrade the pluggin stopped working properly.

    you can see the issue here:

    http://beathespread.com/videolist/all

  • fyi, this plugin does not interface so well with vimeo - e.g. if you attempt to add a vimeo video to videolist while vimeo is processing the video (perhaps an enhancement or other cause for processing) then videolist throws a 'serious software error'.

  • i also am finding that if i delete a video and then visit the url for the deleted video, the plugin still renders a page - that is mostly empty, instead of going to the site's homepage as tidypics does or to a 404 type page.

  • does anyone know why my attempt to over-ride the videolist 'object' page is not succeeding?
    i have copied the file 'videolist_item.php' to the directory 'mytheme->views->default->videolist->object->videolist_item.php'

    and i see that the file is listed as being active by the developer tools plugin -> inspect panel.
    however, when i make changes to that file, they do not show up in my test elgg installation.
    i have been using elgg_dumps and other changes.
    the caches are disabled and i am using 1.8.15.
    anyone? thanks

  • "are you kidding ?;-P you're an 'experienced developer' !;oO have you not browsed thru code" ~ i will study that ' videolist 'object' page stuff @here on my xampp. i also use (@my version) re-packaged videolist @1.8.13

  • works ok ;oO ~ C:\xampp\htdocs\Elgg_1_8_13\mod\nexgen_css_extend_x108\views\default\object\videolist_item.php - check your simpler 'typos kinda bugs'; that's all it's gotta be! wanna discuss your code gyrations? problem's cause cannot be too complex..

     

  • i made the changes directly to the videolist plugin and they have come through ok to the site.
    i have looked through the code, yes.. for some unknown reason, the changes do not effect the site.
    (i have over-ridden many other files in this way without a problem)

  • Hi guys, first time posting here. I just installed videolist plugin on my new host and I'm receiving fatal error warning. Can someone help me with this problem?

    Fatal Error.

    String could not be parsed as XML

    Exception Object
    (
    [message:protected] => String could not be parsed as XML
    [string:Exception:private] => exception 'Exception' with message 'String could not be parsed as XML' in /home/user/public_html/mod/videolist/lib/Videolist/Platform/Youtube.php:41
    Stack trace:
    #0 /home/user/public_html/mod/videolist/lib/Videolist/Platform/Youtube.php(41): SimpleXMLElement->__construct('')
    #1 /home/user/public_html/mod/videolist/actions/videolist/edit.php(50): Videolist_Platform_Youtube->getData(Array)
    #2 /home/user/public_html/engine/lib/actions.php(97): include('/home/user/...')
    #3 /home/user/public_html/engine/handlers/action_handler.php(20): action('videolist/edit')
    #4 {main}
    [code:protected] => 0
    [file:protected] => /home/user/public_html/mod/videolist/lib/Videolist/Platform/Youtube.php
    [line:protected] => 41
    [trace:Exception:private] => Array
    (
    [0] => Array
    (
    [file] => /home/user/public_html/mod/videolist/lib/Videolist/Platform/Youtube.php
    [line] => 41
    [function] => __construct
    [class] => SimpleXMLElement
    [type] => ->
    [args] => Array
    (
    [0] =>
    )

    )

    [1] => Array
    (
    [file] => /home/user/public_html/mod/videolist/actions/videolist/edit.php
    [line] => 50
    [function] => getData
    [class] => Videolist_Platform_Youtube
    [type] => ->
    [args] => Array
    (
    [0] => Array
    (
    [video_id] => cu6cMj6t27w
    )

    )

    )

    [2] => Array
    (
    [file] => /home/user/public_html/engine/lib/actions.php
    [line] => 97
    [args] => Array
    (
    [0] => /home/user/public_html/mod/videolist/actions/videolist/edit.php
    )

    [function] => include
    )

    [3] => Array
    (
    [file] => /home/user/public_html/engine/handlers/action_handler.php
    [line] => 20
    [function] => action
    [args] => Array
    (
    [0] => videolist/edit
    )

    )

    )

    [previous:Exception:private] =>
    )

  • did you receive that error message after adding a video from youtube to videolist?
    if so, what did you paste/copy into videolist? what is the url?

  • Thanks for the quick response ura soul! And yes I received error after adding (pasting) video url http://youtu.be/cu6cMj6t27w

  • Videolist just worked fine on my previous host. Maybe is something wronh with new host settings?

  • i just tested the url on my test site and the video was added successfully.

    there could possibly be an xml component missing from your server - though i do not know the exact requirements of videolist with regards to xml myself.

  • Thanks ura soul. I'll try to submit a ticket to my hosting provider.

  • i just analysed my elgg site using newrelic's detailed server analysis apps..
    the videolist thumbnail.php file comes up as one of the most inefficient on the site presently..
    for some reason the thumbnail file is triggering all the plugin initialisation procedures on the whole site.

    which obviously is unnecessary and slows the site's performance.

    here's a screenshot:
    image

  • HI, I'm having errors in the thumbnail images in the player : The pictures in the profile can not be shown, are broken .

    I set chmod 755 to : /home/user/www/mod/videolist/thumbnail.php but same error . 

    Please, can help-me ? Im using facebook_theme .

    the rest is all ok.

    Thank You!

  • Hello, My problems was solved with correct permission on the paste and all files .

    Now ,. image can be show .

    Thanks :)

  • Getting error when youtu.be url is posted???

  • @latrevino This issue is solved with the most recent release:

    http://community.elgg.org/plugins/814895/1.8/videolist

sem

Lorea Developer

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 6552
  • Recommendations: 41

Other Projects

View sem's plugins