[Elgg 1.8-1.12 & 2.X: Elggx Userpoints] v1.9.7

Release Notes

Changelog:

  • Updated version 1.8.7 for Elgg 1.9 (Fixed awarding of points on starting a new group discussion topic and replying in a group discussion taking into account the new implementation used on Elgg 1.9 for group discussion replies starting with a PR merged today on github).
  • I tested this on the current Elgg 1.9 version and it complains:

    WARNING: Deprecated in 1.9: elgg_version in manifest.xml files is deprecated. Use elgg_release Called from [#24] /home/aivokemi/public_html/elgg/engine/classes/ElggPlugin.php:613
  • @Darth Vader: are you sure that this deprecation warning is caused by the Userponts plugin? I don't see such a message to appear on my Elgg 1.9 test installation. If it is indeed caused by the Userpoints plugin what are you doing exactly for the warning to appear (e.g. enable/disabling plugin, login it, change plugin settings or something else)?

    Do you have any other plugin installed that has

    <requires>
        <type>elgg_version</type>
        <version>..some Elgg version......</version>
    </requires>

    in its manifest.xml? Then this plugin would cause the warning as it needs to be "elgg_release" instad of "elgg_version" on Elgg 1.9.

  • sorry, I had a mistake. It's working well.

Stats

  • Category: Misc
  • License: GNU General Public License (GPL) version 2
  • Updated: 2019-4-7
  • Downloads: 12751
  • Recommendations: 50

Other Projects

View iionly's plugins