[Elgg 1.8-1.12 & 2.X: Login required] v1.8.6

Release Notes

  • Fix in loginrequired_index() function parameter name to match variable name later used (though this error shouldn't have mattered as the loginrequired index page should be served with highest priority anyway),
  • The pages allowed to be visited when logged out by default by the Loginrequired plugin now include all pages also defined as public pages by Elgg's walled_garden mode (almost all apart from some specific pages were already included anyway),
  • Some minor code cleanup.
  • Hi @iionly, I´ve upgraded to 1.8.6 version, and it seens to conflict whith the plugin:

    https://community.elgg.org/plugins/384520/2.1/analytics-plugin

    When an user login, is redirected to this url: analytics/ajax_success, and this text appears in the browser:

    _gaq.push(['_trackPageview', '/action/login/succes']);

    You can test it here. Credentials: test - 123456

    Any suggestion to solve this issue?, I´ve moved the Analitycs plugin over and under Loginrequired but problem persist. 

    As ever, thank you for your great work.

  • Hello to all, is it possible to include the register form in this plugin and make a index page similar to Facebook index page.

     

    Thanks to all

  • Hello iionly, great plugin by the way thank you, can you help me with this, in the register form when the new user is filling it elgg validate the username and email in the database the plugin gives an error 'User authenthication Required' i, ve tried to put 'vendors/.*' to addpages but no deal. Can you help me, im using elgg 1.8.16. Thanks and sorry for the trouble.

  • @LinuxT Are you using any 3rd party plugins that alter the registration process? For example allowing registering an account using external account credentials (Facebook, Twitter etc.) or maybe the Profile Manager plugin (as far as I know this plugin offers some validation functionality on account registering at least in later versions - not sure if also on Elgg 1.8).

    Without using any such additional plugin(s) the registering / validation of new accounts should work with the Loginrequired plugin on Elgg 1.8 without any issues. But if you use any additional plugin that modifies the registration process it might fail due to this plugin(s). At least I would need to know what plugins you are using (if any) to be able to tell you what you might have to add to the array of allowed pages for the account registering to work also with these additional plugin(s) because I would have to take a look at the code first.

Stats

  • Category: Misc
  • License: GNU General Public License (GPL) version 2
  • Updated: 2016-12-11
  • Downloads: 8004
  • Recommendations: 26

Other Projects

View iionly's plugins