Release Notes

Fixed the 'more' menu drop-down problem in IE.

Fixed some random errors. Things I noticed from seeing other people use this theme on their sites.

I've written a tutorial on how to change the main image and customise the colour scheme: http://www.jubo.co.uk/blog/2011/10/easy-theme-tutorial/

Elgg 1.8.1b:

1] How to fix the issue with Sprites/icons in 'Search'.  Open 'mod/easytheme/views default/search/css.php'.  Go to line 32 and change -718px to -934px. Go to Line 36 and change -700px to -916px.

2] If you are finding that the main white content area doesn't 'stick' to the footer... Open 'easy.php' (css file), find class '.elgg-main', and try adding line 'min-height:500px;' and see if it fixes your problem. (note: you may need something larger than 500px, find the value that works for you.)

  • Beautiful work - very well done.  Works great in the ancient IE7 standard that my company uses right now.

  • Hi,

    Unfortunately there was a mistake in the original .txt file. However, there's a new tutorial at http://www.jubo.co.uk/blog/2011/10/easy-theme-tutorial/ that tells you how to use a smaller image, and what to change to make it work.

    I hope these instructions work better for you?

     

  • Jubo thank you so much for this i'm so happy, my site actually looks like it should now.

    My css knowlegde is none and your walk through couldnt be easier

    I will play with your slider version soon.

    I would love to get rid of the elgg images/links and/or replace them with mine any help please

    again thank you so much my site looks great.

    Wayne

  • @waynaldo It's good to hear that you're finding the theme useful and easy to customise.

    To remove/replace the 'powered by elgg' graphic:  Edit, 'mod/easytheme/views/default/page/elements/footer.php'

     

  • Hi,

    i serach it ;) but i have trouble :( - I have elgg 1.8.0.1 - i activate theme. and when i go to my site first time i don't have this defetault logo from this theme :/ but when i login to my account i get it :/. Site is load succesful so i don;t know what is the trouble :/ 

    I want add - i have that trouble with all theme's. Logo don't want load when i go first time to my site, only when i login :/. 

  • i have another how to question

    i changed the favicon in elgg 1.81b

    and i think it causes a deprecating error message.

    is there a way to do this via your plugin?

    thanks

    wayne

  • There is... 

    1] put your favicon.ico file in 'mod/easytheme/img'

    2] create a file 'shortcut_icon.php'

    3] Put this in the file:

    <link rel="SHORTCUT ICON" href="<?php echo $vars['url']; ?>mod/easytheme/img/favicon.ico" />

    4] Save the file in 'mod/easytheme/views/default/page/elements/'

  • @Maciej I don't think that is caused by the theme. Sorry I can't help.

  • Hi jubo i hope things are going well for you.

    i need a little advice on how to add more information to the site name, i would like to (Under the site name) bullet point a list of site functions or just add a little write up. i have tried to work it out for myself but failed.

    Thanks

    Wayne

  • Hi Wayne,

    You need to open the file: 'mod/easytheme/views/default/page/elements/header_logo.php'

    The code that is in <h1> tags is the site name...

    Add something like this after it: 

    <div style="margin-top:30px; padding:10px;">

    <ul>

    <li>one</li>

    <li>two</li>

    <li>three</li>

    </ul>

    </div>

  • This is awesome! I wanted a simple theme with the pages I could customise to create my own look and this was super easy to use. I only have one question, it moved the "powered by elgg" to the left side of the footer, how do I get it back to the right side?

  • Hi Jason,

    find '.mts' in 'mod/easytheme/views/default/easytheme/css.php' and change it to this:

    .mts {padding-right:10px;}

     

     

  • Thanks for the quick response, that is what it says so I must have another conflict with something else. Overall, I love this plug in!

  • No, the problem is with the theme, I just didn't give you the right answer there (sorry).

    Something changed in the css when they released 1.8.1 and I've already fixed it on my copy of theme, but I didn't keep a full note of what I did.

    I think you can solve the problem by just changing this line in 'mod/easytheme/views/default/page/elements/footer.php':

    echo '<div class="mts clearfloat right ">'; 

    to... echo '<div class="mts clearfloat float-alt">';

  • Thank You, that fixed it!

    I highly recommend this plug in. It is perfect for people like me who only know basic code. I don't know enough to make my own theme so I used to hack the elgg core code and make the site look like I wanted. But I had to hack again after every update. This plugin creates a basic theme with great instructions so the people like me who only know enough code to be dangerous can edit the theme and have a great looking site without having to hack elgg core. And you provide awesome feedback!

  • Thanks for the recommendation :) 

  • Can you edit the background color of the content areas with this?

  • No. Just the background, header, sidebar and footer.

    by the way, if you are going to use Easy Theme you should download version 1.3.4

  • ok thanks. I really want to edit the content areas though. I am so sick of white backgrounds on social networks.

    It's a pet peeve of mine :P

Stats

  • Category: Themes
  • License: GNU General Public License (GPL) version 2
  • Updated: 2018-1-10
  • Downloads: 11822
  • Recommendations: 39

Other Projects

View juBo's plugins