Release Notes

2.1.1 (2013-04-05):
 

  • fixed: https support in multi-core situations
  • fixed: spelling errors in Dutch translation
  • fixed: issue with $DB_QUERY_CACHE disabled
  • fixed: HTML language in Digest body
  • Thank you the author for releaing this plugin.

    In daily site digest I have "friend activity". If someone has implemented new discussions in all open groups (member or not) and new blogs, willing to share it?

     

  • @Den Site digest already show new blogs and new groups. Already there1 (But not new group discussions)

  • i activated digest maybe 10 days ago here. i was distracted and didn't think to monitor the output. i had tested digest months ago and then disabled it.

    the cron widget shows that the crons are being triggered. the digest stats panel shows that the digests are being triggered, yet only for 1 user and none are being sent.
    when i view mysite.com/digest/test/site/weekly - the mail format is incomplete and there is no logo/header and content of the email.. even though the plugin is correctly activated.

    the main site's upgrade process has been run since digest was activated and i have html_email_handler 2.5 activated.
    anyone know what i am missing or may be the cause of the broken digests?

  • there are no php error log entries for the digest preview page... just a broken page.. i continue

  • i have 4 cores on my server... and have left the core option at 1 in the digest settings, due to the comments in the admin panel..
    would setting this to 4 make a functional difference here?

  • i am moving through the code here, looking to debug and fix the issue.. 
    when i open digest/elements/site.php - i see that the file is empty of code.

    so i am not clear on how the site digest could possibly be created correctly.. i looked at the github version and it is the same.. any tips on how to resolve this are welcome!

     

  • That is strange because I can confirm that this plugin is indeed working fine on my server.

  • yes, i know others are able to use it ok. i also had it running ok some months ago.

  • @ura soul

    i have 4 cores on my server... and have left the core option at 1 in the digest settings, due to the comments in the admin panel..
    would setting this to 4 make a functional difference here?

    Multi core (so > 1) only affect the speed of sending the digest. If you have > 10.000 users you could increase this to make sure the last person doesn't get the digest several hours later than the first user.

    i am moving through the code here, looking to debug and fix the issue.. 
    when i open digest/elements/site.php - i see that the file is empty of code.

    so i am not clear on how the site digest could possibly be created correctly.. i looked at the github version and it is the same.. any tips on how to resolve this are welcome!

    All the content is an extension on the view you mentioned (look at the start.php) this makes it easier for other plugin developers to support Digest

    anyone know what i am missing or may be the cause of the broken digests?

    No other updates in since you last checked? Other plugins that break eighter output or cron?

  • ok... still no change here.

    All the content is an extension on the view you mentioned (look at the start.php) this makes it easier for other plugin developers to support Digest

    oh ok, i did look for lines that extend that view and didn't find them.. i will search again.

    No other updates in since you last checked? Other plugins that break eighter output or cron?

    i am using this latest version of the plugin code and have disabled my theme to test digest.. which made no change. as far as i am aware, cron is running ok. i will go more deeply into this later today and disable most/all other plugins.

  • Hi Jerome,

    I have set cron to daily, and Digest setting to Forthnightly/Thursday.

    It sends greatly on Thursday, but sends a digest every hour the whole day.

    I use cron hour for another plugin, but have deleted that to test, if it stops sending every hour. But it doesn't.

    Do you know how I can manage this problem? Or is it a server problem?

    Best regards

    Kenneth

  • @TheMuller

    I have set cron to daily, and Digest setting to Forthnightly/Thursday.

    It sends greatly on Thursday, but sends a digest every hour the whole day.

    I use cron hour for another plugin, but have deleted that to test, if it stops sending every hour. But it doesn't.

    Do you know how I can manage this problem? Or is it a server problem?

    Do you mean it sends the same digest on thursday to all the users every hour? Or just that some users receive it on different times of the day?

    Depending on how large your site is it can take a while for the digest to process.

    If you wish to know if you configured the crons correctly check out the plugin cron check, if you made a mistake and configured the daily cron to run every hour ;) fun times!!

  • @Michele

    quick question, is V3 on github ready for production 1.9.8 site? I'm trying to use it but have some issues so don't kno if my problem or incomplete github version.

    v3 is still in development, i think it should work, but don't try it on a production site ;)

  • any update on a version of this for 1.9-1.12?

  • Yeah I'm wondering if it's ok for 1.9+? I turned it off due to my emails going to spam folder but that's not an issue anymore.

  • @ura soul

    any update on a version of this for 1.9-1.12?

    The master branch in GitHub should be compatible with 1.9+, but this hasn't been tested very well. So please be carefull.

    @Cim

    Yeah I'm wondering if it's ok for 1.9+? I turned it off due to my emails going to spam folder but that's not an issue anymore.

    @ura soul

    no ETA on this? ;)

    No, very busy with clients and none wanted this plugin (yet)

  • i have now tested this on elgg 1.12.4 and although no errors were raised, i also didn't receive any emails from the digest process. when i view the digest stats page, i see that all the entries look ok except that the 'mails sent' value is zero. any idea what might cause that?

    i have tested the emails from my test server by requesting a new password for my account and that has been sent to me ok.

  • @ura soul same to me since 1.9.x: when you are logged out (and so it is with crontab), it doesn't send any mail. I already opened an issue on github: https://github.com/ColdTrick/digest/issues/26#issuecomment-113272172

  • Hello Jerome,

    are you planning to upgrade your Digest plugin to elgg 2.0 - meaning using the zend mail environment (maybe instead of HTML email handler - or maybe upgrade HTML email handler to Zend)?

    Would be awesome.

    An idea for a feature request: adding Digest as notification method - meaning when Digest is selected, notifications are collected and get sent to the user in the next Digest. This would reduce the amount of often uncontrolable notification emails.

    Cheers,

    Reklov

  • Hello again :-)

    I realized that HTML email handler plugin will still be necessary, as zend mail does not do all the necessary jobs. Anyhow, I added some lines to HTML email handler to send through zend mail which works fine for me (I need to send the digests via SMTP).

    Cheers,

    Reklov

     

Jerome Bakker

Developer @ ColdTrick IT Solutions

Stats

  • Category: Communication
  • License: GNU General Public License (GPL) version 2
  • Updated: 2019-3-20
  • Downloads: 3824
  • Recommendations: 22

Other Projects

View Jerome Bakker's plugins