[Elgg 1.8: German Language Pack] vr1

Release Notes

r1 (Elgg 1.8.0.1):

  • Updated German language files corresponding to version 1.8.0.1 of Elgg,
  • Fixed some spelling errors and some inconsistency in used German terms,
  • Changes in main language file, in installation language file and in language files of categories, embed, likes, search, twitter_api and uservalidationbyemail plugins.

------

I've tried to proof-read the language pack as best as possible, but most likely I missed a few errors. If you come across any errors, please tell me. Feedback always welcome!

----------

Ich habe zwar versucht, die Übersetzungen im Sprachpaket so gut wie möglich Korrektur zu lesen, aber aller Wahrscheinlichkeit nach habe ich Fehler übersehen. Falls Ihr Fehler findet, wäre ich sehr froh, wenn Ihr sie mir mitteilen könntet. Feedback ist gewünscht!

  • @iionly perfekt! ganz grosses dankeschön :-)

  • Hallo , hab mir das plugin runtergeladen und installiert . es lauft ganz gut nur leider hat man nach einiger zeit das prob. das man keine bilder mehr angezeigt bekommt :(  wenn ich die spache auf englisch umstell sind die bilder wieder da ! ???  was kann das sein ?

  • @youreface: Das ist wirklich eine seltsame Geschichte und ich kann mir momentan auch nicht erklären, wie das passieren sollte. Das Umstellen der Sprache löscht wahrscheinlich den Seiten-Cache / Browser-Cache, d.h. die Seiten werden im Cache neu erstellt und dann sind die Bilder wieder vorhanden. Aber ich kann mir keinen Reim darauf machen, was das mit den Sprachdateien zu tun haben sollte. Im Prinzip könnte das Neuerstellen des Caches bei der Sprachumstellung natürlich auch das Problem mit der Bilddarstellung lösen, wenn es von einem anderen Plugin hervorgerufen wurde.

    Hast Du irgendeine der Sprachdateien verändert - oder auch nur mal in einem Editor neu gespeichert? Die Zeichencodierung der Sprachdateien ist UTF. Falls die Codierung einer Datei durch ein Speichern verändert wurde, könnte das u.U. zu einem Problem führen. Aber das ist das einzige, was ich mir vorstellen könnte.

    Wie lange ist denn die "nach einiger Zeit", nach der keine Bilder mehr angezeigt werden? Hast Du es mehrmals versucht, und das Problem ist wiederholt aufgetreten? Wenn Du die Sprache auf Englisch läßt, tritt das Problem auch nach längerer Zeit nicht auf?

    Welche Bilder werden nicht mehr dargestellt? Sind es Profilbilder, Icons/Bilder des Elgg-Themes, Bilddateien im Dateibereich, Bilder, die mit Tidypics hochgeladen wurden, oder alles zusammen? Verwendest Du das Default-Elgg-Theme oder ein anderes? Welche Version von Elgg 1.8 verwendest Du genau: Elgg 1.8.0.1 oder 1.8.1beta? Ich hab grad mal kurz geschaut, ob es in den Sprachdateien zwischen diesen Versionen Unterschiede gibt. Es gibt welche, aber selbst wenn ein Sprachstring nicht vorhanden sein sollte, sollte nichts passieren außer dass stattdessen der englische Text dargestellt wird.

  • ne geöffnet habe ich die sprachdateien nicht. wenn man die browser cache löscht dann sehe ich keine bilder mehr ..  wie gesagt aktualiesieren usw nützt auch nix ..  geht nur wenn ich auf englische sprache umstelle....  ich benutze nur das deutsch plugin und die facebook theme sonst nichts..

     

    lg

  • hab aber auch schon die faceb.theme abgeschaltet und probiert. immer noch das selbe.:(

    aso ! und wenn ich eine date hochlade kommt eine fehlermeldung das die datei nich geöffnet werden kann weil diese def.sei. Mit engl. einstelllung geht es mhhh ???

  • Ich hab grad mal das Facebook Theme in Elgg 1.8.1beta mit der Sprache auf deutsch ausprobiert. Ich habe etwa 10 Minuten wie wild zwischen verschiedenen Seiten gewechselt und habe nicht gemerkt, dass irgendwelche Bilder verschwinden. Was mir aber aufgefalllen ist: das Facebook Theme ist wohl nicht vollständig mit Elgg 1.8.1b kompatibel. Einerseits gibt es bei Anzeige der Index-Seite einen fatal PHP error und andererseits werden die Icons (z.B. Postfach) sehr seltsam dargestellt. Das liegt aber wohl daran, dass diese Icons in Elgg 1.8.1b im Vergleich zu Elgg 1.8.0.1 geändert wurden und das Facebook Theme da wohl noch nicht angepaßt wurde.

    Nochmal die Frage: welche Bilder werden nicht mehr dargestellt, welche Elgg-Version verwendest Du genau und wie lange bracht es, bis die Bilder verschwinden?

    Verschwinden die Bilder auch, wenn das Facebook Theme deaktiviert ist? Verschwinden die Bilder bei deutscher Sprache sofort, wenn Du das Caching in Elgg (Simple Cache und Filepath Cache) in den erweiterten Seiteneinstellungen deaktiviert hast? Wenn es wirklich an den deutschen Sprachdateien liegt, sollte das der Fall sein, da ohne Cache die Seiten bei Aufruf erzeugt werden. Oder falls sie nicht sofort verschwinden, solltest Du eventuell das Problem eingrenzen können, falls sie erst bei Aufrufen einer bestimmten Seite verschwinden - dann gäbe es wohl ein Problem mit einem Sprachtag, das speziell auf dieser Seite vorkommt, beispielsweise in einer Plugin-Sprachdatei.

  • Nachdem ich Deine letzten Kommentare gelesen habe (leider habe ich sie erst nach Aktualisierung der Seite gesehen, nachdem ich meinen letzten Kommentar schon geschrieben hatte... und dann kam auch noch die Downtime der Elgg-Community-Seite), schließe ich, dass Du Dich auf die Bilder beziehst, die mit dem Tidypics-Plugin hochgeladen wurden bzw. das Hochladen mit diesem Plugin selbst.

    1. Grundsätzlich ist das Tidypics-Plugin noch nicht vollständig kompatibel mit Elgg 1.8. Es können also Probleme auftreten (Ich komme beispielsweise nicht auf die Einstellungsseiten des Plugins sondern sehe nur eine Fehlermeldung).
    2. Im speziellen ist der Flash-Uploader grundsätzlich noch fehlerhaft (auch unter Elgg 1.7). Manchmal funktioniert der Upload, manchmal nicht - bei mir z.B. unabhängig von der eingestellten Sprache zumindest unter Firefox gar nicht. Du kannst es stattdessen mal mit dem Basic Uploader versuchen.
    3. Noch spezieller: die Sprachdatei... Das Tidypics-Plugin enthält seine eigene deutsche Sprachdatei (mod/tidypics/languages/de.php). Diese ist nicht von mir! Ausserdem ist sie meines Wissens nicht komplett und veraltet. Die deutschen Übersetzungen, die Du im Zusammenhang mit den Bildern bei Tidypics angezeigt bekommst, sind aus dieser Sprachdatei und nicht aus meinem Plugin (ich hab zwar in meinem separaten Non-Core-Plugins-Sprachpaket eine Übersetzung für Tidypics 1.6.8 drin, die etwas neuer als die Originale von Tidypics sein sollte, aber auch die ist nicht mehr auf dem Tidypics 1.7.X-Stand). Du kannst mal testhalber die deutsche Sprachdatei des Tidypics-Plugins löschen, während der Rest der Seite weiter auf deutsch eingestellt ist. Tritt das Problem dann immer noch auf? Falls ja, bekommst Du dann vielleicht zumindest auch eine (engl.) Fehlermeldung von Tidypics, die besser auf die Ursache des Problems schließen läßt.

Stats

  • Category: Language packs
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-2-12
  • Downloads: 10974
  • Recommendations: 26

Other Projects

View iionly's plugins