Facebook Theme v1.4

Release Notes

Following improvements

  • Composer works again for Elgg 1.8.3
  • Shouldn't get any more "Fatal error: headers already sent" type errors.
  • Can unlike entities again
  • No more "deprecated" errors about getIcon function.
  • Only compatible with Elgg 1.8.3+.
  • Hi Evan...nice job

    I still have a "Fatal error: headers already sent" when posting on groups wall...

    This is a @sequan fix:

    In /mod/facebook_theme/views/default/messageboard/composer.php

    The last line

    echo elgg_view_form('messageboard/add', array(), $vars);

    I changed it to  

    elgg_view_form('messageboard/add'array('name' => 'elgg-messageboard'));

     

    i don't know if this is the right way to fix that issue, but for now it seems to work

  • Good job!

    But I got the same error: "Fatal error: headers already sent".

    I`m a beginner, so it is over my knowledge to fix it. If you can do that go for it, please.

    Respect!

     

  • fasendores your fix do not work to me.

  • fasendores fix does work.. just do not forget to type "echo"before"elgg_view_form('messageboard/add'array('name' => 'elgg-messageboard'));"

  • I was trying to add comments to the message boards posts (or the walls) using the HypeAlive plugin to make it more Facebook like and it worked for me after a small modification.

    If you have the HypeAlive plugin, go to hypeAlive/views/default/river/elements/responses.php and replace

    "if ($item->annotation_id != 0 || !$object) {"

    with 

    "if (($item->annotation_id != 0 && $item->action_type != 'messageboard') || !$object) {"

     

  • Hi Ahmed...i also use th hypealive plugin, but the real-time search suggestions does not seems to work...do you have any idea on how to fix that issue?

    thanks

  • It works with me without any modification, maybe you have to change the priority of the plugin in the administration..

    In my settings HypeAlive plugin overrides the Facebook plugin

  • when u post a comment on wall

    1. it will refresh the entire page and then it shows the comment, also while refreshing the entire page as to be disappear and then appear, 

    2. Actually while you post message in facebook , page will not disappear for refreshing or goes blank,

    Messages are instantaneously posted, how to make that behaviour of messaging instataneous? without whole page refresh and then message appearence.?

    I understand only for the sub comments on the allready posted comments using hype alive is solving it and ok, but even when enabling hype alive when u post a new message first time on top using message board whole page as to be refreshed going blank and then message as to be appeared, 

    Cant it made instantaneous post as well? :) dont know how hard it is though :)

  •  

    It works with me without any modification, maybe you have to change the priority of the plugin in the administration..

    In my settings HypeAlive plugin overrides the Facebook plugin

    @Ahmed, i have enbled all the hypeAlive options...and also put hypeFramework in first place of the plugin list and hypeAlvie in second place...but the real-time search does not work...any suggestion?

    ps. if i disable the facebook theme, the live search work (with the default elgg theme)

    thanks

     

  • How I can hide the management option when the logged user is not the administrator? Thanks

  • Sorry Ahmed, but even after i did the right modification, doen't work on my site.

    I got this message:

    Fatal Error.

    Redirect could not be issued due to headers already being sent. Halting execution for security. Search http://docs.elgg.org/ for more information.

    SecurityException Object
    (
    [message:protected] => Redirect could not be issued due to headers already being sent. Halting execution for security. Search http://docs.elgg.org/ for more information.
    [string:Exception:private] => exception 'SecurityException' with message 'Redirect could not be issued due to headers already being sent. Halting execution for security. Search http://docs.elgg.org/ for more information.' in C:\xampp\htdocs\sites\elgg\elgg-1.8.3\engine\lib\elgglib.php:151
    Stack trace:
    #0 C:\xampp\htdocs\sites\elgg\elgg-1.8.3\mod\facebook_theme\start.php(382): forward('dashboard')
    #1 [internal function]: facebook_theme_index_handler('index', 'system', true, NULL)
    #2 C:\xampp\htdocs\sites\elgg\elgg-1.8.3\engine\lib\elgglib.php(974): call_user_func_array('facebook_theme_...', Array)
    #3 C:\xampp\htdocs\sites\elgg\elgg-1.8.3\index.php(17): elgg_trigger_plugin_hook('index', 'system', NULL, false)
    #4 {main}
    [code:protected] => 0
    [file:protected] => C:\xampp\htdocs\sites\elgg\elgg-1.8.3\engine\lib\elgglib.php
    [line:protected] => 151
    [trace:Exception:private] => Array
    (
    [0] => Array
    (
    [file] => C:\xampp\htdocs\sites\elgg\elgg-1.8.3\mod\facebook_theme\start.php
    [line] => 382
    [function] => forward
    [args] => Array
    (
    [0] => dashboard
    )

    )

    [1] => Array
    (
    [function] => facebook_theme_index_handler
    [args] => Array
    (
    [0] => index
    [1] => system
    [2] => 1
    [3] =>
    )

    )

    [2] => Array
    (
    [file] => C:\xampp\htdocs\sites\elgg\elgg-1.8.3\engine\lib\elgglib.php
    [line] => 974
    [function] => call_user_func_array
    [args] => Array
    (
    [0] => facebook_theme_index_handler
    [1] => Array
    (
    [0] => index
    [1] => system
    [2] => 1
    [3] =>
    )

    )

    )

    [3] => Array
    (
    [file] => C:\xampp\htdocs\sites\elgg\elgg-1.8.3\index.php
    [line] => 17
    [function] => elgg_trigger_plugin_hook
    [args] => Array
    (
    [0] => index
    [1] => system
    [2] =>
    [3] =>
    )

    )

    )

    [previous:Exception:private] =>
    )

    Any sugestions?

    Respect!

  • @fasenderos try to put the hypeFramework and the hypeAlive plugin "under" the facebook theme plugin, that's how they will be able to override it

    @xini757 I am not sure of the reason, but it seems different from our problem, try to see C:\xampp\htdocs\sites\elgg\elgg-1.8.3\mod\facebook_theme\start.php(382) as it seems the problem started there?

    Are you using the 1.4 version of the plugin as well?


  • @Ahmed..thanks, now it works ;-)

  • @amed how to disable comment on comment in hype alive?

  • Hi to all...

    i'm using izap_video plugin...is there a way to add in the dashboard, user wall and group wall a Share Video (izap_video), after the Share: Status / File / Bookmarks / Page etc ??

    Thanks in advance

  • Ahmed I'm using the 1.4 version of the plugin. Now is just a simple "fatal error". I can't fix it

    although I made the change: ""echo elgg_view_form('messageboard/add'array('name' => 'elgg-messageboard'));"
    In your composer.php is the same:
    <?php
    //hack! Elgg engine should take care of this, or blog/save form should be coded better
    if (elgg_is_xhr() && isset($vars['entity_guid'])) {
    elgg_set_page_owner_guid($vars['entity_guid']);
    }
    echo elgg_view_form('messageboard/add', array('name'=>'elgg-messageboard'));




    Respect!
  • Hi everyone!

    I got this error:

    Fatal Error.

    Redirect could not be issued due to headers already being sent. Halting execution for security. Search http://docs.elgg.org/ for more information.

    Any sugestion?

    Respect!

  • @xini757

    explain exactly when you encounters that error

  • I get this error when I login, after that everything is ok.

  • You know, in the left up corner, near by sing "friends" is the site sign "elgg", when this sign "elgg" is pushed appear this error. when every other sign is pressed up is working normal.

    Thank you fasendores!

  • I don't know how to help you 'cause I can't reproduce that error... when I login or push the site sign "elgg" everything is ok...

    My fix remove the "Fatal Error" only when you post a comment on the Group's Wall..

    I hope that someone else has the same problem and can fix it for you...sorry

  • Hi everybody

    Thank you for the great theme, Evan and for suppoort and discussion, sure i'm facing the same problem:

    Redirect could not be issued due to headers already being sent. Halting execution for security. Search http://docs.elgg.org/ for more information.

    isntalling the same for elgg 1.8.3

    for now i think i will just comment the line 382 in start.php leaving the user in the same page, any help for this will be appreciated.

    thank you

  • Thank you anyway, fasendores.

    Respect!

  • Hi

    How can I updated that?

    Deprecated in 1.8: Please update your use of elgg_view_entity_list() Called from [#6] /home/public_html/engine/lib/users.php:513
  • i get a fatal error

    SecurityException:ForwardFailedToRedirect

    when i try to go to a users profile that is not a friend, i figured out that it seems to be directing non friends to the wall.php file and not the info.php the reason i know this is because when i try to go to a non friends profile i get this fatal error, but if i put the info after (example www.site.com/profile/usersname/info) then the page loads fine and it lets the non frienf view the profile info, but my problem is basicly non friends are being redirected to the wall page and not the info page.....help i cant seem to get it to change

     

Evan Winslow

Software Engineer at Google. Elgg enthusiast. I wrote the Javascript and CSS frameworks for 1.8.

Stats

  • Category: Themes
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 62842
  • Recommendations: 112

Other Projects

View Evan Winslow's plugins