[Elgg 1.7: Extended TinyMCE] vr9

Release Notes

Changelog:

  • Upgraded to version 3.4.7 of the TinyMCE editor.

Install instructions:

  1. Disable the Elgg core tinymce plugin and/or any other tinymce plugins,
  2. Replace the tinymce folder in your mod directory with this tinymce folder,
  3. Replace start.php of the htmlawed plugin with the start.php file in the htmlawed subfolder in this plugin. This version of htmlawed's start.php is a backport of Elgg 1.8 that works better for me - for example it also allowed different fonts to be used in postings.
  4. Enable the tinymce plugin again,
  5. Execute the upgrade.php script, i.e. call http://<yoursite.domain>/upgrade.php in your browser.
  • Thanks for this plug-in! My users were quite annoyed with the strange codes that pasting from MS Word left behind. The additional options to create richer HTML are very welcome too! :)

    I miss the "HTML" view button, though (I have lost the possiblity to fine-tune the HTML is I wnat to). Anyone can point me which configuration file should I modify to show that button? I am trying to find it on the documentation but it's a bit too rich and I don't want to become a tinymce expert!

    Thanks in advance!

  • @Alberto: I've configured the tinymce init for the HTML code button only being visible when logged in as admin. If you want all users to be able to edit their postings directly in html, you can change this configuration. In the file views/default/input/longtext.php in line 37 replace

    <?php if (isadminloggedin()){?>,|,code<?php }?>

    with

    ,|,code

    Then the html edit button will be visible for all users.

  • Hi guys,

    I downloaded few days ago this module, and Ive got a problem. I insert a video, directly with URL on the body. But then, sometimes it appears (the video window), sometimes I just can see URL link, and sometimes it cant see anything at all.

    Does anyone know what happens? Any help?

    And I would like to take the chance to ask you guys another doubt: Does anyone know if text editor is related with edit and remove buttons of Blogs and another kind of contents? I was modified the text editor (between several versions), and now I cant edit or remove my blog post and some contents else (unless Im login as Admin). Any help with this?

     

    Thank you so much ppl :)

  • @Nacho Duran:

    The Extended TinyMCE plugin does not deal with converting video urls to include any videos in postings. If you enter any url, you will only see this url as normal text after saving your posting (you can make it a clickable link with the Extended TinyMCE plugin but it will still not embed the video). I guess you are using another plugin that adds this functionality to embed videos (could it be this one: http://community.elgg.org/pg/plugins/project/787632/developer/RayJ/embed-extender ?). The reason why this works sometimes and somestimes not could be due to some bug in this plugin, or the embedding simply doesn't work for all videos from different websites. Also, Elgg's htmlawed plugin might filter out the embed code sometimes (if that's the reason it's rather the question why it doesn't filter the code out each time...). Please ask the developer of the video embed plugin to ask about this issue.

    The tinymce plugin (either the Extended TinyMCE plugin here, or Elgg's default tinymce plugin) is used for writing blog postings also. Whenever you see the tinymce text editor frame, the tinymce editor is used for writing text on your site. Though the reason why you can't edit or remove blog postings is hardly connected with the tinymce plugin. The editor is only used prior pressing the Post/Save/Publish button. Elgg itself deals with the access rights, for example private or friends etc. Depending on the access rights set you can perform certain actions on the content (reading/editing/deleting). If you can't edit or remove blog postings if you are not logged in as admin, I would say that something is wrong with the blog plugin. You haven't mentioned what version of Elgg you are using. Some version of Elgg 1.7 had a bug in the blog plugin. I don't know right know what version fixed this issue in blogs. Maybe upgrading your site helps, if you are not already using the latest Elgg 1.7 release.

  • Can I upload images with this editor?

  • @Delia: you can't upload images with this editor directly. But you can embed/upload images using Elgg's embed plugin (a link to access the embed/upload dialog will be visible above the editor area). These images will be added to the files section of your site. You can then select a newly uploaded image (or any of your other images) to be embedded in your posting. The other possibility directly included in the editor is to embed images (both on site images but also images hosted on other servers) by giving the URL of the image. This way you can also embed images uploaded previously with the tidypics plugin.

Stats

  • Category: Tools
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-5-15
  • Downloads: 7896
  • Recommendations: 14

Other Projects

View iionly's plugins