[Elgg 1.7: Extended TinyMCE]

Warning: This plugin has't been updated in over 4 years. It may no longer be maintained.

What you can do to help:

Upgraded and extended TinyMCE plugin

Last updated
Recommended Releases
Elgg Release Download Date Links
1.74.1.10 (340.21 kB)2015-May-15
Show all releases

This plugin is intended to replace the core TinyMCE plugin of Elgg 1.7. It includes the latest release of the underlying TinyMCE editor taken from http://tinymce.moxiecode.com/ and offers slightly more options than the default tinymce plugin.

You can configure the options that should be offered by the editor via /views/default/input/longtext.php. The available options are explained on http://tinymce.moxiecode.com.

Install instructions:

  1. Disable the Elgg core tinymce plugin and/or any other tinymce plugins,
  2. Replace the tinymce folder in your mod directory with this tinymce folder,
  3. Replace start.php of the htmlawed plugin with the start.php file in the htmlawed subfolder in this plugin. This version of htmlawed's start.php is a backport of Elgg 1.8 that works better for me - for example it also allowed different fonts to be used in postings.
  4. Enable the tinymce plugin again,
  5. Execute the upgrade.php script, i.e. call http:///upgrade.php in your browser.

Creating your own custom skin:

  1. Configure your custom skin at http://skin.tinymce.com/ and download it,
  2. Copy your skin folder into the tinymce/tinymce/js/tinymce/skins directory,
  3. Change the skin name of the skin option in tinymce/views/default/input/longtext.php to the name of your skin.

Stats

  • Category: Tools
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-5-15
  • Downloads: 7887
  • Recommendations: 14

Other Projects

View iionly's plugins