NoELab Media Embedly v1.4

Release Notes

Version 1.4 - Tested on Elgg 1.7.8/Firefox 4/ Chrome

  •   * Fixed edifice categories input in wrap function if is_plugin_enabled
  •   * Improved Media Library Widget on profile with media icon 
  •   * Fixed,Improved and Added jsSupport for Riverdashboard and Messageboard
  •   * Improved Media Library on river tabs
  •   * Improved languages items
  •   * Improved css
  •   * Added group media widget
  •   * Added support for noelab_media_embedly >>> read NOTES in readme
  •   * Added Media Sharing

ElggFiles overwrited: riverdashboard/nav.php && widgets/messageboard/view.php

  • if you find bugs, please post your elgg version and your browser, optionally your site.

    happy elgging! 

  • This is an interesting alternative to iZap videos.  Would be great if someday we could embed in content posts.

  • Oops, forgot to say 'thanks for the contributions!" :)

  • OW!!! great.!!!

    I have to make some reparations for 1.7.1

    but now, works perfect!!!

    For 1.7.1: change the next lines.

    in start.php in the line 242

    $title = elgg_get_friendly_title($title);

    in 1.7.1 deletel "elgg_get_", :

    $title = friendly_title($title);

     

    in mod/noelab_media_embedly/views/default/object/media.php

    in the line 10. the same:

    $friendlytime = elgg_view_friendly_time($vars['entity']->time_created);

    have to be:

    $friendlytime = friendly_time($vars['entity']->time_created);

     


    I have another problem with my riverdashboard, I use a 3 columns river, anda with the modification of the nav.php, desconfigured my riverdashboard.

    To resolved it, copy the nav.php of your riverdashboard, and paste in the nav.php of the noelab, and put in the bootom of the nav.php the next:

     

    For me in 1.7.1, with this changes works PERFECT!!!

    Thanks, recomended!!

     


  • Are you able to manage thumbnail height and width for this version ........?

  • @bpreston Thanks!!!

    @gastre Thsnks for your help!!! If you find other changes for 1.7.1, I will put them integrated in the next version to do this plugin all 1.7 compatible. In many cases, new incompatible functions are fixed cutting elgg_ as prefix. 

    For riverdashboard, I added a jssupport. In Readme file there are notes that explain how  simple is to add the script that calls the js to support this plugin. (for now this is a workaround to fix tabs issue) 

    @ghumanz I see that now a lot of people are interested in this plugin (near to 1000 download). In elgg 1.8 it will be more simple to do a more flexible layout and I promise I will do that. Thanks for your feedback!!! for now you can joke with css file. try to add to img class, width and height instead of maxwidth and maxheight to see how they change.

  • @ghumanz what about other issues you said before? still problems?

  • First of all thanks for some new features and some improved layouts.

    Here are some bugs which I found in this version.

    1) As you say by css width and height is controled but only for river updates not for other media.
    2) Do not show any previously added on the fly media in blogs. (Important)
    3) If we add new on the fly media it show for two times and not playing in IE 8,9 both. (Important)

    4) if we add any media to cattergory , then no cattergory is shown under admin block.(Important)

    Already fixed contents:-



    1) Tabbed issue is fixed I am on 1.7.8 and using 3 column riverdashboard no file replaced by default it works well for me .

    2) add media on the fly url not shown now but as I mention above the media icon is showing twice.

    3) river updates are awesome and with large icons along with play button .

    4) profile widget is showing correct icons now.

    5) Group widget is added and showing well but not found any css to change from right to left in groups.

     To do list for more attractive video layout:-

    1)  is that possible to show latest media in grid view?

    2) related video option on right side under video discription only 5-6 videos.

    3) As you mention you are going to add a media slider but I think it will made this plugin heavy and slow because it need more js .

     

    I will add more things if I found any think else. still testing this plugin.

  • One more think I forget to mention is move tool which you already know show only 10 grous instead of all groups...

  • @ghumaz 1. about layout if i have time, i will improve it in different way

     

    2.blog doesn't use url output layout by default in riverdashboard. in blog comments it works for me

     

    3. 2 times? try to upgrade elgg, or to delete plugin and reinstall. can you give a link to see?

     

    4. IE is stupid. i can't test it for now. it doesn't run on my pc.:-(

     

    5. category i will see 

     

    6. group widget on left, find the line in start.php and change it to left

     

    7. grid view i will do something creative

     

    8. related if someone share a patch i will add it for now

     

    9. slider in option enabled yes or no   

     

    10. tool move, it is a bug of input form by elgg, also move disussion by cash has the same problem

  • Thanks Lord for replying try to use the coding from izap video for relative videos , i think it help you and look on msn videos for layout , those are too attractive for visitors

  • It's nice and easy.

    Version 1.3 embedded the video player into a blog post or page, while this version seems to only provide a link rather than an embedded player.

    How do I embed the video player into pages?

    Thanks,

     

    Lee.

  • @ Lee Just paste the url into pages or blogs it automatically embed player

  • Hello ghumanz,

    I tried that. I get a small thumbnail that when clicked expands to a bigger image, not a player.

    Elgg. 1.7.8 on EI9, Firefox 4, Chrome 11.0.696.71 and Maxthon 3

     image

     

    When expanded:

     

    image

    Chrome, Firefox and Maxthon behave in the same way.

    Any thoughts?

    Thanks,

     

    Lee.

  • Also, the image properties show the image as hqdefault.jpg

  • @lee did you run upgrade.php? seems that js doesn't work well

     

  • Hello lord,

    Yes, I ran upgrade.php and disabled/enabled the plugin several times. I even cleared browser history, cookies, the lot.

     

  • This is what Chrome's element inspector displays:

    <div class="blog_post_body"> <!-- display the actual blog post --> <p>

    <div class="embed">

    <img src="http://i.ytimg.com/vi/MY YOUTUBE VIDEO/hqdefault.jpg" class="thumb"><a href="http://youtu.be/MY YOUTUBE VIDEO">How to write a homework blog (Pre-intermediate)</a><a href="http://youtube.com" class="provider">YouTube</a> - This video shows you how to write a homework blog.</div><div class="clearfloat" style="margin:5px 0 0 20px;">

    </div>

    <a class="embed-thumbnail" href="#"><img src="http://i.ytimg.com/vi/MY YOUTUBE VIDEO/hqdefault.jpg"><img class="embed-PlayButton" src="http://localhost/elgg/mod/noelab_media_embedly/graphics/play-button-1.png" height="30" width="30" border"0"=""></a>

    <div class="infoembedly"><a href="http://www.youtube.com/watch?v=MY YOUTUBE VIDEO">How to write a homework blog (Pre-intermediate)</a><p>via YouTube</p>

    </div>

    <div class="clearfloat"></div>

    </p> </div>

  • is it the same also with google video, vimeo video, metacafe, and so long urls?

  • Hello lord.

    For some wierd reason it's only the videos I posted myself to Youtube that don't work. Other Youtube videos work fine. I'm using the short URL's from youtube, so I'm not sure why the long URL is showing in the code and not embedding.

     

  • there is a check to recognize the right urls from supported services, ex. you can post www.wikipedia.it/lee in right way , but it can not recognize it.wikipedia/lee ... the same url in another language.

    better to use original urls. for others you have to try

  • For me it works only IE 8 and 9 are showing player with black screen , right now I am testing this plugin on localhost not in production yet. I will try to improve it before using it on production site.

  • An update.

    I tried blip.tv. Adding the links to the media page works, and they show on the river dashboard but not when pasted into blogs and pages. With blip.tv the text link is only visible in blogs and pages.

  • Still struggling. Back to youtube. I've changed the format from avi to mpg, but still, only MY uploads don't work. I've made them private and public; tried short links and long links resulting in jpg images rather than the player. I don't think it's the plugin, but something else. Any ideas?

  • @lee try to see before if the link is supported by service here:

    http://embed.ly/docs/explore/preview

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 6243
  • Recommendations: 25

Other Projects

View lord55's plugins