Facebook Connect for 1.7.3 v1.7.3

  • I have also the Error "The field form is lost or __ts __token"

    any idea would be nice :-)

  • Please tell us how to run a cron to sync updates. sorry I am new to for all these things :)

  • For the people who are using this plugin - Are your members Facebook profile images being updated?  I'm still having an issue getting them to sync.  Any help would be greatly appreciated.

  • no survtime my members Facebook profile images aint been updated too i also want to know where to do the cron too? this would be big help!
     

  • Should crontrigger plugin be sufficient for a cron?

  • I am running elgg 1.7.4 with this plugin, it seems fine to me... you can give it a go if you like at http://community.activityseeker.com

    But in any case, set cron up in you CPanel from the cron icon using:

    wget --output-document=/dev/null http://yourdomain.com/pg/cron/hourly

    and you'll be set up.  

    (change the yourdomain.com for youe domain name)

  • Alright finally! The cron is working.  unfortunately it did not update the profile pics, is there any chance that I have another plugin conflicting with it?  Anyway, thanks for all the help with the cron job.

  • In start.php from about line 300 through to 324 change all of the "$user->username" to "$user->guid"

    e.g.

    $filehandler->setFilename("profile/" . $user->username . "master.jpg");

    becomes

    $filehandler->setFilename("profile/" . $user->guid . "master.jpg");

  • You should update the install instructions. I was banging my head against the wall trying to figure out where the Connect URL field is.  Apparently it is under the "Web Site" tab under Edit Settings and just says Site URL, now.

    @hash:  Where do you see 300+ lines in the start.php file? Mine only has 113 lines and none of the entries you mention.

  • I think @hash is looking at another version of this plugin, but the code he refers to is not in start.php, but in mod/fbconnect/model.php.  Anyway, I asked Kevin (the developer) about the comments by @hash and he gives the following advice:

    "I think that this is a difference between Elgg 1.6.x and Elgg 1.7.x.

    The change you mentioned would be good for Elgg 1.7.x.

    The current system would work for Elgg 1.6.x *and* Elgg 1.7.x I think.
    However, there might be problems if, for example, a user started with Elgg 1.6.x and then upgraded to Elgg 1.7.x. In that case, they might end up being served the wrong icons.

    The ideal fix would check the version number and for Elgg 1.7.0 and above, use the new code."

    I hope this helps... and if anyone wants to provide me with a fully updated version using "$user->guid" then I'll post it here as an alternative version.

  • I'm using 1.7.1.  Tried changing $user->username entries to $user->guid with no luck.  I can login with my facebook account but that's it.  No profile picture and no status updates.

    Any more ideas?

  • Ah, my bad, I was indeed using another version, same original authors, and the profile pic code is almost identical. That change should work for new users, I'm not sure about existing users yet, but will know soon enough.

  • I must be a glutton for punishment because I'm still trying to get this to work.  I can logon with a facebook account no problems but i get an error everytime...

    "Sorry there was a problem uploading your profile picture."

    The status does not update either.

    When I run pg/cron/hourly/ by manually putting it in the browser bar it says...

    "Synced 0 Facebook accounts."

     

    Any ideas?

     

     

  • @hash - This solution works with new members, thank you so much.  This has been driving me crazy for over a month! 

    $filehandler->setFilename("profile/" . $user->guid . "master.jpg");

  • Since implementing @hash's solution, my members profile pictures have slowing been updating from their Facebook accounts.  Which is great news. 

    As for status updates, none so far.  

    Thanks @hash

  • $filehandler->setFilename("profile/" . $user->guid . "master.jpg");

    Changing only that entry seems to work for me too.  Changing all of them as suggested caused problems.  Thanks.

    I also cannot get status updates.


  • @Daemonik are your status updates working?  What types of problems happened when you changed all of them?

  • When I changed all of the entries it created a member with no owner assigned and gave me an Invalid Parameter Error whenever the member was called from the database to a page.  I had to find the member guid # in the database and manually assign the member an owner using PhpmyAdmin, then delete the member using Elgg so my site would work again.  I don't suggest it.

    The plugin does not show status updates nor does it import the profile information fields.  Oddly enough, when I pull up the user list with the administration panel it shows the Location listed next to the user.

  • Has anyone noticed their members are not able to enable/disable Facebook profile synchronization in their settings page?  Some of my members want different profile pictures than posted in Facebook, but each time they change their icon on my site, their profiles are re-synced with Facebook.  Thanks!

  • How do you get it to redirect to your dashboard. Please help with this you can see it in action at www.LLLx2.com

  • Installed this on Elgg 1.7.6 easily enough

    1st account I created with FBConnect synced with facebook and pulled all profile and status updates fine just no picture.

    2nd account that was created only pulled in the users location and nothing else

    Running the cron job gives me ---> Synced 0 Facebook accounts.

    I have tried changing model.php with this fix ---> Tried changing $user->username entries to $user->guid with no luck 

    I have found that if a user who has connect to my elgg site with fbconnect goes to their settings page and clicks the no under the facebook setting to unsync their facebook account and click saves it still shows as yes sync my facebook account after the page loads. So a user cannot unsynce my elgg site from their facebook account.

    ----------------------------------------------

    Any ideas or suggestions on any of the above? 

  • Additional odd behavior

    After changing $user->username entries to $user->guid in model php it did seem like everything was working fine except that we tried adding a new user to my elgg site via FB connect. End user was able to sign up/in but was presented with a page of code.

    In Admin when I clicked on user admin or statistics I received an error that user guid 40 was not found. I had to run the repair DB utility that is found here on this site for such problems. It did not repair it until I reverted my model.php back to its original form.

    As of now my main issue is that there is zero sync between my site and facebook.

    Is there Anything I can try?

  • Possible ideas:

    Make it un-sync after first login so the users can edit their pages. Or have an Admin Option.

    I noticed it auto creates a username based off last name.. Maybe set it up so it will send a confirmation email to the users so their account can be fully active.

  • @Mark, I think I now understand Facebook connect, I THINK! This allows FB widgets to run on your site.

    I would like my members to be able to link their Elgg profile to their Facebook profile, while not having the same profile name or password, is this possible now?

     

     

Mark Bridges

Currently doing a bit of caving, surfing and developing my Rifle Club website

Stats

  • Category: Authentication
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 3415
  • Recommendations: 7