Elgg Notify v0.5

Release Notes

Well its been over a week since the first release and I am really excited to announce the next version. 

This release make it easier for developers to make their plugins give live notificiations as it now uses the elgg notification handlers. all users have to do it add a new parameter $live = "has written on your wall......   etc. 

take a look at the message board for example

notify_user($user->getGUID(), $_SESSION['user']->getGUID(), $subject = elgg_echo('messageboard:email:subject'), 

$message = sprintf(

elgg_echo('messageboard:email:body'),

$_SESSION['user']->name,

$message_content,

$CONFIG->wwwroot . "pg/messageboard/" . $user->username,

$_SESSION['user']->name,

$_SESSION['user']->getURL()

), 

$live = "has written on your message board <a href=\"". $CONFIG->wwwroot . "pg/messageboard/" . $user->username . "\"> click here to see it </a>"

); 

 

New features

  • Its a lot faster!
  • Now works with comments, no matter what plugin you are using
  • Disables site messages

Please make sure that this plugin is at the bottom of your plugin list.

 

  • Hello I wana add this plugin..i copied it to mod folder  but it didnt enable...t was miscinfigured.hw can i add this plugin?

  • Anyone getting the "live notifications could not work because the plugin has not been updated" error -

    this is because the plugin that is trying to send a notification does not give the necessary information for the live notifications system to work.

    Please refer to the link in my previous comment on this plugin for more information about integrating the live notification functions into your plugins

  • is there is any way to change the plugin direction

    mena in my template message is shown on right side

    i want notification will sho on left side is there is any whay

  • are you meaning the notification window, or the number icon?

  • i try to use this plugin.BUt i have a error

    * live notifications could not work because the plugin has not been updated *

    i'm using elgg 1.7.3

    anybody can help me this problem.

  • live notifications could not work because the plugin has not been updated ????????

  • por favor actualize esta versión a elgg 1.7

  • live notifications could not work because the plugin has not been updated

  • I use 1.7.4 ..how can I make this plugin to work . iget an error message...misconfigured plugin.

  • live notifications could not work because the plugin has not been updated

  • you get the error message "live notifications could not work because the plugin has not been updated" because the plugin still needs to be changed to add the new notification system's command into the plugin that is trying to use the default elgg notifications system. so if the friends request plugin was giving you the error you would need to edit the notifications command for : Request Friendship, Accept Friendship, Refuse Friendship Request, Remove friendship. I've given an example here.

     

     

    estoy usando traductor Google, lo siento si esto no tiene sentido;)

    recibe el mensaje de error "notificaciones en vivo no podía trabajar debido a que el plugin no se ha actualizado", porque el plugin todavía tiene que ser cambiado para añadir la orden del nuevo sistema de notificación de en el plugin que está tratando de usar el valor predeterminado elgg sistema de notificaciones. por lo que si la solicitud amigos plugin se te da el error que habría que editar el comando de las notificaciones para: Amistad solicitud, acepta la amistad, rechazar la solicitud de amistad, quitar la amistad.
    Le he dado un ejemplo aquí.

  • why do the notification does not appear when i send messagebox or anything? it seems that doesn't work :D

  • i found that no notifications were shared within the site for me on elgg 1.7.6

  • creo que sera grandioso una mejora a este plugin para elgg 1.7.6

  • tener notificaciones en vivo seria grandioso ya que aria mas adictiva la red social

  • Lotsa these great plugs not getting updated.

  • is there anyway someone can take over on this pligin or is it just lost forever?

  • ;-) 2 ways to help keep nice but forgotten plugins going and living -> find some developer who has enough spare time to devote to coding for $0 free or hire a $paid developer to enhance, improve and afterwards.. release the code back to the community as GPL'ed $0 free ;-) easy, ain't it ? There cannot be any more to emphasize or comment on how the general elgg users can help, encourage developers and thefore you keep up contributing to the community's benefits and overall help to make Elgg the Killler platform !

  • Hi,

    1.) There were problems with the live update, but solved it:

    /notifications/views/default/notifications/topbar.php


    Old line:
    $ ("count"). load ('<? php echo $ vars [' url '];?> mod / notifications / ajax / livenum.php ");

    New line:
    $ ("count"). load ('<? php echo $ vars [' url '];?> mod / notifications / ajax / livenum.php? random =' + Math.random ());

    and so on for all .load("");

    With this solution is perfectly updated.



    2.) The comments link did not work. Solution:

    /notifications/actions/comments/add.php


    Old line:
    $ live = "has commented on your blogpost \" $ entity-> title \ "<a href=\"$entity-> getURL \"> click here to see it </ a> "

    New line:

    $ live = "has commented on your blogpost {$ entity-> title} <a href={$_SERVER['HTTP_REFERER']}> click here to see it </ a>"

    Good luck. :)

    ps.: 1.7.1.

  • @$LL tu solucion no funciona en el archivo topbar hay dos lineas asi

     

     $("#count").load("<?php echo $vars['url']; ?>mod/notifications/ajax/livenum.php");

       var refreshId = setInterval(function() {

          $("#count").load("<?php echo $vars['url']; ?>mod/notifications/ajax/livenum.php");

       }, 9000);

    cual tengo que remplazar ya que e remplazado las dos pero el plugin sigue tirando el mismo error
  • I'm sorry but I have no time for 1.7.6.  :\
    I work a lot in 1.7.1.

    ps.:I forgot that On my side:
    Notifications are included in the header_contetns.php.

    Good luck.

    $łŁ
    elgg 1.7.1.

  • yo seguire investigando pero no logro solucionarlo

  • This will be updated for elgg 1.8 - please use 1.7.1 for the time being. 

    If anyone is desperate to use this then please message me and I can get it working for your site with as many plugins as you want for £200.00 - in the mean time you'll just have to wait until 1.8 is released

Mark Harding

elgg developer, iOS developer

Project Info

Stats

  • Category: Tools
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 4877
  • Recommendations: 12

Other Projects

View Mark Harding's plugins