Elgg Mobile v1.6

Release Notes

Changes in 1.6

- Bug fixes

- Users can switch between the mobile and desktop sites

- Resolved the message board issue

- Reply to wire now works.

 

Thanks to everyone for you bug reports/patches.

Installation

Extract into the mod folder. Enable in plugin tools and then run upgrade.php.

Does this work with your phone?

Please test this plugin on as many phones as possible and report if there where any bugs in it.

So far I have tested it on Android, iPhone, Blackberry and Nokia

Developers

Please make sure that you have create mobile views for your plugin - if not, they will not work with elgg mobile.

Dontations

The next release of this plug-in will involve the restructuring of the code to make it even faster. I have spoken to some very experienced developers who will contribute to this but they do require payment. In order to speed up the next release, please donate using the link above. Thankyou to everyone who has generously donated already!

Demo

http://maestrozone.com/mod/mobile to take a look at this plugin on a live site

  • Ok another Problem I found now this is an Issue with my CELL PHONE and a Brand or Model of Cell Phone that is NOT Compatible with this Plugin and also NOT Compatible with ELGG Period (even the full version is not working).

    Phone is:

    Brand: Samsung

    SCH-r350 Freeform™ (Metro PCS)



    This is a phone that is thru MetoPCS if that has anything to do with it also. It loads up the Front page fine but it will NOT Login once you put all your info Username and Password and Submit it will just re-fresh the very same front page all over again and it never gets past you are not able to login.

    If anyone knows about a Patch or an Update to this plugin to support this phone please message me on here ASAP this is very important that I have this phone working with my main site RapiChat.com thanks in advance.

  • can we change the logo and the copyright to suit our site?

  • Hello Mark,

    I am new to elgg and not a programmer.  I installed your plug_in and got it to work.  After logging in, the screen went to  HOME_PROFILE_FRIENDS with a blank white body. How do I "create mobile views for your plugin".  Which folder would I create them in? view/default/mobile - view/mobile.  Can you give an example of one of these selection.  I am an artist who visually understands how things works, however the documentation for elgg is limited to programmers. Can you help with layman's terms and visual reference. 

    Cheers

  • Can I change the logo and the copyright to suit our site? please explain I need it for my site which is ready to launch. I thing more is that possible to add chat in mobile version.

  • Any new updates to this plugin? Is anyone using it on a 1.7.1 (almost 1.7.2) Elgg site?

  • Exceeded maximum redirect attempts to server

    this is what i get

  • Hi,

    I'm using this on my Elgg 1.7.1 site, and after a lot of coding things look quite good.

    I have one problem though, the browser on Nokia N900 (Maemo) is not detected. Is this something that could be corrected?

    Regards

  • WORKS GREAT!!! YOU SAVED ME SOOOOO MUCH TIME!

  • Hi. I'm using v 1.7.1. on an iPhone 3G running OS4. I'm now having the same problem as Wetodid -- each of the nav links in the mobile site's header and footer elicit the error message about exceeding the maximum redirect attempts to server. The problem started only after I tried to log out—before that, the header nav links worked fine. The iPhone's browser actually seems to be alternating back and forth between two different urls until that error message appears. Looks like an otherwise great plugin though, and I'm very grateful for your work Mark.

  • Hi! I've installed OK, but when I tried submitting something on The Wire on my iPod Touch, it went back to the login screen? And also, I changed to the Full Site version and want to switch back but the link didn't work on my iPod Touch.

    Thanks. :)

  • worked first time - fantastic work!

    Newbrie

  • Blackberry curve 8530

    OperaMini

    Elgg 1.7.1

    All o.k, very nice plugin ........ but

    don't display correctly the national Characters (spanish and greek letter)

  • Hi,

    I'm running 1.7.1 and testing on an iPhone.

    The plugin is working well except for one thing.

    When I post anything to the wire, it doesn't post, and brings me back to the login screen.

    Also, when I click on the home link (the elgg toolbar at the top) it brings me to a page not found screen.

    I checked the url, and it was missing folders in the url.

    address should read mysite.com/f12/elgg/pg/dashboard

    but instead its going to mysite.com/pg/dashboard

    It gets the address correct on everything else (that I checked)

    I can make it so that my server will redirect the site url, but was wondering if there was something i can change in the plugin.

    Thanks for any help and great plugin!!

     

  • I found the problem with the toolbar linking wrong, the site url is hardcoded in the header_contents.php file.

    <a href="/pg/dashboard/"><img src="<?php echo $v
    ars['url']; ?>_graphics/elgg_toolbar_logo.gif" /></a>

    I changed it to

    <a
    href="<?php echo $vars['url']; ?>pg/dashboard/"><img src="<?php echo
    $vars['url'];
    ?>_graphics/elgg_toolbar_logo.gif" /></a>

    one problem fixed, still searching for the activity post fix, I'm guessing its a similar issue. I'll post back if I find it.

  • Hi,

    Im use your plugins on elgg 1.7.1 and im access the elgg site from my Sony Erricson phone using browser Opera Mini 4.2

    Why the log-in form still appear for logged-in user? if im click the "Home" menu.

  • International Character Solution

    /mod/mobile/view/mobile/page_element/header.php

    <head>
     <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

     

  • I still have the problem posting to the "Activity Stream"

    I enter text in the text field under "Activity Stream" then I click "Share"

    It redirects back to the first page with an error:

    "Form is missing __token or __ts fields"

    I will keep trying to find the solution but hoping someone knows the solution off hand.

    Any help is appreciated.

    Thanks

    -WiZ-

  • Sounds like something wasn't updgrated to work with 1.7 as it requires security tokens for actions now.

    There is a ton of info on this site about updating plugings to fix this. Do a search or hire someone to fix it for you.

  • Found the problem with posting to the wire:

    in the file: mod/mobile/views/mobile/dashboard/blurb.php

    i found:

    <input type="hidden" name="method" value="site" />
    <input type="hidden" name="location" value="activity" />
    <input type="hidden" name="access_id" value="2" />
    <input type="submit" value="<?php echo elgg_echo('Share!'); ?>" id="submit_mobile"/>

    Changed it to:

    <input type="hidden" name="method" value="site" />
    <input type="hidden" name="location" value="activity" />
    <input type="hidden" name="access_id" value="2" />

    <?php echo elgg_view('input/securitytoken');?>

    <input type="submit" value="<?php echo elgg_echo('Share!'); ?>" id="submit_mobile"/>

    Now I'm able to post on the mobile view. It was a bit frustrating trying to find exactly where to make changes so maybe this will help someone else. Still, I appreciate the great plugin!

  • Hi,

    the problem is with the action tokens. I will update the plugin when I have time. I'm a little busy with some paid projects at the moment. 

    Regards,

    Mark

  • I also noticed that it does not work on Cerain Models of Cell Phones for Example the Samsung R350 the phone that looks like the Backberry. It works on another phone we have a touch screen one but not this Samsung one that is new. So either it is the software that this phone uses like the browser have no idea why but when I type the username and password it does not login goes right back to the front page on the phone. Statusnet works on this Samsung phone and also Jisko microblogger I have that installed also. Another one that does not work is the one from Blogtronix their free microblogger. I have 4 different Open Source Social network platforms running on my main domain but in sub domains.

    If you want to try it out see for yourself go here:

    http://rapichat.com--- My main Elgg install

    http://microblog.rapichat.com&nbsp; --- Blogtronix Open Source Microblogger Platform

    http://m.rapichat.com --- Statusnet (Same Runs: Identi.ca) Platform running

    http://2012.rapichat.com&nbsp; -- Jisko Microblog platform

    Plus:

    http://blog.rapichat.com --- Wordpress install

    And something very cool:

    http://free-backlinks.rapichat.com --- a cool Backlinks PhP Script that I found and paid for

  • The river don't show all the actions. Why?

  • Doesn't work ?view=mobile in elgg 1.7.3

Mark Harding

elgg developer, iOS developer

Stats

  • Category: Uncategorized
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 43250
  • Recommendations: 86

Other Projects

View Mark Harding's plugins