Release Notes

  • Removed internal getter function, refactored out to url_getter plugin
  • Hi Justin:

    Really cool plug-in!

    Q. Is it supposed to authenticate against MW (it doesn't for me) to edit/create pages or do we authenticate separately?

    Q. Is it designed to render graphics in a MW page? (It doesn't for me.)

    David

  • Hi David:

    1) No, it does not authenticate against MW yet. We are working on an OAuth-enabled version of this plugin and a corresponding OAuth plugin for MediaWiki to allow for this kind of action. This plugin will be updated when that is available.

    2) Yes, it is supposed to render graphics in a MW page. The problem is more than likely the image root parameter in your configuration. The plugin does a string-replace (since I can't rely on valid XML structure, this was the best I could come up with) that is supposed to point things at the right absolute image URLs. It's not perfect, but it does work most of the time.

  • Hi Justin

    I have noticed some discussions about configuring your plugin in former versions of your MediaWiki plugin. We'll really like it to work, and we got ssh access to both the ELGG and Wikimedia sites:
    http://192.38.114.240/elgg/mod/mediawiki/mypages.php to http://species-id.net.

    When following any link from the

    We have tried a lot of combinations of configurations*, without luck. Can I use a "str_replace" workaround in a .php file to go-to the right login-location?

    $printingX[1] = str_replace("http://species-id.net/w/index.php?title=Special:UserLogin&returnto=Main_Page","/w/index.php?title=Special:UserLogin&returnto=Main_Page", $printing31[1]);

    Best wishes, Phillip

    * My Mediawiki setup is, for the best of my knowledge, set to the present:

        1. http://www.species-id.net
        2. /w/api.php
        3. /w/index.php
        4. /
        5. /w/media/
        6. TaxNet Wiki


    Other configuration options tried:

    ad 1. It seeems to be the same with or witout www
    ad 2. Have tried using /api.php and /wiki/api.php and no page is found 404 error
    ad 3. Have tried using /api.php and /wiki/index.php and no page is found 404 error
    ad 4. Have tried /wiki/ that I honestly would expect to be the right setup, but then an extra /wiki/ is added in all links writing /wiki/wiki/ in all these links
    ad 5. Have tried /wiki/media/ and a 0 error appears, shown on an empty page (inside my layout)
    ad 6. Anything seems to be acceptable here (free text)

    Finally, we have tried a Iframe, but when going to the login page it jumps out of the frame and cannot login.

  • This is a great plugin!

    I'd be interested in setting it up in a Elgg 1.8.3. Is there any plans to update the plugin? I see that many functions have been deprecated in the new version of Elgg so it doesn't seem to work.

    thanks,

    Wouter

  • There are no plans to update this plugin for 1.8 at this time, but if someone else wants to take this and put it into a 1.8 compliant form, I'd be happy to take the changes and push a new version here.

  • Justin, I'd be happy to do it, but I'd like the license to be GPLv2, or later, otherwise I can't distribute it with lorea, and will have to rewrite it from scratch.

Stats

  • Category: Third Party integrations
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 2547
  • Recommendations: 5

Other Projects

View Justin Richer's plugins