Weather Widget v1.1

Release Notes

-------------------------------------------------------------

Updates in this version include:

1. Displays the low/high temperature for each day

2. The ability to select Fahrenheit/Celsius (when displaying temperature)

3. Mouse hover over image will include additional description of image

-------------------------------------------------------------

  • Hi @good_vibrations I tested it on 1.6.1 and all seemed ok and 1.5 seems to work (thx @jededitor) could you provide any more information as to the nature of the problem on 1.7a1? Could I have configured something incorrectly that older versions choose to ignore?

  • @jace - Sorry, my fault. Everything seems to work very well with 1.7a1. Nice one. thx

  • @good_vibrations - phew a relief for sure. As it was my first I immediately assumed i'd broke the up coming 1.7 (not something that would ensure the longevity of my widget :-) Anyway, thanks for the update.

  • Hi Jace, nice Job. Do you think there will be a update version of this plugin and if so you think it's possible to show all seven days to appear? 

  • Awesome, exactly what i was looking for.

    Just one tiny little problem with cities containing weird characters, the XML from Google is not UTF-8 compliant so SimplexmlElement failed to load the XML.

    To fix it, i just added "&oe=utf-8" to the $requestAddress var and everything seems good !

  • Hi @Mr. Achiever, I'm not sure if you can request any more than the standard 4 days from the google weather api as it is in fact a non-supported api and I don't see any clear way to do this :-( If you were serious about developing a more fully functional API then you could look at Yahoo's equivalent http://developer.yahoo.com/weather/ However, please note their ToS (Terms of Service) at the bottom of the page. As the google api is not officially supported it does not officially have a ToS.

    Thanks @FredB well spotted, hopefully I will get chance release 1.2 and will include your change and a dedication accordingly. Alternatively, send me a message if you want to release it yourself. 

  • unpacked and uploaded and went to enable it told me it was a misconfigured plugin and froze up my site..  removed it and all is well again

  • @Imoutofhere sorry to hear you've had problems. I'm not aware of anyone else having issues, could you provide additional information. What version of Elgg are you using? Did you ensure you uploaded the entire package before trying to enable it in the administrator page. I know i've made that mistake in the past (i.e. my ftp client hadn't copied all the files I thought and in my excitement to enable the plugin I had a misconfigured plugin that prevented the site from working momentarily).

  • Hi Jace does pluging make changes to the database?

    Dennis

  • Hi freevermontradio

    Nope, there is no requirement for the widget to access your DB itself. It simply accesses the google weather api and renders the results within the widget. It does however store the users settings through the widget's edit parameters (this does edit the database, but only based on the Elgg framework, so should work as per all other widgets).

  • Hi,

    I'm having an issue when I use the plugin.

    Once the widget set, I get a String could not be parsed as XML

    and it seems reloading the complete page inside the widget.

    I'm using the version 1.7 of elgg.

    thanks! :)

  • Hi veikos,

    this is most likely an encoding issue as identified by FredB above. What location are you setting?

    regards

    Jace

  • This is kwel, just one thing that would make it awesome,,, a searchable weather forecast so that the page owner sets a default location but visitors could searh for weather where they are.

  • Hello Jace,

    I am having the same problame like Veikos,

    String could not be parsed as XML

    Have you fount any solution to this?

    Thanks

  • Hi @Szabi you prompted me to make a new release with the changes identified by @FredB. See version 1.2 and hopefully your problem will now go away (i.e. I suspect you and @Veikos are specifying cities that use characters beyond the standard ascii range and need the UTF-8 encoding as FredB says).

    Thanks J

Stats

  • Category: Widgets
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 3228
  • Recommendations: 8