[Elgg 1.5-1.12 & 2.X: Tidypics] v1.8.6

Release Notes

  • UI-improvements on thumbnails re-creation page (progress bar),
  • Fine-tuning of sidebar entries with addition of "Latest comments" and "Tagcloud" blocks where appropriate.
  • Hello.

    I have this problem: I have 2 images. One is OK but other is missing (/mod/tidypics/graphics/image_error_master display). I look at their URLs.

    Working has /photos/thumbnail/45049/master/

    Missing has /photos/thumbnail/45038/master/

    Then I go to data directory. The newest data directory is: data/2015/06/30/40544

    Then I think to myself: 40544 is the highest GUI. So maybe it is normal 45038 is missing. Maybe some newer directory like /2015/09/12/45038 is deleted by mistake.  But then why does 45049 work? I do not see any directory newer date than /2015/06/30/40544?

    Do I look at wrong place? Where is image 45049 hiding?

    Thank you for help. 

  • @Den

    The guid in the path data/2015/06/30/40544 is not the guid of the image/album but the guid a user account (not necessarily the user who uploaded the image with guid 45038). The guids of entities (users, objects like an image, groups) get incremented together, so you can differ the the type of content (or if it's a user) by the guid.

    On Elgg 1.8 the data directory structure is year/month/day/guid for the corresponding user with the date taken from time of account creation (on newer versions of Elgg the structure is different). You can find out the corresponding data subdirectory of the user who uploaded for example an image using for example my LastLogin plugin (https://elgg.org/plugins/874298). It has plugin options to display the date of account creation (join date) and user's guid (only visible for admins) on a user's profile page.

    Within a user's data subdirectory (e.g. data/2015/06/30/40544) there are further subdirectories, if a user has uploaded files. For Tidypics there would be a directory named "image" and within this directories would be directories for each album ("image/album_guid"). Within the album folders there should be 4 image files for each uploaded image (orignal file and 3 resized versions). Filenames of images consist of a timestamp (time of upload) plus the original filename. The resized versions have a prefix for the different sizes (e.g. thumbnail).

    The image that displays the image error image might have failed at upload time on creation of the thumbnails. If you click on the image in the full view page of the image there should open a popup displaying the original image file. If this image shows up, you can try to recreate the thumbnails on the Tidypics plugin settings page (Thumnail creation tab). You would just have to provide the guid of the image (45038) for the creation process getting repeated for this image. If the original image file is also missing, there's no way to recreate the thumbnails. In this case it might be best to just delete this image entry (in case this fails on the site's frontend due to this image entry being corrupt you can remove this entry on the "Delete image tab" of the Tidypics settings page by entering the image guid).

    The reason why the image is not correctly displayed could be a too small size of post_max_size or memory_limit set in Elgg's htaccess file. Or it just happened that the image upload of this image got disturbed for some unpredictable reasons.

  • @iionly  Your answer is a real treat! Thank you!  "/guid for the corresponding user with the date taken from time of account creation" is important for me. "Account creation".

    My original image is also missing. I think it happen when I moved from one server to another (system time difference?).

    I will check all. THANK YOU!

  • Timezone could be a reason if the site has been moved and the timezone is different on the new server. Another possible reason connected with moving the site is that the filestore database entry might not have been updated - should only be necessary if the path to the data directory on the server filesystem has changed (see http://learn.elgg.org/en/2.0/admin/duplicate-installation.html#database-entries).

    You could check if you can find the image file(s) in the data subdirectory of the user who uploaded it. If the file(s) are there but don't show up on the site, the problem is likely due to the move. If the problem is due to the filestore enty the image should show up once the filestore entry has been corrected. The timezone is another thing. You could change the timezone to the zone used on the old server. But if the site is already on the new server since a while this could result in issues with content uploaded after the move. The only solution for not getting bothered with timezone issues for sure would be updating your Elgg version to a newer release as the different structure used for the data directory on more recent versions of Elgg is no longer depending on the timezone for locating files.

  • Another possible reason is the character encoding/collation difference in the from/to databases as well as in those of the from/to data file/directory names.

    What I am saying is; those images might not be missing. They might be just there but maybe software cannot find them because of different encoding of the file names.

  • Tidypics in the directory called "image" and within this directories would be directories for each album ("image / album_guid"). Within the album folders there should be 4 image files for each uploaded image (orignal file and 3 resized versions). But this was not happening .... original image file is also missing ....... corrupted image ... use elgg 1.9 and tidypics 1.95. SOLUTION: I increased the Memory_limit from 64M to 128M. Problem solved. I also installed tidypics 1.8 but appeared red lightbox message ... so with tidypics 1.8 still active, copied and pasted tidypics 1.9 over 1.8 and problem was solved. Whoever goes through this ...
     
    
     
  • One posting at the right place would have been sufficient. I don't know why you needed to post exactly the same 3 times.

    It's explained in FAQ.txt that comes with Tidypics and it has been explained numerous times already here on the community site: if you use the GD php extension as image library for Tidypics the resizing of large images (not necessarily only for a large image filesize but rather large image resolutions) requires a lot of memory. That is due to the way the GD php extension works and there's no workaround except increasing memory_limit. Alternatively (if available on your server), use the Imagick php extension or the ImageMagick command line tools as image library for Tidypics (in my opinion the ImageMagick command line tools also gives the best image quality). Both these alternative image libraries require much less memory for image resizing.

    Also, I've not released different versions of Tidypics for Elgg 1.8 and 1.9 without a reason just for fun. Please use the recommended version of Tidypics for the Elgg version you use. Don't use a version recommended for another version of Elgg - if you do, do it on your own risk and don't blame anyone else if something goes wrong. Also, Elgg 1.8 and 1.9 are totally outdated. Use at least Elgg 1.12 (or even better update to Elgg 2.3).

Stats

  • Category: Photos and Images
  • License: GNU General Public License (GPL) version 2
  • Updated: 2018-9-16
  • Downloads: 134384
  • Recommendations: 245

Other Projects

View iionly's plugins