[Elgg 1.5-1.12 & 2.X: Tidypics] v1.8.0-preview 2

Release Notes

Adds album sorting, slideshow, view counting, and tagging

Still need to implement ajax/flash uploader, notifications, and admin support pages

  • Something is strange in the neighbourhood: some of my users are able to use Photos from the menu-line but some get a white screen of death and I can't tell the difference. Looks like all old users (in the system before the upgrade to 1.8) are ok and all newer ones are failing.

    In my logs I found some deprecated messages which I fixed (mostly) in the scripts but no changes. Still get some: PHP Fatal error:  Call to a member function getURL() on a non-object in /home/www/web1450/html/community/mod/tidypics/views/default/object/album/gallery.php on line 24

    Will check regurlaly for updates

    Regards

  • I've posted a bug fix for "lost objects" to

    http://code.google.com/p/tidypics/issues/detail?id=157

    Changes are in the file: TidypicsAlbum.php (you dan download the file there). On my site it was happening when user delete one or more pictures from the album.

    Alex

  • @Aleksandar Radovanovic

    in my 1.8.3 elgg site, the tidypic downloaded from github (brettp version) was working something went wrong when a user uploaded or deleted an image in group. Since then the tidypic not working i downloaded the latest one from github (brett) but it is not working ..only white page comes after activating the plugin .....tried with ur above fix but all in vain...........can u suggest an working version of tidypic for 1.8.3 ........will be grateful

  • Is anybody now how to pull latest photos in this version old code is not working ?

  • Hey Dhrup:-

    I am using below code but no pic is displaying.

    <?php
       
        if (elgg_is_active_plugin('tidypics')) {
        echo elgg_view_module('popup',  elgg_echo("Recently added Photos"), $vars['entity'], $mod_params);
    echo tp_get_latest_photos(12);
    }

    ?>

     

  • oye: just got my internet connexn yesterday.. wish i had switched to new isp earlier than 10 fck days  ! but surfing on android can b fun (w/ 4x reading glasses!)
    that code does not reveal much more than 'no pic...' ;-)
    ? what does display
    ? any (error) messages
    ! have u tried any code level 'debugging'

     

  • is this version safe for production sites?

  • I'm glad tidypics is starting to function again, and I am using it on a produciton site because of a lack of alternatives, but there are several bugs that still need to be worked out.  On my site, galleries with more than 8 photos do not display correctly in album view.  Only the first eight photos have title links, and there is no next/previous button to get to the rest of the pictures.  Currently the only way to see eveything is in slideshow mode.  

    I'm on Elgg 1.8.3 and would be happy to help debug if you need anything, but so far i have been unsuccesful in fixing this myself.

  • @Dhrup:- I found the solution to show latest photos or latest albums to custom index.

    I will post code here tomorrow.

    Bret's tidypics version is working fine to me know and I am going to upgrade my site this week end.

  • I installed the Preview Version on 8.3 and uploaded picture. It came up fine, however, there is no link to delete picture. Even when I click Edit, still no Delete button or link. Help please.

  • Looking forward to the final release

    Will there be an overall / per-user quota on image uploads as the previous version? I like to set the image limit, and the number of images / total user upload size.

    Thank you :)

  • I've got a strange Problem:
    The Thumbnail Images in the Preview (when you upload a single or more pictures) cannot be loaded, but i can add Text.

    Also the (Thumbnail)Images in the preview cannot be loaded, but when i am in the Album and click on the (unloaded) Picture-Link, a Pop-Up with the big Picture appears and it can be loaded!?

    Where is the Problem, can someone help me?
    (I'm using 1.8.5) 

  • Found it:
    Files Plugin was not active.
    But manifest-File didn't say, i would need it.

    However, it is working now.

    When will the next version be launched? (Will there be one!?)
    Maybe you can add the feature to tag friends in the pictures. (Or I didn't find it, because i can only tag a Text) 

  • I have elgg 1.8.5 pls upload the support vertion

    Thankyou

  • Thanks for your plugin.

    I checked and it worked on 1.8.5, but there has problem with "Access right". I check for "Private" but my Album still be accessed by publicer and friend.

  • how does one take away public albums? I just want logged in users and groups to be allowed to make albums. Thanks.

  • I get the following error on admin page

    2012-06-22 00:59:04 (GMT+3): "Object of class ElggPlugin could not be converted to string" in file /home/silverfoxweb/www/mod/tidypics/views/default/forms/photos/admin/settings.php (line 45)

    What's going on?

     

  • Rafael I'm having the same problem on top of photo size is exceeding limits set my administrator I cannot get around.

  • @Rafael and Michael, I was having the same problem.  The fix I found was in line 45 has "$$plugin->im_path)" It has an extra "$".  It should be "$plugin->im_path)".  This fixed it for me.

  • how does one disable the download photo button ?

  • @marcnl: admin>settings>tidypics --> first tab, show download link -->uncheck that tickbox, this is a standard preference, have you checked the tidypics settings page in your admin?

Stats

  • Category: Photos and Images
  • License: GNU General Public License (GPL) version 2
  • Updated: 2018-9-16
  • Downloads: 131472
  • Recommendations: 262

Other Projects

View iionly's plugins