[Elgg 1.5-1.12 & 2.X: Tidypics] v1.8.0-preview 2

Release Notes

Adds album sorting, slideshow, view counting, and tagging

Still need to implement ajax/flash uploader, notifications, and admin support pages

  • Cash is there a working uploader at all for these test releases? I'm getting the same behavior I had in preview 1. There appears to be a functioning uploader, but I only get empty images/thumbnails.

     

     

  • @knussear Did you enter a value (width & height) for the Thumbnail image size?

  • Layout is fixed in this release but no flash uploader. With basic uploader blank thumbnails. I am on 1.8.3 ..................Old albums are displaying good but no new uploads.

  • I have been testing with the basic uploader and haven't had any problems. Have you checked your error log to see if Tidypics is writing any messages there?

  • The basic Uploader has always worked fine as long as I can remember. The Flash seems to have had problems now and then and then.. Here's the guts what I posted last year on that problem :=

    Oh weeellll ;) TidyPics seems to have some code in there for the flash session 'workround' but that code is not trigerred from anywhere ;(
    Also - seeing that the TidyPics 'Team' is whittled down to *one developer(used to be quite a few around)  --
    Might there be any other experienced developers a least @ 1/3 of the usual weight-class who might be interested in joining to create a new synergistic team to take care of this oh-so-important PlugIn ? Having spent waking-hours, sleeping-hours, dreaming-hours, potty-hours.. ad-hoc-hours and ad-nauseum-hours studying Elgg code -- I'm quite game if there be others qualified, capable, willing and dedicated enough ? -- to 'work' ;-oO lolz for me on this ?

    Never heard from any suitable person/developer on that subject. Ackshully I think I even sent Cash some PM's offering to take ownership of TidyPics and work on fixiing the major issues. Never heard back from him either ;-) Even tho in public he's always 'griping' about the lack of quality coding time to work on TidyPics - he is *the *only *Developer who's working on TidyPics and ++ all his Core involvement and such heavy-duty commitments...? I'm not surpirised TidyPics sees to be suffering symtoms of neglect. And the GitHub availibity  and casual offer for anyone to just go grab and fork frm there - seems to have not worked to take the worload off his tireds shoulders...;(

    Anyway - after having tried about 3 times already - if Cash would be interested in (officially) handing over management of TidyPics (He kinda does need to *ask and *officially) to give some TLC and make it shine even more brightly - I have the time, commitment and (most important) the technical background to take it and propel... he knows where to find me.

     

  • @good_vibrations I hadn't set those. Working now, Thanks!

  • And just btw -- For the near/mid-term future - IK's hypeGallery might be worth watching for - When he gets around to fixing up some 'makings' for it such as more sophisticated gallery features :- SlideShows, taggin, geolocation, etc; and who knows ? That mickeymouse 'Media-Manager' PlugIn that I started working on for some specialzed features we need -- might take some more definite form - enough to be published here.

     

  • hypegallery will be useful for those who make a fresh install of elgg. What about a tidypic gallery which have more than 3000 photos? is it possible for them to blindly install hypegallery loosing all previous albums?

  • Losing existing Albums ? At Fkkids.com we do not plan to lose anything, we've got about 100 GB (~0000`s of photos ) of data to migrate from TidyPics to Media Manager ;-)

  • Hello, I am trying to use version 1.8.0 P2 and the oddest thing happens, I get a white page when I activate the plugin. On a default installation of Elgg 1.8.3 it works fine but on my current site I get the white page. I see no error logs in the Elgg error file, server log, and am not told anything on the white page. It's not other plugins affecting it as I tested each one. I did an upgrade from the dashboard and flushed the caches to no avail, im not given the open in the Tidypics admin page todo an upgrade. Any help is appreciated.

  • This release is working perfectly for me with no bugs :) The only problem I have is a layout issue when photo or album titles are too long - it would be nice if there was a feature to truncate the titles after so many chars.

  • ...sorry forgot to say that's for the thumbnails in the summary views.

  • Spoke too soon, just realised that it's not resizing the images - when you view full size it shows you the original 5mb photos.

  • How do you remove a tag once placed?

  • Image thumbnail is not working for me. Please help.

  • Will there be a user/group quota we can set? That was great on the previous release. Don't see it on the current one?

    Else, great plugin!!

  • I downloaded, installed and am using 1.8.3 without problems in elgg, tnks
  • Thumbnails also not working ofr me :(

  • Nudeler2

    In language (en) I added:

    'photos:add' => 'Add Album',

     

    In language file (de) I added:

    'photos:group' => "Gruppen-Alben",

     

    In start.php below "Add a menu item to an ownerblock" I changed this:

    if ($params['entity']->blog_enable != "no") {

    to this:

    if ($params['entity']->tidypics_enable != "no") {

  • Tidaypics preview 2 using Elgg 1.8.3. I make an album, upload 10 (max) photos. Then I go an upload 10 more, so the album contains 20 images. When I view the alum, it will only display 16 of the images, no pagination option is visible for the next 4 images. Bug?

  • Hi, this Version does work with my 1.8.3 installation besides I get an error clicking on 'my' in the album overview. It says: sorry, can't find requested page. Strange. Clicking on 'friends' I can see the friends albums.

    Good work, keep going and many thanks

  • i was using older version when i upgrade to 1.8, although the "depreceted" messages, that i treated one by one, all my albums were fine. Then suddenly all images disappeared.

    Remove the old version, installed this version and press "upgrade" but no avail. My images did not appear again.

    I have a message like this "0 (guid:3) cannot be initialized. Reason : it was not possible to include start.php for the plugin idypics (guid: 3) in /mnt/glusterfs/....../ /mod/tidypics. Check pemissions!"

    any thoughts????

  • WORKS FINE in 1.83: SKSLink.com/network

    Everything working great on my site but I forgot what I did to fix it since the comments I did been closed in:Tidypics Fix elgg 1.8

    P/S: What I did was re-installed few times with old version. Kept the good ones, un-installed the script.

    P/S/S: Pasted the good one's to the newly installed script 1.83

     

    *Take your own risk as I had mine, lost 500 plus active users. A Single mistake made all the file goneforever.

     

  • Can you help me?

    After some time running ok, using tidypics 1.7 on elgg 1.8 all images from my albums started to not be shown. Only albums (profile pics are ok).

    Tried using 1.8 version, changed permissions on my data folder, changed metastrings... Nothing.

    The images are there and I can see them with ftp but when trying to see through code, nothing. Only a message saying that my request could not be loaded.

    Tried to download the image. It downloads, but says that the file cannot be opened... Strange.

    Wait for some clue. thanks

     

Stats

  • Category: Photos and Images
  • License: GNU General Public License (GPL) version 2
  • Updated: 2018-9-16
  • Downloads: 130078
  • Recommendations: 262

Other Projects

View iionly's plugins