[Elgg 1.5-1.12 & 2.X: Tidypics] v1.8.0 rc1

Release Notes

Updated for Elgg 1.8

Thanks to Brett for significant contributions. Make sure you run the upgrade script.

This is a release candidate which means there is not going to be any significant development before the final 1.8 release. Changes will be bug fixes.

Please make useful bug reports (report browser information if browser related, report server information if server related).

  • which ellg vers r u on ? 1.8 or b4 ?

  • Hello DhrupDeScoop

    I use elgg 1.8.9 with latest version of  Tidypics plugin (rc1). What is b4?

  • lolz ;-)

    'b4' = 'before' ;-P

    okay - the problem **is caused by username containing non-roman-character-set the diacritical  ö in ötek; tidypics trigerrs code in core which looks for current page's owner using username ötek - and cannot find you. could be several reasons - maybe database encoding, maybe bad code,... i cannot be 100% sure without digging more & looking closer.

  • First I think because I enter wrong username. But Elgg say username is fine otherwise it complain b4 it save. But it does not complains. Therefore I think tidypics username handling not compatible with Elgg. Thanks.

    (I think b4 "build 4" mean:-)   )

     

  • check your database in phpMyadmin - do you have collation --> utf8 ?

     

  • I have "MySQL connection collation" : utf8_general_ci

    I think site is OK. I can see the utf8 chars in site URL. Other plugins I check are OK. I think Tidypics.

  • paste your URL where this 'error' happens.

  • @Selen:

    Try these code changes at the top of the php file
    and.. report your testing results back here :=

    All the new code lines are in bold & marked with //:DC:

    file:        mod/tidypics/pages/photos/owner.php
    . . . 
    group_gatekeeper();
    $username=get_input("username");            //:DC:    fix non-roman charset usernames
    $username=utf8_encode($username);        //:DC:
    set_input('username',$username);             //:DC:
    $owner = elgg_get_page_owner_entity();
    $title = elgg_echo('album:user', array($owner->name));
    . . .

     

     

  • Thanks DhrupDeScoop. I made changes, I get same error:

    Fatal error: Call to a member function getGUID() on a non-object in ...../www/myownsite.com/mod/tidypics/pages/photos/owner.php on line 30

    line number 30 in my system: 'container_guid' => $owner->getGUID(),

    the URL at that point: http://myownsite.com/photos/owner/ötek

    (when I copy past here is shown: http://myownsite.com/photos/owner/%C3%B6tek)

    I summarize all in my old message here to have all here:

    problem: FATAL ERROR when username with a utf8 character ("ö"). This error happen only on "Mine" tab. Not on "All" not on "Friends".

    system: on Elgg 1.8.9 Tidypics1.9.0.rc1

    Databas have "MySQL connection collation" : utf8_general_ci

    To repeat:

    Got Photo page. Default it shows "All" tab pictures uploaded by all user. Then click on "Mine" tab to see current user's my pictures and get fatal error:

     Fatal error: Call to a member function getGUID() on a non-object in /..../www/myownsite.com/mod/tidypics/pages/photos/owner.php on line 25

    Username which this problem had is "ötek". So URL  http://www.myownsite.com/photos/owner/ötek

    My conclusion:

    Elgg say username is fine otherwise it complain before it save. But it does not complains. Therefore I think tidypics username handling not compatible with Elgg. Thanks.

    Thank You

  • everything looks correct ;-)
    my guess is that the php scriot file for the code changes are the wrong one;
    itested that same utf8-encode($userame) on a different piece of code..
    ( though i am sure that owner.php is the correct file ;)
    but with the same get user by user name checking and it corrects the error.
    send me a PM with your website url, setup a userid & pasword for me
    so that i can look first-hand
    OR
    locate he exact PAGE url from where
    you click to try to goto the MINE album..
    and we can figure which php file needs the utf encode..
    that's all it needs..

     

  • update: ;-)
    wrong little part of code !
    i installed tidypics to try -->
    the URL here @my xampp is :-
        http://localhost/elgg1880_base/photos/owner/%C3%B6tek
              ( b/c URL encoding, 'escaping' )
    but NOT
        http://localhost/elgg1880_base/photos/owner/ötek
    as it should be !;-) so..
    i think a little bit more code juggling will be needed;
    maybe we'll try to hack thru to make it work..
    and can code it properly.. laterrr.

     

  • ok...
    i will post more details later; i need some coffe and food !;-p then need to figure just what & where the problem is being caused in and by tidypics with non-roman userName like ötek - I hecked the code in owner.php to get the correct, proper username set up - and can see this page which is what it should be - because user ötek does not have any albums in my xampp elgg here.

    ötek's photo albums

    No photo albums

     

  • Hello, I am using elgg 1.8.3 and the problem I am having is everytime I edit a photo in the group albums It turns into a question mark.  the orginal photo is only visible to the owner and the admin.

  • havent q finished muh coffee(s) ;) not coding much yet but the re-design in the mind is proceeding; cash colstelli @credit shud have taken me up on that offer to 'take-over' tidypics many months ago !

  • @Dhrup - Feel free to make any pull requests for fixes you have locally: https://github.com/cash/Tidypics/

  • Estou sentindo falta da visualização como slid onde eu posso ver todas as fotos passando no mause o seta, nesse plugin só abre a foto na pagina e não o album todo como slidshow...

  • I was wondering what happened to the photo rating integration? Is there plans to bring it back?

  • 1. "HTTP error" on flash uploader at firefox? Actually this problems appears at opera as well, the only browser I managed to get it working is chrome.

    2. Another problem with flash uploader is "Unable to save new object's base entity information!" when uploading to album that isn't owned by user. (happens nevertheless of what browser is being used).

    Are there any workarounds for those problems? I'm setting up a social site and really need to get flash uploader working properly, would appreaciate if someone can help out.

     

     

     

  • - When the upload of an image fails (say, due to image size being larger than allowed one), image is still listed as an empty image in the river and widgets. And when clicked, it gives:

    Fatal error: Call to a member function getURL() on a non-object in ...mod/tidypics/views/default/object/image/navigation.php on line 20

    And I could not find a way to delete such "images" on UI. I shall try DB cleanup.

    I tried Vladimir's fix but it did not work for me. There are also some other errors. I checked github but could not find an update there (other than a German language pack).

    These errors you hit pretty fast. Does anybody use tidypics in a live website and how?

    Best.

  • Hi all! Great plugin, tks a lot!

    Some questions: I want just admin to create albuns and upload pictures. And also, I want to remove comments. I could not find config options to remove. How can I achieve it?

     

    Regards, Fabio

  • the problem is in core pagehandler.php, function default_page_owner_handler() at
        $segments = explode('/', $path); 
    the url (which contains the username) is encoded, and so needs decoding before the explode, to handle non-roman characters so that the get_user_by_username fetches the user object ok -->
    $path=urldecode($path); 
            $segments = explode('/', $path); 

    someone, anyone (else) can grab this code and do the "  free to make any pull requests for fixes " - all that the customary github pull request rigmarole procedural stuffs. (and also you can take the credit.. i don't care;) 



  • The slideshow function .. it only shows maximum of 50 photos in an album ... :( why is that ... 

  • Hi, i'm using Elgg 1.8.11
    I see that the "Administration" menu are visible to non-administrator user when the user on image page.
    Also, the image "edit" link, how can I make it visible to the photo owner only?

  • +1 also the "delete" button, how can I make it visible to the admin and the photo owner only?

Stats

  • Category: Photos and Images
  • License: GNU General Public License (GPL) version 2
  • Updated: 2018-9-16
  • Downloads: 132646
  • Recommendations: 246

Other Projects

View iionly's plugins