[Elgg 1.5-1.12 & 2.X: Tidypics] v1.6.8

Release Notes

Supports 1.5.x-1.7.x

Fixed a bug with resizing images. Added some markup and css to improve photo album layout. Improved the admin settings page layout.

Install/upgrade like any other plugin. If you haven't upgraded since Tidypics 1.5.x, an upgrade button will appear on your Tidypics admin page.

  • Another question: is this a possibility to do some pictures sorting?

  • why i can not choose pictures from the tidypics-album with the "Embed/Upload Media"-Dialog?

    I think it should be a register "tidypics" and in there a pulldown to select the album

    or is there a other way to choose a embed tidy-pic to insert in a blog as example?

     

  • @Anna - sorry, do not have time to write that code

    @Robert - that feature is highly requested and is coming

    @manfred - will be part of Elgg 1.8

  • @Tidypics Team:

    please give trouble shooting steps for this tydypics how to configure this plugin and how to use this give

    thanks

     

  • Just did a fresh install of 1.7.2 and the first plugin I installed was tidypics and I get

    "tidypics is a misconfigured plugin. It has been disabled. Please search the Elgg wiki for possible causes (http://docs.elgg.org/wiki/)."

    New install, new db on new folder on the server. What can I do to correct?

  • @nine17

    Have you checked the tidypics folder you installed. Most likely you unzipped the files into a subdirectory inside the tidypics directory, i.e. start.php and all other files are not directly in /mod/tidypics. This won't work. Unzip the files directly into the tidypics directory.

  • @iionly

    Thanks for the suggestion! I did make sure this was the case. I dropped in the newest version on another install and it didn't work so part of my testing was to do a completely new install with no other plugins activated and see if I could get it working. This is where I am getting the error. All files are in the mod/tidypics/ folder and still nothing.

    Any other ideas I can try or anything I could post here that would be helpful? Could it be a permission issue on any of the files/folders?

  • @nine17 - I'm curious. Why not follow the instructions and search the wiki?

  • @cash I searched the wiki and nothing I found there got it working. Is it inappropriate to post the comment here while working htrough the wiki also?

    @iionly I'll look at this again. Thanks!

  • @nine17 - the answer is in the Wiki so I'm always surprised when I see people posting about the "misconfigured plugin" error

  • One more thing: I have an application with lots of photos uploaded by users (well - at least in the future there will be lots of photos ;)). I would not like users to upload the same photos more than one time: for example if Michael has uploaded photo with Ferrari - Peter can't upload the same photo (even in other group than Michael).

    Wouldn't it be helpful to add some md5sum to check if the photo exists in the system already? Does it make a sense?

  • @cash I understand that. I have been working on Elgg for a while now and it was baffeling. One of those situations that makes you feel nooby all over again. I deleted, moved, renamed, check permissions, confimred start.php, did it all. I even re-read the wiki post like 100 times to smake sure I wasn't missing anything. Nothing.

    Finally deleted the entire sub-domain in WHM, created new sub-domain and loaded it in and it is now working. Hosting company said it could have been "some risidual .htaccess issue" whatever that means.

    Thanks for posting either way!

  • Great plugin! Congratulations.

    I run latest Elgg version and Tidypics plugin.

    On my 1and1 server I have installed the latest ImageMagick, as well, but I don't know how to make it work.

    What should I put in the settings under "Enter the path to your ImageMagick commands (with trailing slash)". Any examples?

    Thanks a lot from

    alfhinojosa@gmail.com

     

  • I have already seen that the path to ImageMagick commands is "/usr/bin/". Great.

    But when in Tidypics Administration - Image Library Settings I choose "ImageMagick Cmdline" and  save it all right, when I come back the Library Settings are always back to "GD"

    Is it normal or do I need to change anything?

    Besides the

    TidyPics Server Analysis

    gives me that the IMagic php extension is disable. Do I need it having ImageMagick installed?

    Thanks a lot.

     

  • In fact, I can't make any changes on the Tidypicks Administration Settings.

    Though it says that changes are saved, they don't stay on the new configuration.

    Is there anything which could be done about it?

    Thanks again

  • Hi again!

    Working hard at it. I have found that the impossibility of making changes in the Tidypicks Administration Settings was caused by the plugin Easyembed, which I had already noticed made the categories plugin not work and impossible to make any changes on the rest of my plugins. Great, one thing out of the way.

    However, I can't still make ImageMagick work. I have installed on the root of my server 1and1 both, latest versions of ImageMagick and Imagick but I don't know how to enable Imagick Php extension. I have googled a great deal but no luck. This post is my only chance to ever make it work. Do I have to make any changes in .htaccess? Do I have to create an php.ini? What code should I write?

    Thanks a lot.

     

  • @Alfonso - some servers are configured to not allow the path to be set for ImageMagick (the security mod for Apache can block this). If you did get the path set, then there must be some other issue. Have you confirmed that ImageMagick is running using the image library screen of Tidypics?

  • Thanks a lot for the quick reply!

    And yes, using the image library screen I can confirmed that ImageMagick is running, it gives me feedback of the version installed.

    But do I still need to enable Imagick Php extension? And if so how do I do it? I installed Imagic and in the prefix I wrote the same path I used for the prefix of ImageMagick. At the end of the installation I could see that the line saying "shared" the message was "yes".

    Thanks for your kind help.

     

  • Any chance of seeing a better photo uploader? Having to choose each image is tedious. Maybe something for Facebook-like? 

    *noob here*

  • same problem since 3 month

    tidypics is a misconfigured plugin. new fresh install today and same problem. I know Elgg, my tidypics in under mod. So, I really don't understand and I can see I'm not alone

    regards

  • Hello, can you help me to integrate this: http://fotoflexer.com/api.php/ .

    What datas of fotoflexer did i put and where?

    Tidypics:

     

    ______________________________________________________________________________________________

    api of fotoflexer:

    <?php

    // Parse paramters to get Image and thumbnail urls
    $image = $_GET['image'];

    // Verify that the URL begins with "http://fotos.fotoflexer.com"
    // This step is used to ensure that the image is in authentic

    if (strpos($image, "http://fotos.fotoflexer.com") != 0){
      //Handle the error:
      echo "Invalid Origin";
      exit;
    }


    // Grab the image type (png or jpeg)
    $file_type = $content_type[1];

    // Set the local file path for the image and thumbnail
    $image_path = "/path/to/images/image_name." . $file_type;

    // Image source and content have been verified, and a location has been set.
    // Now copy the images to the local server.
    copy($image,$image_path);

    // Both image and thumb are on your server at the location specified!

    // Optional:
    // if this is is an intermediate page, you can now setup your server state
    // and redirect

    /*
    header("Location:Path/AnotherPage.html");
    */

    ?>
    --------------------------------------------------------------------

    Thanks very much and sorry for my bad english; i'm french!

  • Good morning, good afternoon, good evening.

    Is it possible to modify Tidypics to receive photos by e-mail?

    Or; does it exist a plugin with this option?

    Thanks

  • Hi,

    after one fine import of some pics, i get now an ugly:

    Not Found

    The requested URL /elgg//elgg/mod/tidypics/pages/edit_multiple.php was not found on this server.


    Apache/2.2.14 (Ubuntu) Server at localhost Port 80

    What could that be? The file edit_multiple.php is at the showed path...
    PLease Help
  • Wiki-Search for "edit_multiple.php" ends up with "There were no results matching the query."

    Tidypics uploads the choosen pics but do not ask for comments nor for the Albumcover...

    After Upload pops up the Page Not Found error:
    The requested URL /elgg//elgg/mod/tidypics/pages/edit_multiple.php was not found on this server.

    Please Help. Peace

     

Stats

  • Category: Photos and Images
  • License: GNU General Public License (GPL) version 2
  • Updated: 2018-9-16
  • Downloads: 131393
  • Recommendations: 262

Other Projects

View iionly's plugins