[Elgg 1.5-1.12 & 2.X - 4.X: Tidypics] v1.6.4

Release Notes

The newest version of the Tidypics Photo Gallery.

For list of features, go to the Tidypics Group

Changes from 1.6.3

  • Slideshow (added by Torsten)
  • Bug fixes
  • Improved watermarking
  • Added plugin hooks for overriding watermarking and slideshow

Our tracker list is here: http://code.google.com/p/tidypics/issues/list  It includes bug reports and feature requests.

 

New Install

  1. FTP code
  2. enable plugin
  3. go to Tidypics Administration page
  4. save your settings

 

Server Analysis - find off settings page. Some documentation in docs directory on how to use this

Want images on your front page? see tidypics/lib/tidypics.php

White screen - probably not enough memory allocated to PHP

Uploaded images giving up question marks - that's an issue with your image processing library (GD, ImageMagick, imagick extension) - check your server error log for more information

  • @Tidypics Team  I thought suggestion could make your plugin more calueable,and other reason is that I don't know PHP very well, But I have started work on implementing the Flah uploader in your Tidypics addon & I hope I can do it,

    Wish me

  • @ Tidypics Team

    can you tell me where uploaded photos been stored???

  • Hi,

    When i disable "Allow group members full access to group albums", shows edit and delete link.

    It doesn't allow the group user to edit album (sends user to main page or delete album (sends user to all site albuns).

    I sugest it would work like tag link and download link when disabled it does not appear.

    The other sugestion is that the group owner can enable full access to grupos album not the site admin.

    regards,

    jose

  • @ElggTurkiye - those pages might be missing the contentWrapper div. I'll take a look at that.

  • Hi all,

    i have installed the last version of Tidypics (1.6.4) on Elgg 1.6.1.

    This is my configuration:

    PHP version 5.2.9   GD Enabled Elgg requires the GD extension to be loaded IMagick PHP extension Disabled   exec() Enabled Required for ImageMagick command line Memory Available to PHP 32MB Change memory_limit to increase Memory Used to Load This Page 8.40 MB This is approximately the minimum per page Max File Upload Size 32MB Max size of an uploaded image Max Post Size 24MB Max post size = sum of images + html form Max Input Time 60 s Time script waits for upload to finish Max Execution Time 60 s Max time a script will run GD imagejpeg Enabled   GD imagepng Enabled   GD imagegif Enabled   EXIF Enabled  

     

    As image library i use ImageMagick 6.0.7 (also tested with GD). The plug-in is at the bottom of the list.

    But i have a problem... tagging doesn't works for me. There is no way to select an area. I have tested it on Safari 4.0.3 and Firefox 3.0.14 on Mac platform running Leopard and also on my PC. There are particular instructions to activate tagging? All users on my site can use this useful option :-(

    This is the list of the plugs activated on my site:

    event_calendar

    messageboard

    notifications

    bookmarks

    logbrowser

    messages

    diagnostics

    crontrigger

    captcha

    invitefriends

    tinymce

    members

    thewire

    garbagecollectorprofile

    reportedcontent

    logrotatecategories

    uservalidationbyemail

    friends

    htmlawed

    embed

    pages

    externalpages

    file

    custom_index

    blog

    defaultwidgets

    riverdashboard

    groups

    bottom_bar

    friend_request

    fivestar 

    tidypics

     

    You think that someone of these plugs can disturb Tidypics? I really don't understand why it doesn't works for me.

    I also have another problem.... Slideshow doesn't starts. If i click on the button "View Slideshow" nothing happen.

     

    Someone can help me please?

     

    Thanks for your great work and for your time.


  • I have 1.6.4 tidypics and 1.6.1 running and all works perfect. I have one suggestion ... When i tag one person in a photo .... ¿is it possible "copy" or make a link to the tagged photo in the "main" galery of tagged person?

    This is the method used in facebook or tuenti network.

    Thanks

  • @Paolo - Not sure why your tagging doesn't work. When you click on "Start Tagging" does it change to say "Stop Tagging"?

  • @acidrain_lnx - when a user is tagged, it creates a relationship between the user and the photo. This in effect creates a new album though the current version does not fully expose this. You can click on the tag and see a list of all photos that person has been tagged in. The next step would just be providing a link to that off a user's profile or photo albums.

  • Hi, thanks for your answer... yes, when i click on "Start Tagging", it changes on "Stop tagging".

  • @Paolo - After you click "start tagging", does the cursor change to crosshairs when you mouse over the image? Can you click and drag on the image to create the tagged area?

  • After click "start tagging" the cursor doesn't change. It is always a default arrow cursor. and I can't click and drag on the image to create the tagged area. If i click and drag on image, i drag out the entire image but there is no way to select a particular area.

    Thanks for your attention

  • hey I found an error

     

    I created an album

    but when I click on Your photo albums link it doesn't show me my albums,

     

    but when I click on ALL SITE PHOTO ALBUMS its showing then

  • To Paolo:

    Try with other "theme". Last day i installed a cool theme, but i got the same error than you. Try with original elgg template and test again. I think there is a problem or conflict with theme.

    Test and tell us.

  • sorry my fault, actually I added that album in Group

     

    lolz sorry for that

  • to acidrain_Inx

    Thanks but I use the default template, i never changed it.... i really don't understand why won't works... i'm going crazy :-)

  • Problem solved √

    There was a files permission problem. Probably uploading files via ftp, some permission is changed. After change CHMOD all works fine. I can tag the images and the slideshow works so good. Thanks all for your time and sorry for my mistake.

  • Hi all, anyone can help me? when I give click the Save button, sends me to the following address:

    http://99.53.60.227/elgg/action/tidypics/upload

    When I look for that folder, I realize that there isn't http://99.53.60.227/elgg/action/ folder, but there http://99.53.60.227/elgg/actions/. Of course that does not rise any photograph. How can I fix it?

  • @JLuis - that is the correct address. Elgg uses rewrite rules and an action handler to include the correct file. Reasons for seeing this include:

    1. mod_rewrite is not working on your server (but I wouldn't expect you to be able to install the plugin if this were the case)

    2. an error in upload.php in the plugin - this is unlikely since no one else has reported this problem

    I'm guessing there is something wrong with your server configuration or the code has been modified.

  • @Paolo, how did you change the permissions? Since I moved to another server the "Start Tagging" Links doesn't appear anymore, I can see it in the sourcecode but it is nowhere on the page (I also changed Themes back to default and tried to disable several plugins, nothing worked...)

  • found it, it was a languagefile problem, I had to change

    <?= elgg_echo('tidypics:tagthisphoto') ?>

    to

    <?php echo elgg_echo('tidypics:tagthisphoto') ?>

    was this wrong code or some code my server couldn't work with?

  • Tidy Team,

    I get a nice view arrangement in "photo albums" but just funky layout when I click "latest photos" why the difference? The "latest photos" when clicked is just unacceptably ugly and cumbersom, how come they don't both just take you to the same place where their is a slideshow and also the nice new viewer from Wegali? Man you guys are close on this, just needs a few loose ends tied up. My last request is the same as ever, a widget that can be placed anywhere that is smaller slideshow in itself whether it's all lastes sitewide pics or a profiles entire collection, both would be great!

  • @Dahaniel - thanks for pointing that out. It is fixed in svn and will be part of the next release.

    @TahoeBilly - there are also some fixes for most recent photos, most viewed, etc in svn. Some of those pages were not wrapped with the contentWrapper div and are now. The pagination should be looked better now. We had to work around an Elgg bug.

    We will not be integrating the highside lightbox as it requires a fee to be paid for commercial usage. I am evaluating other lightboxes currently. For those who want to use it, Webgalli modified his plugin to work with Tidypics.

    Don't understand your last request. 

  • Thanks, I had the problem with some other plugins too, so if somebody runs into this, enable "short opening tags" in your php.ini.

  • Hello All. Does anybody knows how to resize izap-thumbnail videos to work with TIDYPICS. I would like it to be 110x110. I just seen a site that was spamming here witht that size thumbails. I looked at the code in fire bug it shows as an album cover settings from tidypics on the video thumbnails. Does anybody knows how to do this.  Making IZAP thumbnail bigger with TIDYPICS album cover settings.

Stats

  • Category: Photos and Images
  • License: GNU General Public License (GPL) version 2
  • Updated: 2022-10-10
  • Downloads: 144050
  • Recommendations: 232

Other Projects

View iionly's plugins