[Elgg 1.5-1.12 & 2.X: Tidypics] v1.10.6

Release Notes

  • Same code base as version 1.9.6,
  • Fix of deprecation issues occuring on Elgg 1.10 (namely changing output/confirmlink view to output/url view).
  • sorry for ask you basic question,but i just want to rename "photos" as " Album" how can i do that ???

  • @naughtyboy I'm not sure I understand what you have in mind. The term "album" is already used by Tidypics. An album is a container the photos a user uploads into it. So, changing the word "photos" to "album" might seriously confuse your users.

    If you want to change the wording nevertheless, you can do so by modifying the text of the language strings in the language files according to your wishes. I would suggest to not change the Tidypics language files themselves though (as you might lose your changes when upgrading Tidypics and not saving your changes before). You can include any modified language strings (not only from a single plugin but for any plugins and also from Elgg core) in a separate language file within a "customization" plugin. The Rename the Wire plugin (https://community.elgg.org/plugins/1497293) will give you an example of the basic structure of such a plugin that overrides the default wording of language strings with your own text. You don't need to use any of the strings currently included in the language file of the Rename the Wire plugin. They are just an example to show how you would be able to change the wording of the Wire plugin. Just add the language strings you want to modify into the language file of your customization plugin and place this plugin below the plugin(s) you want to change the wording of.

  • Olá, eu preciso de assistência que vai estar acontecendo quando eu carregar o plugin?

    Minha versão 1.10.5 elgg

     

    0 (guid: 236) não pode ser iniciado. Motivo: não foi possível incluir start.php para o plugin tidypics (guid: 236) em / home / server / public_html / mod / tidypics v.1.10.6

  • @Jaqueline Have you put the plugin files of Tidypics to the correct location? The "tidypics" folder should be within the mod directory of your Elgg installations with the file start.php in location

    mod/tidypics/start.php

    If start.php is for example at

    mod/tidypics/tidypics/start.php

    then it's wrong (all files of Tidypics one level too low). The Elgg can't find start.php and therefore won't activate the plugin.

    Or the permissions of the Tidypics plugin files might be wrong (missing read permissions) or the files and subdirectories within the Tidypics plugin folder might have a wrong owner and / or group. Then the webserver can't correctly access the files (not read them correctly) and again Elgg won't be able to activate the plugin. If the location of the files is correct, check if the permissions and owner/group of the plugin files are correct. The permissions might have changed, if you unzipped the Tidypics zip file locally (maybe on Windows) and then copied the files to the server. Instead of unzipping them locally, you could copy the zip file to the server and unzip the archive directly on the server. Then the permissions shouldn't get modified accidentally.

  • iionly,

    Thanks for a great plugin as ever, but I was wondering why images do not load on my Android devices... it appears to try and then says it failed to load.

    Cheers,

    Mark

  • @Mark Bridges you say "devices" (plural). May I ask which devices exactly (also info about Android version and which browser used)? Does it only happen on Android or does it happen also on desktop computers (possibly not with all browsers)? What version of Elgg and what version of Tidypics have you currently installed? Are the images of Tidypics not displayed at all anywhere or is it limited to certain kind of actions (e.g. viewing the fullscreen popup version of the image or on the activity page)? Are any other images on the site displayed correctly (e.g. profile images or images uploaded to the files section)?

    I can't test access from Android devices on hardware because I don't own any such device. I can test with a virtual machine though (different Android versions and different devices). I did some brief test today and it seemed to work fine (emulated Nexus 4 with Android 4.4.4) both in displaying the photos and also with uploading. If you could tell me which devices it fails to work for you I might be able to test it on the same device or at least a device as similar as possible.

  • Where can I adjust the number of picture thumbnails shown in the gallery btw? Thought it would be /pages/photos/all.php and tried to set limit to a differnet number than 16. But it did not show any effect after running upgrade.php

  • @Hanzolo Number of images per page is hardcoded in various files. You would have to adjust the limit within these files. Checkout the files under the mod/tidypics/pages/ directory. The line to modify is

    $limit = (int)get_input('limit', 16);

  • thank you for very wonderful plugin....

    1. Is there any way to change the the number of photos to upload, using Plupload HTML5/HTML4 uploader?. Default setting is 10 photos..
    2. Is there any way to make an album "public" where any logged in  user can upload their photos to that album irespective of the owner ship of album?

    Thank you

     

  • @Satheesh PM

    1. In mod/tidypics/views/default/js/photos/uploading.php the variable $max_files defines the number of images you can upload with the HTML5 uploader at the same time at maximum.
    2. Sorry. But there's currently no way to do that. In group albums all group members can upload images but group members only. For albums outside groups this is currently not possible (and I also don't know when - and if - I will implement such an option).

     

  • when i upload images its not show properly ,all image icon is broken what should i do?? i didnt enter path of image library(actually i dont know what to enter) that is reason of it??? elgg version is 11.1.2

  • @naughtyboy Entering something in the path input field is only needed when using the ImageMagick command line tools. And these have to be installed on your server to be able to use them (and in this case the webhoster should be able to tell you where they are installed).

    Likely reasons in case all images broken:

    • memory_limit too small and/or
    • post_max_size too small?

    These are settings to be done in Elgg's .htaccess file.

    Or the permissions of the data directory are wrong preventing any files to be saved (if uploading avatars also fails, this would be a likely reason).

  • there is no issue of avtar uploading ,so data directory is fine :) i will check memory limit and post max size tomorrow. Here is mid night and im feel bit slippy i will tell you tommorow after checking that :)

  • got a bug here in 1.12. if i use the comment icon in the main river/activity stream to add a comment to a river item for a tidypics photo, there are two problems:

    1. the resulting entry in the river for the new comment does not point to the photo. it instead points to a comment.
    2. the comment is not added to the tidypics photo's main list of comments

    i have tested this with other subtypes and it seems that only tidypics is effected.

  • Does it happen only on 1.12 or also on older versions of Elgg? I can't reproduce the issue.

    • Is there an upgrade button displayed on the Tidypics settings page?
    • Are you sure that no other plugin causes the problem?

    Tidypics does some specific handling of comments made on the river page:

    • one photo uploaded: comment goes to the photos's page,
    • more than one photo uploaded: comment goes on corresponding album page.
  • aha ok - the cause is somewhere in my theme. i should have tested that first by disabling the theme plugin, but i did already quite carefully compare my theme to the current 1.12 codebase for elgg and thought i had made all the called for changes.. i'll dig in there and find the cause. thanks for the tips.

     

  • having dug into this deeper, i have no idea what is causing this issue! i have found that the river item that is added to the river when i add a comment to an image, via the comment button on the river item for the image - is a standard 'comment' view, not a tidypics one. i can see that the tidypics comment handler routes to specific views for image comments and album comments - but not for tidypics batches. through adding log dumps to the comment handler, i can see that when my theme is activated, the river item that is being added for comments has a subtype of tidypics_batch and yet when my theme is deactivated, the river item is added with a subtype of 'image'.

    i have absolutely no idea why this is occurring as i haven't deliberately altered this part of elgg in my theme. any tips on how this might be being triggered are welcome!

  • so this only occurs when the tidypics admin setting for river items is set to show tidypics batch objects and a batch is uploaded, rather than break the images into individual river items. though this still doesn't explain why the item is being created as a non specfic comment, rather than a tidypics comment when my theme is enabled!

  • Is your theme registering anything to the 'creating', 'river' plugin hook? If yes, this could override the handling of commenting on Tidypics river entries done by Tidypics.

    I'm afraid I don't know what else to say. If it only happens with your theme enabled, it must be something done in the theme and I can't test this out myself obviously.

  • no, there's no use of the 'creating' hook. i had not even heard of that one before. i understand that you have no clue either, yes. it's a weird issue as i really haven't changed any logic related to this in my theme deliberately and no related keywords (that i am aware of) come up when i search my theme.

  • Not knowing what code is in your theme I can't tell you what to look for exactly. I can only guess that there's some plugin hook used that alters either the creation or the display of the river entries' views. Something is conflicting with the Tidypics code that creates the river entries when commenting on the Tidypics image upload entries. If you could show me this code I might be able to tell you what goes wrong. But without knowing the code I can't do anything.

    Are you sure that it's the theme that causes the problem? If you disabled any other plugins for testing you might be looking in the wrong plugin's code.

Stats

  • Category: Photos and Images
  • License: GNU General Public License (GPL) version 2
  • Updated: 2018-9-16
  • Downloads: 128079
  • Recommendations: 261

Other Projects

View iionly's plugins