Language Selector v1.0.4

Release Notes

1.0.4:

 - fixed: secured action url for changing language (needed for Elgg 1.7)

 

1.0.3:

 - added: flag for denmark (da)

 - changed: flag for sweden (sv)

 - fixed: cookie now set for correct path (/)

 - fixed: issue with selecting languages for non logged in users (again)

 

1.0.2:

 - fixed: issue with selecting languages for non logged in users

 - added: flag for zh (chinese) language

 

1.0.1:

 - added: flag for hebrew

 - fixed: current language onclick action incorrect 

 - fixed: dutch translations

 

1.0:

 - first release

  • is there a flag for spanish???? where can I see an example of this plugin? 

    Thank you!!!

  • Hi Jeroen,

    Thanks for the plugin update! The logged out user side seems to be working fine, but the logged in user function loads a blank page when it switches languages, like this:

    SITENAME.COM/action/language_selector/change?lang_id=ja&__elgg_ts=1271222107&__elgg_token=240c1035823b4ef38c0cf8dc435b1faf

    When you press the back button it has indeed changed the language but is there something I could do to make it switch without going to the blank page?

    Thanks again!! :0)

  • Hi! Awesome plugin!

    Is it possible to change the language "The name of your site" field somehow with (or without) this plugin? 

    thanks

  • @lou

    Interesting the loged in users can switch the languages and it works fine for me but the selector dosen't work in loged out mode :( it happens nothing. I use elgg 1.7

  • @puffi I had a similar problem on an earlier version of language-selector, me and another guy seemed to fix it by setting the default language (in the admin screens) to the non-english option (my site is only bi-lingual, haven't tested with multiple)

  • As someone said: Loged in users can switch the languages and it works fine for me but the selector dosen't work in loged out mode :( it happens nothing. I use elgg 1.7

  • Update!

    The white screen of death, WSOD, blank pages problem was caused by extra lines outside the pair on a Japanese language pack I downloaded. As hinted to on this google discussion about blank pages, and easily identified after looking at the server cpanel controlled error log.


    [Mon Apr 19 03:12:26 2010] [error] [client ???.???.???.???] WARNING: 2010-04-19 03:12:26 (EDT): "Cannot modify header information - headers already sent by (output started at /home/username/public_html/languages/ja.php:1093)" in file /home/username/public_html/mod/tidypics/thumbnail.php (line 73), referer: ???.com

    Apologies Jeroen, the WSOD is cured and, @DJuse again, although I had that problem on earlier versions of this plugin, I first fixed it on v. 1.0.1 by setting the site language as the non-english option in the admin panels, but in the latest version it works fine for logged out users as well on my site

  • * outside the   < ? p h p   ? > pair

Jeroen Dalsem

Owner of ColdTrick IT Solutions, developing social networking sites for the dutch market

Stats

  • Category: Language packs
  • License: GNU General Public License (GPL) version 2
  • Updated: 2019-3-20
  • Downloads: 12290
  • Recommendations: 35

Other Projects

View Jeroen Dalsem's plugins