iZAP-Videos, Full featured videos plugin v4.2.0b

Release Notes

I am feeling so good while release this new izap-videos version. We have introduced so cool features in this release which would help users who has no dedicated resources. but they want to offer videos uploades to their users. In this realse, we have implemented YouTube development API. Now end users would be able to upload their videos under their YouTube account via your site. Your videos would not be processed by your server they would be processed by YouTube servers. 

For those who can afford videos processing and hosting on their servers would be continue. Actually videos upload can be switched from youtube to onserver and viceversa. 

### Version 4.2.0b ####

Enhancements:

  1. Youtube upload via YouTube Developer API.

Bug fixes: 

  1. Some shared hostings has no availability of "file_get_contents". So we have removed that and instead of that, we are doing curl request.
  2. Bugs mentioned by the community in last release.
  3. Removal of Deprecated function.

Minimum Requirements:

  1. Of Couse izap-elgg-bridge. You can download it from https://github.com/pluginlotto/izap-elgg-bridge/archive/v2.1.4.tar.gz. Github version must be renamed to "izap-elgg-bridge" after extract. If you do not want to go for this. Than you can download from pluginlotto itself. http://www.pluginlotto.com/store/product/sona/26014/izap-elgg-bridge-version-214-free-elgg-plugin.

How to install izap-videos for (embeddable + YouTube Upload).

http://www.pluginlotto.com/blog/view/23099/how-to-install-izapvideos-for-elgg-embeddable-youtube-videos

Declaration about Arvixe Warninghttp://blog.arvixe.com/a-warning-about-using-izap-plugins-for-elgg-1-8/)

After I finally got the framework, I installed it like you normally install a plugin in Elgg. However, when I tried to use it I couldn’t because I had to register my domain name in their site. In other words, I had to give the address of my Elgg network if I wanted to use the plugin Izap Disk Quota. That’s just plain wrong, because there’s no reason why a free plugin will need my domain name. I find it suspicious, and I believe it sends server information to the developer, which is wrong.

 Above was written by Rodolfo Hernandez

@Radolfo, Your questions are valid. I would like to clarify all.

Why do we need you to register on pluginlotto.com?

Guys, We are poviding video pulling feature in izap-videos. This is something like, Your server will send a request to our server with video url (youtube, 5min ....). Our API recoganize this request with the registered API which is suppose to send with every such request on our server. And for authorized requests, our server is sending back the requested data. This is something like "http://embed.ly". But they are paid. We have created our own API with some sites support (Youtube, vimeo, 5min etc ( have plans to upgrade this support in future ). So we are providing video pulling free of cost which is actually costing me for my dedicated resources. So it is fair enough to atleast authenticate every request we are serving. Hence need to register API by putting your domain.

Can i use iZAP's plugins without putting my url in pluginlotto.com?

Of Couse Yes, If you do not want to use izap-videos plugin, So there won't be any such vidoe pulling request. Than you no need to put your domain name on pluginlotto.com. You can simply download izap-elgg-bridge from github too. I gave url above. And can download any other plugin like "izap-diskquota" etc and use that without putting your domain name on pluginlotto.com. It is only required when you want to install izap-videos plugin.

Are we pulling any servers information?

No, we are not pulling any server information like My friend @Radlfo pointed out. In futere if we need to do that. It will be asked you and if you allow, only than we will do that. But yet we have no such plans.

 

  • It could be.  Like I said I use On server so I've never recently tested the embed feature until now.  It's definitely timing out though when I click the "embed videos" (/videos/add/mydomain/offserver/) tab.  Since I use On server by default when I click "on server" it goes to "upload videos" (/videos/add/mydomain/onserver/) instead.  Without knowing all the details logic makes me inclined (but not sure) to think it is related and has to do with the Elgg bridge/site too.

    Also it looks like pluginlotto.com is down now too.  http://www.downforeveryoneorjustme.com/www.pluginlotto.com "It's not just you! http://www.pluginlotto.com looks down from here"  That is strong evidence of a connection.

  • aha taking the URL and not the share/embed code everything is working.... Thanks Ron!

  • Offserver looks to be working again on my site.  Pluginlotto.com is back up so it must have been just that. :)

  • gts fan9: Thanks. Looks like we are up and going again. Since you investigated pluginlotto.com and found it down, and now that it's up again, we too are working again. I'm not sure what to think about that. I don't like the idea that our business success is dependent upon a plugin.

    charismeki: glad to hear it.

  • Now that we are up and going again, I thought I'd share what we are having to do to make are videos presentable again so tha the thumbnails display. We're having to reload them all. It's not too tedious just a little timeconsuming. I will say though that however it happens the slide that is picked to be the thumbnail automatically upon load generally is pretty nice.

  • wow, nice plgin.

    I just wanted to know how to upload a vide or add a youtube url to a GROUP FOLDER. when I click upload button it takes me to a page where I can add url, define tag, select  categoy, but select  folder (like in files) does not show-up. thanks.

  • @Wakadala Mato Philip, I don't see that functionality either.  I think maybe it is something that would need to be written into the file tools plugin (assuming that is what you are using) so that it could extend Izap-videos to do that?  I might be wrong.

  • @gts fan9 and @Wakadala Mato Philip, YouTube upload has it's own restrictions, like to keep categories while posting videos. Since these are not elgg defined categories, So izap-videos is considering them as tags and saving these categories.

    @Ron Wallace: video pulling api is getting so much traffic. for the timebeing, corresponding services has been restarted. I am not sure, but it might be spam. So tring to find out and will ban all such spammers to ping our service.

    Thank you.

  • Hi,

      I am using izap video plugin. Could you please help me to remove flv conversion in this plugin. I need mp4 or 3gp outfile from izap video onserver upload. Is available any settings in this plugin? Please help me? Thanks in advance...

     

     

  • Currently there is no such options. But i can consider this features in next release. Please post this requirement on https://github.com/pluginlotto/izap-videos/issues

    i'll consider.

  • Hello, It works fine, I can upload videos from my pc with this plugin, but when I put the url of the youtube video doesn t work. I´ve a youtube developer key.. where am I wrong?

  • xhipri09: don't know - the url always works for us. what is one of the urls you are trying to use, and I'll be happy to test it.

  • @xhipri09: the youtube developer key does not help you at all - it's not needed. You need to register an API key at pluginlotto.com. See: http://www.pluginlotto.com/blog/view/23099/how-to-install-izapvideos-for-elgg-embeddable-youtube-videos

  • @iionly thanks a lot! it was my fault, becouse surely I´ve registered in plugin loto with the http path and the key was not the one I needed. Now it goes very goood!!!! RECOMEND PLUGIN!!

    @Ron Wallace thank you for your rapid answer! it was my fault!

  • Now I can embed videos with this plugin but cannot upload from my PC.. Here the analysis of the izap:

     

    PHP interpreter test Fail PHP interpreter not found. 
    Action: Be sure the provided path is correct in admin settings. FFmpeg Fail - See more at: http://...

    About what path is talking? The database path and elgg path instalation is OK

  • i just tried out the linking to youtube videos via url. something is going wrong with my viewcount. i went to the video list and it was 3 then i watched it and it was 4 but upon returning to the list it was 6. i will check again to make sure.

  • i am on elgg 8.12 and my viewCount seems to be incrementing incorrectly: http://youtu.be/9LWMu50I4GI

  • I've registered API key but every time another user uploads it asks for google login???

    I got a APIv3 youtube!

  • Elgg Release - 1.8.16 on Arvixe

    izap-elgg-bridge-2.1.4 (guid: 243) cannot start and has been deactivated. Reason: Cannot include start.php for plugin izap-elgg-bridge-2.1.4 (guid: 243) at /home/demyden/public_html/elgg/mod/izap-elgg-bridge-2.1.4.

  • Buenas!

    Yo estoy usando izap videos con exito. Lo que quisiera es que al subir los videos a youtube que se suban a mi canal y no al canal del usuario ya que de esa forma ellos no necesitan estar logueados en google, tampoco tener un canal de youtube.

    Gracias

  • Any script or plugin to import videolist videos to iZap Video plugin?

    I have more than 600 tubes in my site... better a script than manually! ;-)

  • Hi,

    upgraded to elgg 1.8.16 and latest iZap bridge 2.1.5 and videos 4.2.1b both from github.

    Activated ok but I still see the https youtube issue "Error saving thumb, unable to write the file on server" any solution?

    Those https videos from youtube can not be added at all and the problem is that if you add alternate http link from youtube on a https site like mine, all browsers block the visualization because of the 'mixed' content on the page and users simply think the site has something wrong...

    Cheers

  • Hi guys,

    great plugin, thank you. I just have some little problems I can not solve.

    Right now elgg runs on a VMWare, local only.

    The Server ist Apache/2.2.15 (Oracle)

    The PHP is 5.3.3

    Elgg Verions is 1.8.16

    The plugin versions are: iZAP elgg bridge 2.15, iZAP videos 4.2.1b

    1) The Thumbnails of uploaded onserver videos are poor quality. They are much better with the old Version 3.8.2b, even using the same ffmpeg command "/usr/bin/ffmpeg -y -i [inputVideoPath] -vframes 1 -ss 00:00:10 -an -vcodec png -s 640x480 [outputImage]" How comes?

    2) I can not embed any youtube videos anymore. It worked a few weeks ago. I don't know what I changed until then. Maybe I have some problems with other plugins. Are there known incompatibilities?

    I also deactivated some plugins like TinyMCE and Embed. I suppose I don't need them for that, because embedding doesn't work when they are turned on either.

    Maybe someone has an idea or knows how to solve the problem. Would apreciate that!

iZAP

We are leading elgg providers. We have implemented complex combination of applications like "elgg + elasticsearch + cloud infrastructure + comet server for active pages"

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-3-13
  • Downloads: 56705
  • Recommendations: 107

Other Projects

View iZAP's plugins