iZAP-Videos, Full featured videos plugin v4.1.3b

Release Notes

Version 4.1.3b
Bug fixes:
1. Flv videos should be skipped from conversion process.
2. Wmode transparent for onsrever player fix.

  • @ izap thanks for updating the plugin. 

  • I would appreciate if you guys keeps recommend if it really worth of your recommendation :)

  • Thanks for the new version. I seem to get some errors, I know I am doing something wrong, but could not resolve:

    - When I activate the İZAP Video 4.1.3b, I see the 'Invalid Admin Section' error. I've got the same error on 4.1.2b yesterday.

    - When I add İZAP widgets, I get the error message: 'Deprecated in 1.8: widgets use content as the display view Called from [#9] C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\elgg-1.8.4\engine\lib\views.php:503'

    - When I look at the dependencies of İZAP Video, I see pdo_sqlite is missing. I notice that pdo_sqlite is 'Suggested' as opposed to 'Required' (though in INSTALL.txt, it is among the minimum system requirements). Does 'Suggest' mean it is optional? I am using PHP 5.2.17 (VC6 thread safe) for Windows. PHPInfo says 'pdo support' enabled and with driver sqlite2. As well as 'SQLite Support' enabled. I can not see anything 'pdo_sqlite'.

    I have elgg 1.8.4, elgg IZAP Bridge 2.1.1 running on Windows Vista 32bit with Apache 2.2.10. I got FFMPEG from and copied ffmpeg.exe (from static package) under C:\Windows\System32 (find an .msi package hence only manual copy).

    What am I doing wrong? I appreciate any help. Regards.

  • @İşöğünçı: delete the izap_videos folder from your mod directory first. Then copy the new version again on the server. I think at least some errors are caused by files that remained from the previous version and are no longer needed - and even cause issues now.

    I think you need pdo_sqlite only in case of on-server videos. If pdo_sqlite would be "required" as opposed to "suggested" you wouldn't be able to enable izap_videos even when you don't want to use the on-server videos function.

  • Thanks for this plugins IZAP, I think an excellent job, however we can not activatebecause it has dependencies incumplidad design "requires Izap elgg-bridge-2.1" andthis plugin can not find it. It could help us.

    Grace.

    Translated with google.

  • Thank you for attending our concerns so quickly.

  • @ izap i had already recommended it and am willing to recommend it again but one person one recommendation policy hinders me from doing so............:). Anyways good work guys. Keep up the good work.

  • @ izap i visited your site i.e pluginlotto.com and saw the free plugins.I was like ahaaaaaah.Only one question. Are all the plugins 1.8 compatible?

  • @coolsam: Thank you to appreciate our job. And yes you are right. we are opening all of our plugin. I have good reasons to open all of them. We have around 15+ plugins. And i am interested to open all of them for elgg community.

    Soon, you will find our publication about this.

  • When i click to activate izap-elgg-bridge, next page its blank and when i remove the plugin folder these message appear on plugins page:

    izap-elgg-bridge (guid: 144) cannot start and has been deactivated. Reason: Cannot include start.php for plugin izap-elgg-bridge (guid: 144) at D:/EasyPHP/www/elgg/mod/izap-elgg-bridge.

    Hope you can help me and sorry for my english...

    Thanks

  • Many thanks iionly for your reply. I have tried several times deleting the izap_videos folder and recopy from the zip file. No avail. I get the same issue.

    The thing is; In the INSTALL.txt it says: "Go to izap-videos plugin settings from admin panel and Click on Save once to save all settings". But I do not have any settings for izap-videos under the Configure menu! I only have settings for 'İZAP Elgg Bridge' which I configured. What I instead have is: When I activate izap_videos, I get a menu on the admin page (on the same level with 'Configure'), called 'Develop' with the menu option 'admin:utilities'.  When I click it, another submenu appears: 'admin:utilities:izap-videos-server'. Could this be a hint? And when I click it, I see 'Invalid Admin Section' on the detail page.

    Is there anything else that I should have done like some additional php.ini or apache settings?

    Regards.

  • @iaio: With my limited knowledge: Are you sure that you have the start.php file direcly under the izap-elgg-bridge directory? (this is the directory which originally comes as "izap-izap-elgg-bridge-04ea80b" in the plugin download file and you should have renamed to "izap-elgg-bridge").

    Could it be the case that you have instead by mistake renamed the top level "izap-elgg-bridge-v2.1.1" directory (in the original release file) which does not have the start.php file?

    regards.

  • @İşöğünçı: from where do you download the izap_videos plugin? Are you sure you have the latest version installed? Try the versions of izap_videos and izap_elgg_bridge from pluginlotto. I just tried them and they work.

  • @İşöğünçı: thx for your help... i download izap-bridge and izap videos from pluginlotto page and bridge works for me...
    My problem now its with izap-videos, when i active the plugin, i was redirected to plugin config section and there these message show:

    Invalid Admin Section.

    i put all permissions on 777 and all dependencies are ok

    Hope you can help me again... thx...

  • well, you simply need to browse izap settings from admin panel. Actually it needs you to browse that particular page to save all settings. this is elgg behavior.

    But when you get such page, i am sure izap-elgg-bridge will be placed after videos and you activate the plugin in this location.

    Before activation, izap_videos must be after izap-elgg-bridge. First you will need to activate bridge plugin and than videos.

    current solution for you.

    1. put izap-elgg-bridge on top of your elgg.

    2. browse settings of videos plugin from admin. And make change whatever you required. This will simply make things work for you.

  • @iZAP:

    There's one little error with izap-elgg-bridge though. In case you have enabled izap-elgg-bridge but not yet registered an API key there is displayed an error message at the top of the admin section. Within this error message a link to the izap-elgg-bridge plugin settings is included. This link does not work in case your Elgg installation is installed in a subdirectory. The link url does not include the subdirectory and therefore clicking on it leads to a 404 error.

  • @izap, @iionly, @İşöğünçı:

    Check my images... i show you how i have my izap installation on my elgg 1.8.5 local site...

    in my first image, that its the page looks when i activate izap videos plugin...

    http://www.subeimagenes.com/img/error-285102.html

    http://s2.subirimagenes.com/imagen/previo/thump_7742310error2.png

    http://www.subeimagenes.com/img/error3-285105.html

    Thx for your help !!!

  • @iaio: something must have gone wrong obviously. You seem to have the latest version of izap_videos and izap-elgg-bridge installed but the "admin:utilities" button text in the first picture shows that the corresponding language string (in this case "iZAP Utilities") could not be found for some (unknown to me) reason. Either you have not the latest versions installed after all or there are some files included in these plugins corrupted or missing on your server. Try disabling both plugins, then remove the plugin folders from the mod directory. Then refresh the site cache. The  download the latest versions of the two plugins again from pluginlotto and re-install.

  • @iionly: ok, i will try again !!!

    Thx, and later i told you if videos work for me !!!

  • @iionly  Hi, I downloaded the izap_videos plugin from this page (4.1.3b), is it not reliable?

    regards

    p.s. it is placed under bridge plugin in the plugins order.

  • The version available here should be okay, too. It seems to be exactly the same as the file available on pluginlotto. If it does not work, it's either due to some incomplete files when copying the plugin to the server, some issues with Elgg site cache (refresh the site cache), maybe a problem with language setting (in case you have not the default language English set) or it is a conflict with another plugin (though I can't think of any).

    In case you have set file permissions to 777 for all files this could also result in problems. The problem is that this is highly insecure for files within the Elgg root path which are accessible via internet. Therefore, the server could block accessing any files with 777 permissions.

    I would suggest to delete the izap_videos and izap-elgg-bridge folders. Then refreshing the site cache before installing the plugins again.

  • @iionly: ill do all what you say and still happen the same to me...

    i download both plugins (bridge and videos) from pluginlotto...

    i really dont know what happen...

  • @iaio: I'm getting out of ideas what to suggest unfortunately. What version of Elgg are you using? Had you been using any previous versions of izap_videos on your site before?

  • I've noticed that when a video is selected via the "latest videos" river feed on my sites main page, the view counter works perfectly but if the same video is selected from the "site url/videos/all" page after accessing it from the drop down menu, the counter is then set to 1 view and then no longer records video views at all. Any ideas?

iZAP

We are leading elgg providers. We have implemented complex combination of applications like "elgg + elasticsearch + cloud infrastructure + comet server for active pages"

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-3-13
  • Downloads: 57479
  • Recommendations: 103

Other Projects

View iZAP's plugins