iZAP-Videos, Full featured videos plugin v4.1.2b

Release Notes

### Version 4.1.2b

#### Enhancements:
1. Improved full page display.
2. Screen shots has been added according to the manifest recommendations.
#### Bug fixes:
1. Critical fix of view counter. It was doubling the view counters.
2. Quite small changes in language file.
3. Some function name changes as per the recommended conventions.

Download latest version of izap-elgg-bridge: https://github.com/izap/izap-elgg-bridge/downloads

  • I have the follow issue:

    Error Fatal

    izap:izap-videos:izap_videos_lib no es una librería registrada

  • This plugin reguires that you php.ini file is modified so that allow_url_fopen on
    Is there a security risk here? Import remote php scripts instead of uploading a video? Just curious. Thanks.

  • allow_url_fopen - is usually a potential risk; but one could trap and detect the referrer to conditionally and temporarily switch this on for the prequisite izap videos functionaliy.

  • I still have the same error

    Error Fatal

    izap:izap-videos:izap_videos_lib no es una librería registrada

    The php.ini configuration is well (allow_url_fopen on)

     

  • https://github.com/izap/izap-elgg-bridge/downloads

    404 error page not found.... where shall i download izap elgg bridge???????

  • I have a issue.

    Fatal Error.

    izap:izap-videos:izap_videos_lib is not a registered library

     

    I cant embed a video. I have 1.83 elgg version.

  • Existe algun problema en la version 1.83. Los enlaces de Youtube no funcionan. Que puede estar pasando?

  • Hi,

    I'm having same issue as DAYLORD, upload file, the original file is in tmp folder. But the conversion process is not running and never finishes.

    Has anyone found solution for this?

    Thanks.

  • Anyone else experienced this problem uploading/converting videos via ffmpeg?

    Thanks.

  • @DAYLORD, have you figured out anything on this?

    Can anyone shed some light here? Izap Team ? anyone had this problem?

    Thannks.

  • Anyone?

    Anyone had success with converting?

  • @NoobyNoob: I'm not yet using the latest version of Izap_videos but I'm still on version 3.71b on Elgg 1.7. Uploading videos and conversion via ffmpeg works for me, but it can be quite tricky to get it running. You should test a few things to see where the problem is:

    1. try uploading a video that is in flv format. This video won't need to get converted, so you can check if uploading works.
    2. test out ffmpeg via command line to make sure it works on your server. Depending on the available version of ffmpeg the command parameters can be quite different. If you get a working parameter configuration on the command line it should work with the same parameters via izap_videos replacing the names of the input and output video files by the placeholders used already in the default izap_video command.
    3. Is sqlite installed on your server and is it enabled? I believe you can check that using phpinfo().

    If you checked this and it still doesn't work you might need to investigate the possible reasons more thorougly (checking logs etc.)

  • @iionly, thanks for your input :) much appreciated

    yes I'm running latest izap videos on Elgg 1.8.3

    Files are geting uploaded as they show up in tmp folder (elgg data folder) after upload, also in "Server analysis for videos (iZAP Videos)" utilities page in Admin, all dependecies have been met ( eg. SQlite, ffmpeg command, php, etc.)

    Interesting tho that in "Utilities:Queue status" izap page in Admin there are no files getting converted (says " Quene empty") Does it need cron ?

    I'll try uploading flv file to see if that makes a difference and will report back.

    Thanks.

  • Tried uploading flv file and same thing , file is uploaded to tmp folder but on file page it says "Video quened for conversion..."

    It must be broken code in izap_videos plugin I guess. :(

    Any suggestions?

    Thanks.

  • FLV videos should not go through conversion queue at all but copied to the users data directory directly. Maybe they show up in queue during the copy process though. What size have you set for post_max_size and upload_max_filesize in .htaccess? post_max_size needs to be larger than the uploaded video for the copy to work. Best would be twice the intended max video size.

    Regarding dependencies showing all green... ffmpeg can still fail to convert when the paramters for the conversion command do not fit to the installed version of ffmpeg. Especially, the pre-defined quality parameters (-vpre hq) and audio paramters are quite different in more recent versions of ffmpeg. You can check your server log if there are any error messages from ffmpeg included. Or you can test out the conversion parameters by converting a video from the shell (in case you have ssh access to your server).

    I'm also not using the crontrigger plugin (in Elgg 1.7) that's no longer available in Elgg 1.8 anyway. I once had a problem in Elgg 1.7 when using cron to trigger the queue. Since then I'm not using any cronjobs to trigger the queue.

  • I don't undestand why it woud Queue flv file for conversion.

    My post_max_size and upload_max_filesize are at 16MB and files I'm uploading are 2-5 MB so that should be ok.

    I see what you mean about ffmpeg. But uploading flv file still does not work either, I'm lost now. Maybe just have to wait for another video layer being developed or new release from izap.

    Thanks for your help iionly, much appreciated :)

  • I installed the the izapp-elgg bridge and when I activated it I got a huge error message and could not do anything with my site. So I deleted the plugin file from my server control panel and now most of my site is not functioning at all. I can log in but there is no administration tab, no settings tab, no nothing.  Can anybody help me out with this? I don't understand how removing just that file would cause all the other features to simply disappear.

    Thank you

  • @tbevel: izap_videos needs izap_elgg-brigde. If you still have izap_videos installed after removing izap_elgg-bridge, then remove that plugin, too. Then call http://yoursite.url/upgrade.php to flush the site cache. Hopefully, everything will work again afterwards.

  • Thank you! All is back to normal. :)  

     

  • @NoobyNoob: problem has been fixed in newer version. I'll upload it later today. But if you need you can download that from http://github.com/pluginlotto/izap-videos

  • We just released newer version of izap-videos version 4.1.3b plugin having couple of fixes. http://community.elgg.org/pg/plugins/izap/read/384975?release=874585

  • It works but i have this error register_entity_type() was deprecated by elgg_register_entity_type.

    And i use the last version.

    Any idea

     

     

  • when i download the file it pops up as a text file.  This is my first time attempting to use this plugin am i doing something wrong?

iZAP

We are leading elgg providers. We have implemented complex combination of applications like "elgg + elasticsearch + cloud infrastructure + comet server for active pages"

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-3-13
  • Downloads: 56755
  • Recommendations: 107

Other Projects

View iZAP's plugins