iZAP-Videos, Full featured videos plugin v3.62b

Release Notes

Release 3.62b

This release is more concerned to the bugs we are getting requests to get resolve. I would request to all of you to get involve in this testing.

Enhancement

  1. New flash player for on server videos.
  2. Queue reset option from admin panel.
  3. Compatible with elgg (1.5.1, 1.6.2 and 1.7.1).

Fixes

  1. View counting issue.
  2. Better pdo_sqlite drivers loading.
  3. Now there should be no Warning, Notice in error.log by izap_videos. Let us know if you could find something regarding that.
  4. We worked to suppress even deprecation messages due to newer elgg versions. System will make function calls according to the version of elgg.

Release 3.61b

Cool enhancement

  1. We decided to removed "izap_videos" from URL. now you can enjoy urls like "www.xyz.com/pg/videos/xxxxx". Complete branding for you :).

Fixes

  1. Small fix in video play page for elgg 1.6.1 and elgg 1.5

Release 3.6b

In the previous release we added the support to monitor the actual ffmpeg process to be sure about if queue is running or not. But that was behaving different on different server configurations (dual core, cord core). Number of cores effect on the number of threads of ffmpeg and hence background processes. So that's why it was behaving differently on different flavor of servers. To over come this, we stop this monitoring and start to see the queue status via sqlite db. And i tested it alot here, and it's working perfectly and now we also restored windows support. WAMP is tested with this version.

Release 3.55b:

In the previous release, We got so many queries regarding intense database load of background process. And even some shared hosting providers having ffmpeg support banned some accounts because of eating of lots of database resources by the background processes. Reason of this was obvious, Queue is working in background and we were saving all queue elements as elgg object in database. And used elgg framework, we all know. Database is the thing where we need to take it seriously. And more over izap_videos plugin need to be optimized according to the demanding feature in almost every social networking site. So we solved this by using Sqlite queue management. To see result you can just try http://elgg.izap.in

How do we planned stability in this version:

In this version we have removed complex video conversion preset command and use simple ffmpeg command "ffmpeg -y -i [inputfile] [outputfile]". I setup a testing lenny instance of a server. than simply install ffmpeg using lenny package manager. And setup elgg with izap_videos. And it was working perfectly there was not any issue. Please post your feedback. And if it works for you. than post your server environment and give us one recommendation. As we will reach to the recommendation of 20. We will change this beta release to stable one.

  1. You can control plugin setting either you want to keep original video file after conversion
  2. Sqlite implementation to cut down all background processing.
  3. More control in queue management.
  4. Implemented Trash, This will just put videos in trash having any issue. it could be ffmpeg supporting libraries. Admin can delete them or can restore them after fix.
  5. Cron implementation to re-trigger queue in case of sudden interruption in the queue. You can manage cron timing according to your need.

Upgrading from previous release:

  1. Backup your database and izap_videos folder.
  2. Disable izap_videos plugin from your admin panel.
  3. Download and unzip izap_videos version 3.5 and place it in mod directory.
  4. Re-enable this new izap_videos plugin from you admin panel.
  5. You may need to re-enable ON-SERVER support from setting tab of izap_videos plugin settings.
  6. Clear simple cache.

New installation:

  1. Download and unzip the plugin in your mod dir.
  2. Enable it from admin panel.
  3. Clear simple cache.

ONSERVER Prerequisites:

  1. PDO sqlite drivers must be installed. This release and all future release will support queue management using PDO sqlite.
  2. ffmpeg and all supporting libraries.

Optional Prerequisites:

  1. notifications p lugin
  2. crontrigger plugin
  3. messages plugin

Optional plugins will give you better control over izap_videos plugin. These optional plugins are only required for ONSERVER support. If you leave them, izap_videos will yet to work with its basic functionality.

Bug fixes:

  1. Access control of uploaded video.
  2. Cutdown elgg-db communications to save resources
  3. Delete video entity will also delete all related media.

Compatiblility:

  1. Elgg 1.5
  2. Elgg 1.6
  3. Elgg 1.7a
  4. Elgg 1.7

Operating system compatiblity:

  1. *nix (confirmed)
  2. Windows (working perfectly tested with WAMP)

We are releasing beta release so we could collect feedback from all of you. Post your tickets at https://izapvideos.googlecode.com

I am twitting on: http://www.twitter.com/the_izap

I am blogging at: http://www.tarunjangra.com

Follow below our group discussion:

http://community.elgg.org/pg/groups/forum/340718

  • It seems a bug that had already been fixed in earlier version returned with 3.62b:

    When deleting a video from the site the related files (flv, snapshot pngs) are not deleted from the user directories on the server. I don't know if the original video file would also remain undeleted as I've set these files to not being saved after conversion.

    This error occurs both in Elgg 1.6.2 and Elgg 1.72.

  • Version 3.62b defines quite strict rules for htlmlawed. In start.php line 69 $CONFIG->htmlawed_config is set to

    $CONFIG->htmlawed_config['elements'] ='object, embed, param';

    In my case this resulted in banner links being stripped from spotlight (vazco_spotlightedit plugin). It might help to be less strict:

    $CONFIG->htmlawed_config['elements'] = 'object, embed, params, param, b, i, ul,
                                              li, u, img, alt, a, blockquote, span,
                                              style, p, strong, em, ol, br';

  • @iionly:
    Thanks for your feedback. Actually, it was only to be concerned to the flash object. That's why we make it more restrictive in this version. I think, every user can edit this set according to his personal need.
    Thanks

  • I have a problem to display video player in activity river ,I am using 3 colum riverdashboard , Only url is shown no player , please help me to resolve this issue.

    Thanks

  • I have a problem with conversion jobs getting finished successfully. It might be due to lack of available memory. Php limits should be okay (unlimited execution time, memory limit 64 MB, VPS with 512 MB RAM).

    The upload is okay for all videos and snapshots are also created. And small videos (~5 MB) get also converted successfully. But slightly larger videos don't work. I'm not sure at what point the conversion fails exactly. Maybe the conversion itself gets even finished.

    I noticed in top that ffmpeg occupies about 42 MB memory. In the izap_videos queue the progress of conversion showed. But the queue entry suddenly shows file size 0 both for the original file and the converted file. The converted file is also nowhere to be found while the original file is still in the tmp folder.

    I'm wondering if izap_videos tries to allocate more memory at this point to copy the files into the upload folder and then fails leaving a stub in the queue?

    Other possible reasons for the problem? File and folder permissions seem okay. Server is running with suphp and suexec enabled. But the fact that it works for small videos seem to exclude these factors.

  • How to display video player in riverdashboard,please anybody help me.

  • VPS - RAM requirements:

    As I mentioned in my earlier message I had some problems with conversions of even small video clips failed. After upgrading from 512 MB to 1 GB this issue doesn't happen anymore - so it was most likely really just a "Out of memory" issue.

    Using izap_videos on VPS with Onserver video option enabled seems to require more than 512 MB RAM. Of course, it may depend on site traffic and other services running, but even a few site visitors surfing might leave not enough free memory for video conversion in this case. 1 GB RAM seems to be recommended.

  • @IZAP:

    I get an "500 Internal server error" instead of the "All videos" and "Friends" videos" lists. I still can access my own videos. With another user account I also can access the "Friends videos".

    Soon before this problem started someone added a video - I don't know yet if embedded or uploaded to server. This user is on the friends list of my main account but not on the friends list of the other account. Could some issue with this latest video cause the problem with accessing the site videos and friends video lists?

    What can I do now? There are no queue entries and also no files in the user's data directory. My site is running on Elgg 1.6.2.

  • HI,

    Is there any possibility to show player in river activity. PLease reply I am waiting for you answer.

    Thanks

  • Hi,

    All settings seems to be ok. All in green. But queue status not running.

    Is there a script to call and run the queue / convert videos manually?

    Any idea why queue is not running? I´m using elgg 1.5

    Thanks in advance

    Queue status: Not running (1) www_domain_com_izap_videos_1279607486_todor.avi
    www_domain_com_izap_videos_1279607486_todor_c.flv 32.18 MB
    0 B

    izap_videos version: 3.62b exec() Success Required to execute the commands. cURL support Success Required for fetching the remote feed. PHP interpreter test Success PHP 5.2.4-2ubuntu5.10 with Suhosin-Patch 0.9.6.2 (cli) (built: Jan 6 2010 21:59:29)Copyright (c) 1997-2007 The PHP GroupZend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies with the ionCube PHP Loader v3.1.33, Copyright (c) 2002-2007, by ionCube Ltd. FFmpeg Success FFmpeg SVN-r21783libavutil 50. 9. 0 / 50. 9. 0libavcodec 52.54. 0 / 52.54. 0libavformat 52.52. 0 / 52.52. 0libavdevice 52. 2. 0 / 52. 2. 0libswscale 0.10. 0 / 0.10. 0libpostproc 51. 2. 0 / 51. 2. 0
    Simple command Success
    Tested with avi format only. upload_max_filesize 300.00 MB The maximum size of files that PHP will accept uploads. Keep it bigger for big files. post_max_size 300.00 MB Needs to be a small amount bigger or same, than upload_max_filesize for a file upload to work. Keep it bigger for big files. max_input_time 10000 Determines how much time PHP will wait to receive file data. Keep it "0" for bigger file. max_execution_time 10000 This sets the maximum time in seconds a script is allowed to run before it is terminated. Keep it "0" for bigger files. memory_limit 300M This is php main memory limit and it needs to be bigger enough for your bigger file need to process via ffmpeg.

  • @Luckylucciono:

    Do you have PDO drivers installed and working correctly? Was an earlier version of izap_videos installed before? Then you might try if it works after executing /mod/izap_videos/upgrade.php (best to disable all cache mechanisms before doing that).

    @IZAP or anyone else who might know advice... help needed urgently:

    I still have the problem with an "500 Internal server error". I suspect that it's caused by a single video added by a user shortly before this server error message appeared for the first time, because this error only occurs on the "All videos", "Friends videos" (this user is a friend) and on his profile page. "My videos" still works, upload still works and "Friends videos" also still works for accounts if this user is not a friend.

    I believe the user might even deleted the video shortly after the upload. I suspect that some entries were not properly removed from the database and therefore the server reply includes a faulty entry that results in the Internal server error. I also found "Premature end of script" errors in the apache log that seem also caused by this issue.

    I'm not sure if the video might still have been in the queue when it was deleted or if an error occured during conversion that resulted in faulty database entries.

    What can I do now?

    What database entries would I have to delete to completely remove every trace of this faulty video? Can I do this by simply dropping the entries via phpMyAdmin? In case the video was still in the queue when the problem occured, would there be additional entries in the database the need to be removed?

    Regarding queue + database entries:

    It seems that the upgrade.php script might not have been completely executed during former upgrades of izap_videos. I still have the subtype "izapVideoQueue" in my database. As I understand upgrade.php this subtype should have been removed by now. I upgraded step by step using each version of izap_videos in the course of time. So, this part of upgrade.php seems not being executed anymore with the latest few version because I'm already above version 3.55. Could these entries in the database cause problems, maybe even be responsible for the "500 Internal server error" problem?

    Any help very welcome!

  • I could resolve the Internal server error issue. It wasn't the video upload with the non-existent entity after all. The user deleted this video soon afterwards. But then he uploaded two more videos. I just missed these when I searched the database the first time. The entities were there, but the metadata was corrupted (server glitch... whatever). I deleted these two entities and everything works again just fine!

  • I got 

    Queue status: Not running (2) In queue status in setting for izap videos.

    All requirements are green. Any idea ?

  • @elHayaze:

    If you're sure that your server fulfills all requirements then you might try to initiate the izap_videos plugin again. I guess you might have upgraded from an earlier version.

    Disable izap_videos, disable simple cache file cache, delete the izap_queue_db folder from the data directory. Enable izap_videos again, run the upgrade.php script in the izap_videos mod folder, adjust the izap_videos settings, reenable simple cache file cache. If it still doesn't work then, I have no idea what might be the problem.

  • Still doesnt work. 

    Queue status: Not running (1) jah1213_net_izap_videos_1279759300_Nogomi.com_Mohamed_Ammah_Inshallah.wmv
    jah1213_net_izap_videos_1279759300_Nogomi.com_Mohamed_Ammah_Inshallah_c.flv 4.75 MB
    0 B

  • Thanks for the mod but I have a problem. The mod is interfering with the TinyMCE  plugin, the HTML editor that provides editing in Blogs, Pages and Discussions. When the IZAP Video mod is enabled I can't format text or embed images. Simple paragraphing doesn't work either. When I disable the IZAP Video mod then the formatting works again.

  • @Daffers:

    see my post above about izap_videos defining stricter rules for htmlawed...

  • @iionly

    Thanks, I see the problem - problem fixed :)

  • I'm running 1.7.1 and I see you don't have this version on the list.The only problem I'm having is the pagination is not working.If I click on the next group I just come up with the same first page.I don't allow on server videos so I don't know how that is acting.

  • I'm running on 1.7.1 on a linux server. A few bugs:

    1) queue never processes
    2) on server analysis view I get a constant repeat of the entire page inside itself. (everything is green)
    3) causes "form is missing token ts fields" to itself and other plugins.

    Nice plugin, depressed that it can't work on my site.

  • Got the same error with Trajan. Also using 1.7.1.

    1. queue never processed

    2. everything is green 

    Not having error no 3 though

  • I have an earlier version of Izap video (3.55b) installed on my other web site (elgg 1.7.1) and it works flawlessly without going to htacess to do any changes and  all the other stuff.  Now I've installed this new Izap video (3.62b) on my other web site (elgg 1.7.1) and the video_converting.gif'  spins forever. Please tell me what is going on? Thank you.

    mod/izap_videos/_graphics/video_converting.gif'

  • Hello, I'm running 1.7.1. My problem is that I upload a youtube videos, and now i can delete anything.

    When I push the botom of delete/remove. I go to a white page and finish.

    Any idea?

    sorry for my english.

    Thanks.

  • @gastre, ikpoho, elHayaze, Trajan:

    You might need to reinstall izap_videos. While there are some bugs even in 3.62b (some quite annoying...) it should run nonetheless fine both on Elgg 1.6+ and 1.7+, if php.ini settings are okay and ffmpeg and PDO runs properly. The installing/upgrading of izap_videos seems to fail with simple cache / file cache activated. Additionally, the upgrading seems to fail at least sometimes when there's already a izap_queue_db folder. I disable all caching each time before I upgrade and I also delete the izap_queue_db folder prior the upgrade.

    Depending on your old izap_videos plugin version it might also be necessary to run the upgrade.php script from the izap plugin mod's folder. If you upgraded step-by-step from each minor version since 3.0 or 3.5 it might also have happened that the database modifications in upgrade.php haven't been executed. The 3.62b upgrade.php contains a if clause checking if the old version is <3.55 and does some clean up in the database if true. Strangely enough these operations haven't been done in any of my Elgg installations. The only explanation I have is that something went wrong (bug?) when upgrading from <3.55 to >3.55. Later on the izap_version was already higher and the database cleanup was never done anymore. I've done it manually now... But the problems with queue and also the white page are most likely caused by not following the upgrading/installing procedure properly.

  • Regarding the problem with files not getting removed from the data dir I modified

    /lib/izap_videos.php public function delete() line 333 ff:

    public function delete() {
    global $CONFIG;
    // delete entity from queue and trash with related media
    $queue_object = new izapQueue();
    $queue_object->delete_from_trash($this->guid, true);
    $queue_object->delete($this->guid, true);
    $imagesrc = $this->imagesrc;
    $filesrc = $this->videofile;
    $ofilesrc = $this->orignalfile;
    //delete entity from elgg db and corresponding files if exist
    $this->setFilename($imagesrc);
    $image_file = $this->getFilenameOnFilestore();
    if (file_exists($image_file)) @unlink($image_file);

    $this->setFilename($filesrc);
    $video_file = $this->getFilenameOnFilestore();
    if (file_exists($video_file)) @unlink($video_file);

    $this->setFilename($ofilesrc);
    $orignal_file = $this->getFilenameOnFilestore();
    if (file_exists($orignal_file)) @unlink($orignal_file);

    return delete_entity($this->guid, TRUE);
    }

    The only remaining file is the new second preview picture. I tried to add

    $preview = $this->preview;
    $this->setFilename($preview);
    $preview_file = $this->getFilenameOnFilestore();
    if (file_exists($preview_file)) @unlink($preview_file);

    But this didn't help. How to remove this file?

iZAP

We are leading elgg providers. We have implemented complex combination of applications like "elgg + elasticsearch + cloud infrastructure + comet server for active pages"

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-3-13
  • Downloads: 56516
  • Recommendations: 107

Other Projects

View iZAP's plugins