iZAP-Videos, Full featured videos plugin v3.61b

Release Notes

Release 3.61b

Cool enhancement

  1. We decided to removed "izap_videos" from URL. now you can enjoy urls like "www.xyz.com/pg/videos/xxxxx". Complete branding for you :).

Fixes

  1. Small fix in video play page for elgg 1.6.1 and elgg 1.5

Release 3.6b

In the previous release we added the support to monitor the actual ffmpeg process to be sure about if queue is running or not. But that was behaving different on different server configurations (dual core, cord core). Number of cores effect on the number of threads of ffmpeg and hence background processes. So that's why it was behaving differently on different flavor of servers. To over come this, we stop this monitoring and start to see the queue status via sqlite db. And i tested it alot here, and it's working perfectly and now we also restored windows support. WAMP is tested with this version.

Release 3.55b:

How do we planned stability in this version

In this version we have removed complex video conversion preset command and use simple ffmpeg command "ffmpeg -y -i [inputfile] [outputfile]". I setup a testing lenny instance of a server. than simply install ffmpeg using lenny package manager. And setup elgg with izap_videos. And it was working perfectly there was not any issue. Please post your feedback. And if it works for you. than post your server environment and give us one recommendation. As we will reach to the recommendation of 20. We will change this beta release to stable one.

  1. You can control plugin setting either you want to keep original video file after conversion
  2. Sqlite implementation to cut down all background processing.
  3. More control in queue management.
  4. Implemented Trash, This will just put videos in trash having any issue. it could be ffmpeg supporting libraries. Admin can delete them or can restore them after fix.
  5. Cron implementation to re-trigger queue in case of sudden interruption in the queue. You can manage cron timing according to your need.

Upgrading from previous release:

  1. Backup your database and izap_videos folder.
  2. Disable izap_videos plugin from your admin panel.
  3. Download and unzip izap_videos version 3.5 and place it in mod directory.
  4. Re-enable this new izap_videos plugin from you admin panel.
  5. You may need to re-enable ON-SERVER support from setting tab of izap_videos plugin settings.
  6. Clear simple cache.

New installation:

  1. Download and unzip the plugin in your mod dir.
  2. Enable it from admin panel.
  3. Clear simple cache.

ONSERVER Prerequisites:

  1. PDO sqlite drivers must be installed. This release and all future release will support queue management using PDO sqlite.
  2. ffmpeg and all supporting libraries.

Optional Prerequisites:

  1. notifications p lugin
  2. crontrigger plugin
  3. messages plugin

Optional plugins will give you better control over izap_videos plugin. These optional plugins are only required for ONSERVER support. If you leave them, izap_videos will yet to work with its basic functionality.

Bug fixes:

  1. Access control of uploaded video.
  2. Cutdown elgg-db communications to save resources
  3. Delete video entity will also delete all related media.

Compatiblility:

  1. Elgg 1.5
  2. Elgg 1.6
  3. Elgg 1.7a
  4. Elgg 1.7

Operating system compatiblity:

  1. *nix (confirmed)
  2. Windows (working perfectly tested with WAMP)

We are releasing beta release so we could collect feedback from all of you. Post your tickets at https://izapvideos.googlecode.com

I am twitting on: http://www.twitter.com/the_izap

I am blogging at: http://www.tarunjangra.com

Follow below our group discussion:

http://community.elgg.org/pg/groups/forum/340718

  • One of the example images shows a progress bar for video uploads. But I don't see this progress bar on my site. Is it not implemented yet in the released version or has it been removed?

  • Hello Izap,

    Thanks for the update. I'm having a problem with pagination when embedding videos. Its sending me to the dashboard page, instead of page 2. Please comment on this.

    With Love,
    Uddhava dāsa

  • @Uddhava:

    I tested, there is nothing like this. It is just working fine here. Please post some more info like elgg version you are using. 
    Thanks

  • Necesito ayuda

    Trabajo con elgg 1.7, cuando trato de eliminar un video la página queda en blanco.

    Cuando intento configurar izap_video la página solo muestra dos link que no funcionan:

        * Settings
        
    * Queue status

    Otra pregunta (perdonen mi ignorancia) : que es "Clear simple cache" ??

    ----------------------------------------------------------------------------------------------------

    Working with Elgg 1.7, when I try to remove a video the page is blank.

    When I try to set izap_video page (
    blank) only shows two links do not work:

        
    * Settings
        
    * Queue status

    Another question (excuse my ignorance), that is "Clear simple cache?

    Thanks

  • Hello Izap,

    I'm using Elgg Release 1.7 version 2010030101 (with the plugin upgrades for blog, etc that fixes pagination problems), and here are more details of the problem:

    1) All links in the pagination section have the same URL, going to:
    mod/groups/topicposts.php?topic=24457&group_guid=24216#

    2) After clicking on the link, it sends me to the home page, as if there was a php error.

    With Love,
    Uddhava dāsa

  • Hi izap! The plugin is cool as always, but I still have the onserver problem that the queue is still not running :( 

    In the server analysis tab everything is green but the conversion dosen't start :( 

    I'm using elgg 1.7 Any idea?? It would be great! 

    THANK YOU!

  • @puffi:

    Have you executed upgrade.php in the izap folder? Best way is to delete the izap_queue_db folder in the data directory before you do it (it will get created automatically again later) and I also keep simple_cache off when I execute the script.

    Next question: are you sure that all ffmpeg parameters work on your server? Especially preset parameters could cause errors in ffmpeg conversion.

  • works well for me(v1.7). A goood plugin :)

  • Hi izap. I'm using elgg v1.7 and izap_videos 3.61b and I have some problems

    1. I'm not using ONSERVER and still I'm getting an warning that I should install PDO sqlite

    2. when I want to delete a video I'm getting a blank page and the video doesn't delete

    Thanks and Waiting your solution

  • @iionly: 

    Thanks for the answer. I've tried that you wrote, but the queue still dosen't start. 

    If I start the conversion manually from command line it works like a charm so the preset parameters must be ok :(

    Thanks!

  • solution for me?
    I have Elgg 1.7.

    When I try to delete a video, the page turns white.

    When I try to set izap_video shows two links (in a white page) and these links do not work:
        
    * Settings
        
    * Queue status

    The rest works fine (group videos, upload videos, etc)

    (sorry for my English)

    Thanks

  • Queue status: Not running (1)

    www_in2bar_com_izap_videos_1271072782_Niklas.avi
    www_in2bar_com_izap_videos_1271072782_Niklas_c.flv
    38.85 MB
    0 B

    Queue doesn´t run. I have tried from command line too and works but not works automatically

    Any idea?

  • Hi Izap,

    I tried uploading a .3gp file format, thumbnails are getting created but the conversion does not work. There s nothing in the queue and got the following error on the "all sites videos page".

    Delete  You can not edit until the completion of conversion process.

    I also tried uploading a .mp4 file. For mp4 file thumbnails are not getting created and the conversion does not work.

    Any ideas, as this are valid file formats.

    thanks

  • Hello Friends and thank you very much for this excellent plugin it work fine in my website and I am able to upload any flv videos only but not any other video type like mpeg , 3gp ... ect . if I try to upload any of these videos it never converted !!! please i need help as i am new to this elgg script .

    why no converting the mpeg or wmv videos ?

  • Hi @izpap,

    If we try to upload videos having single and double quotes in the title, the video isn't sent for conversion. It looks as if it does not support videos having quotes in their titles. Any ideas?

    thanks in advance

  • How about fixing this typo? been in the last few versions: From Settings screen:

    IS:

    Include the uplaod text to top bar 

    SHOULD BE:

    Include the upload text to top bar 

  • Hi

    Great plugin.  everything is working fine except when i upload a video file from my PC, it  says its waiting for conversion... 10days its hasnt started... how do i go about fixing this problem

     

    thks

  • Hello Izap,

    by me the same problem, i can not delete movies, comes a white page. OnServer function i have set off, but there comes allways a error message (install PDO drivers)  if i call video settings (i using elgg v1.7.1)

    Greetz,
    Cube

  • Hi Izap,

    When I enable the plugin it gives my white screen and dies. :( I'm using 1.7.1

    It worked flawless with 1.7.1b  any idea?

  • can anyone please help me

    i get this error

    Form is missing __token or __ts fields

     

    and file shows in queue only

    image

  • There seems to be a issue when this plugin and Tidypics are installed together.  A token error appears when posting images to tidypics.  To reproduce, just go to Tidypics Admin and click on recreate thumbnail, generate a thumbnail for any image and you will see the error.  I tested with 4 versions back of tidypics all ok and izap_video was I rolled back to 3.5 and the issue disappeared.  Might you take a look kind sirs?

     

  • Hi, It doesnt work for me

    I am running elgg 1.6 ,standard version of Tinymce   on a linux centos 5 server running ffmepg with php extension,

    when I enable the izap plugin  and tried Video setting its is not showing any thing, my mouse pointer is just spinning

    On the topbar when I click upload video and  added a url for a youtube video it gives me a white page

    I deleted the izap_queue_db folder from the data folder but still doesnt work

    can some one also give instructions to how execute upgrade.php from izap folder.

     

     

    Thanks

    Farhan

  • @farhan

    You just have to enter http://yoursite/mod/izap_videos/upgrade.php in the browser's address bar to execute it.

  • hi

    the embed works fine and I really like the whole thing but the problem for me is when I upload a video from my computer it uploades just fine but there is no way for me to play the video. There is no play button and you cant click the video to get it to play either. Do you have any idea as to what my solution is for this problem. Please reply to   webmaster@firstbaptisthackett.com

  • Nasty bug in your main library file. You need to include your settings file with the full path.

iZAP

We are leading elgg providers. We have implemented complex combination of applications like "elgg + elasticsearch + cloud infrastructure + comet server for active pages"

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-3-13
  • Downloads: 57246
  • Recommendations: 107

Other Projects

View iZAP's plugins