iZAP-Videos, Full featured videos plugin v3.5

Release Notes

Special in this release:

  1. Sqlite implementation to cut down all background processing.
  2. More control in queue management.
  3. Implemented Trash, This will just put videos in trash having any issue. it could be ffmpeg supporting libraries. Admin can delete them or can restore them after fix.
  4. Cron implementation to re-trigger queue in case of sudden interruption in the queue. You can manage cron timing according to your need.

Upgrading from previous release:

  1. Backup your database and izap_videos folder.
  2. Disable izap_videos plugin from your admin panel.
  3. Download and unzip izap_videos version 3.5 and place it in mod directory.
  4. Run upgrade.php. You can find it like http://www.xyz.com/mod/izap_videos/upgrade.php. It will upgrade your old version of izap_videos plugin. Upgrade has been tested from izap_videos-1.6.1-2.5 final and on words releases.
  5. Re-enable this new izap_videos plugin from you admin panel.
  6. You may need to re-enable ON-SERVER support from setting tab of izap_videos plugin settings.
  7. Clear simple cache.

New installation:

  1. Download and unzip the plugin in your mod dir.
  2. Enable it from admin panel.
  3. Clear simple cache.

ONSERVER Prerequisites:

  1. PDO sqlite drivers must be installed. This release and all future release will support queue management using PDO sqlite.
  2. ffmpeg and all supporting libraries.

Optional Prerequisites:

  1. notifications plugin
  2. crontrigger plugin
  3. messages plugin

Optional plugins will give you better control over izap_videos plugin. These optional plugins are only required for ONSERVER support. If you leave them, izap_videos will yet to work with its basic functionality.

Bug fixes:

  1. Access control of uploaded video.
  2. Cutdown elgg-db communications to save resources
  3. Delete video entity will also delete all related media.

Compatiblility:

  1. Elgg 1.5
  2. Elgg 1.6
  3. Elgg 1.7a
  4. Elgg 1.7

Operating system compatiblity:

  1. *nix (confirmed)
  2. Windows (Under testing)

We are releasing beta release so we could collect feedback from all of you. Post your tickets at https://izapvideos.googlecode.com

I am twitting on: http://www.twitter.com/the_izap I am blogging at: http://www.tarunjangra.com

Follow below our group discussion:

http://community.elgg.org/pg/groups/forum/340718

  • there is no upgrade.php in the files.

  • @Durangod:
    upgrade.php is under izap_videos directory. You can browser that file. you can access that file like http://www.xyz.com/mod/izap_videos/upgrade.php

    replace xyz.com with your domain.

     

  • thanks that worked but can you tell me what all of these mean, im getting a crap load of them .

    WARNING: 2010-02-09 19:04:13 (PST): "file_get_contents(/home/xxxxxxxx/public_html/data/a/d/m/i/n/admin/izap_videos/embed/1265771041.jpg) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory" in file /home/xxxxxx/public_html/xxxxxxxx/engine/lib/filestore.php (line 254)

  • and this is line 254

    public function grabFile(ElggFile $file) {
       
       return file_get_contents($file->getFilenameOnFilestore());

  • also i know we all have those clients that are very anal on word errors, i have a few of those myself so normally i would not say anything i can fix them myself but for  your other clients you might want to scan your lang file, you have several typos in there.. i have seen laod not load and vidoes not videos... thats all so far there might be others... just fyi

  • Hi izap,
    I put all the files and folders permissions 755, folder files, any file is deleted normally, but with the tmp folder where to upload videos waiting to be converted file is not removed and the conversion does not work. I'm all set as you said: sqlite3 and the latest version of ffmpeg. Who else has a problem with removing the files from the server? Perhaps video is not converted if something is wrong with permissions? I even put 777 permissions, but also did not help =((((

  • @Abrikos:
    Did you follow all instructions. Specially upgrade instructions from previous izap_videos releases.

    Thanks

  • Well, generally followed, but I'm on the same server, put a clean build and installed it as a plug, the same thing =)!

  • ver 3.51 beta:

    • After executing upgrade.php the izap admin section including the Settings tab looks fine.
    • If a video is uploaded and converted without errors it gets removed complete (original file, converted file, screen shot) from the user's "uploaded" directory.
    • BUG: sometimes the converting of videos doesn't start. The upload has finished without errors and the original file is in the user's "tmp" directory. The screen shot is also created and is saved in the"uploaded" directory. The converting job also shows in the queue, but the size of the flv file remains at size zero. The converting just doesn't start at all.
    • If a video file remains unconverted in the queue, a new video upload may trigger the starting of the converting of the first video file. I saw this once, but maybe this won't happen in any case and a batch of unconverted videos remains in the queue then.
    • After the upload and before the video conversion is finished, the video can already be deleted (not edited) from the site. During that time the video is still in the "tmp" directory. If the ffmpeg conversion is going on in the background and the video entry is deleted, it seems that all files are removed correctly after the video conversion has finished. But if the conversion doesn't start in the first place and the entry is deleted, the original file remains in "tmp".

    It seems everything is quite alright apart from the problem with the video converting not always starting. But this bug seems to occur quite often, almost each time. During testing it happened already on the second upload and several times after that. I tested it with two video files. Sometimes it worked, sometimes it didn't, with the same video file. Therefore the video file doesn't seem to be the cause of the problem.

    I noticed that the settings for background and foreground color of the video player has been removed from the settings tab. I tried to set the colors used in the CSS (default.php) directly, but I haven't found the setting to only change the player background and controls color. I want it to be white instead black and blue instead red, but if I set the color to white for the player background, also the "Video is queued up for conversion" message gets a white background - with a white font color... Is is possible to set the background color and the color of the player's controls independently?

  • hey Izap team!

    any news about izap-uploadify module?

  • @iionly:
    Thanks for all these details. I will see all these things and fix them.

  • @iionly:
    All of the issues "you mentioned above" have been fixed in 3.53beta realse. Please check that and get back to us with your feedback.
    Thanks

iZAP

We are leading elgg providers. We have implemented complex combination of applications like "elgg + elasticsearch + cloud infrastructure + comet server for active pages"

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-3-13
  • Downloads: 56536
  • Recommendations: 107

Other Projects

View iZAP's plugins