iZAP-Videos, Full featured videos plugin v0.6

Release Notes

  • @feelarun:
    It may be the reason of compilation of FFMPEG library. Here is the compilation configuration of our server.

    FFmpeg version SVN-r17630, Copyright (c) 2000-2009 Fabrice Bellard, et al.
    configuration: --disable-debug --enable-libfaad --enable-libfaac --enable-gpl --enable-libamr-nb --enable-libamr-wb --enable-libx264 --enable-libxvid --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libgsm --disable-debug --enable-shared --enable-postproc --enable-nonfree --enable-libmp3lame --enable-libtheora
    libavutil 49.15. 0 / 49.15. 0
    libavcodec 52.20. 0 / 52.20. 0
    libavformat 52.30. 1 / 52.30. 1
    libavdevice 52. 1. 0 / 52. 1. 0
    libpostproc 51. 2. 0 / 51. 2. 0

    Be sure, your server is also support all these configuration and codecs.

  • Excellent, just what I wanted for my site - thanks!

  • it worked perfect as soon as activated it (just off video tested)

    thanks for another great plugin, justlet me poist a suggestion: looks the video list shows the video title only besides the member icon, but no thumbnail there unless mouse over the link, people use to click on thumbnails to see a pic or video here and there, so I assume they will actually click the member icon instead of the video link, my suggestion is to set the thumbnail fixed on the left hand of the list so people can click it to view the video.

    anyway, great video mod !!!!!!!!!!

  • @cabz888:
    Thanks to give us your support. We will consider your suggestion in our future releases.

  • @izap   Thank you for you response....  im on a shared hosting and using elgg on a subdomain.... tried changing th emime types, i still get the same error.... Im a Nube  so plz help me out here....

    Thanx

  • @feelarun:
    Well for on server support, you must have VPS or Dedicated hosting. So you can compile required libraries as i explaind you before.

    As your hosting provider, if they can make available their server with above FFMPEG  support. that may also work.

    Thanks

  • @ Izap :

    One of my friend is using social engine script on the same shared server and he uses the video plugin from SE and it work's fine... any idea???

  • Hi, any suggestions how I can get this working in 1.2 as well? This is a great plugin. Thanks.

  • I had just switched from "both" to "off server", one my site. But, when I saved, my tools page reloaded and the CSS was messed up and I lost some of my other tools settings. All of my site's CSS was affected. I had to get a new map api, etc... I switched it back to both and changed all the settings back. Everything works now, and just for kicks, I checked "off" once again and saved. No problem. I did notice this same exact behavior once before, but it was when I updated to 1.5. So, I dismissed it thinking it was the upgrade. Let me know if you need any other info.

    Elgg 1.5

    iZap 1.5 -0.6

    iZap is close to the bottom of the plugin list.

     

    Scott

  • i'm having the error converting video too....

    it's weird that i'm sure my server supports ffmpeg! i'm on shared host but it worked with boonex dolphin....

    thanks

  • @zanzoon:
    What exactly the error you are getting?

    Please be sure if your server is supporting all required codecs with ffmpeg. Following is our version of ffmpeg with all compiled codecs.

    FFmpeg version SVN-r17630, Copyright (c) 2000-2009 Fabrice Bellard, et al.
    configuration: --disable-debug --enable-libfaad --enable-libfaac --enable-gpl --enable-libamr-nb --enable-libamr-wb --enable-libx264 --enable-libxvid --enable-pthreads --enable-libvorbis --enable-libtheora --enable-libgsm --disable-debug --enable-shared --enable-postproc --enable-nonfree --enable-libmp3lame --enable-libtheora
    libavutil 49.15. 0 / 49.15. 0
    libavcodec 52.20. 0 / 52.20. 0
    libavformat 52.30. 1 / 52.30. 1
    libavdevice 52. 1. 0 / 52. 1. 0
    libpostproc 51. 2. 0 / 51. 2. 0

    I hope, it will help you.

    Thanks

  • hi Izap!

    thanks for the fantastic plugin.

    I'm running elgg 1.5 and having trouble getting the videos to work.

    when i put in a youtube url i get the error message izap_videos:errorCodeArray

    any suggestions?

    thanks!

  • I can get teh off site video to work but when I upload an mp4 video from TED I get the following error:

    click to dismiss

     

    Form is missing __token or __ts fields

  • I just cut and pasted the error from my elgg site, and now the error is showing up on this page, can anyone else see that?

  • i dont like that one bit, eeeek

  • Ok, I compiled ffmpeg from source and everything is working now with on server videos, sorry for not following the instructions as given.  What I was doing was using ffmpeg from the Ubuntu repository.  This does not work.  To compile I cut and paste the configure options that were listed into my terminal.  Then when configure spit up a missing library I tracked it down.  All in all it took about 30 mins.  I had to remove the --enable-shared option to get it to work, not sure why, but I don't mind running it static.

  • I'm still getting the "Form is missing __token or __ts fields" error when I try to upload mpeg vidoe from http://www.ted.com/.   But 3gp files are working properly

  • Is there a size limit for the files that I have to modify somewhere?  I just uploaded a very small 2 meg mp4 and it worked fine.  The TED ones are all > 10 megs.

  • Sorry for the empty comment.  I just increased my file upload size to 50M in my php.ini but I still get the same result with large mp4 files. 

  • Ok, its working now, again I appoligize for spamming this page.  I needed to increase the sizes in my .htaccess file.  So I opened it up and edited the the php_value post_max_size and php_value upload_max_filesize.  I'm not sure if I needed to change both, but it works so I'll leave it alone.

    # php 5, apache 1 and 2^M
    <IfModule mod_php5.c>^M
            # default memory limit to 64Mb^M
            php_value memory_limit 64M^M
            # to make sure register global is off^M
            php_value register_globals 0^M
            # max post size to 50Mb^M
            php_value post_max_size 52428800^M
            # upload size limit to 50Mb^M
            php_value upload_max_filesize 52428800
            # hide errors, enable only if debug enabled^M
            php_value display_errors 0^M
    </IfModule>^M

    Thanks for this great plugin!  It will come in very handy.

  • Ok, now when I try to upload a larger file > 25 Megs my browser (both IE and Firefox) return a blank page.  Here is a snippet from my Apache2 error log for the latest attempt:

    [Sun Apr 05 18:08:06 2009] [notice] caught SIGTERM, shutting down
    PHP Warning:  Module 'curl' already loaded in Unknown on line 0
    PHP Warning:  Module 'mysql' already loaded in Unknown on line 0
    [Sun Apr 05 18:08:07 2009] [notice] Apache/2.2.9 (Ubuntu) PHP/5.2.6-2ubuntu4 wit
    h Suhosin-Patch configured -- resuming normal operations
    [Sun Apr 05 18:08:11 2009] [error] [client 99.248.234.253] WARNING: 2009-04-05 1
    8:08:11 (EDT): "parse_url(/pg/izap_videos/group:76/add) [<a href='function.parse-url'>function.parse-url</a>]: Unable to parse URL" in file /var/www/elgg/engine/lib/pagehandler.php (line 27), referer: http://www.portents.ca/pg/izap_videos/group:76
    [Sun Apr 05 18:08:11 2009] [error] [client 99.248.234.253] WARNING: 2009-04-05 18:08:11 (EDT): "Division by zero" in file /var/www/elgg/views/default/output/tagcloud.php (line 44), referer: http://www.portents.ca/pg/izap_videos/group:76
    [Sun Apr 05 18:08:11 2009] [error] [client 99.248.234.253] WARNING: 2009-04-05 18:08:11 (EDT): "Division by zero" in file /var/www/elgg/views/default/output/tagcloud.php (line 44), referer: http://www.portents.ca/pg/izap_videos/group:76
    [Sun Apr 05 18:08:11 2009] [error] [client 99.248.234.253] WARNING: 2009-04-05 18:08:11 (EDT): "Division by zero" in file /var/www/elgg/views/default/output/tagcloud.php (line 44), referer: http://www.portents.ca/pg/izap_videos/group:76
    [Sun Apr 05 18:08:11 2009] [error] [client 99.248.234.253] WARNING: 2009-04-05 18:08:11 (EDT): "Division by zero" in file /var/www/elgg/views/default/output/tagcloud.php (line 44), referer: http://www.portents.ca/pg/izap_videos/group:76
    [Sun Apr 05 18:08:11 2009] [error] [client 99.248.234.253] WARNING: 2009-04-05 18:08:11 (EDT): "Division by zero" in file /var/www/elgg/views/default/output/tagcloud.php (line 44), referer: http://www.portents.ca/pg/izap_videos/group:76
    [Sun Apr 05 18:08:11 2009] [error] [client 99.248.234.253] WARNING: 2009-04-05 18:08:11 (EDT): "Division by zero" in file /var/www/elgg/views/default/output/tagcloud.php (line 44), referer: http://www.portents.ca/pg/izap_videos/group:76
    [Sun Apr 05 18:08:11 2009] [error] [client 99.248.234.253] WARNING: 2009-04-05 18:08:11 (EDT): "Division by zero" in file /var/www/elgg/views/default/output/tagcloud.php (line 44), referer: http://www.portents.ca/pg/izap_videos/group:76

  • @liam,
    Did you also increase maximum execution time in php.ini or .htaccess file. I think, that might be the reason of blank screens for big files.
    Thanks

  • anyone here successfully installed this plugin on windows vista?

    i keep on getting that error "Form is missing __token or __ts fields"

    it might be my ffmpeg installation on my Wampserver. do you know how to check my ffmpeg settings on wampserver or any windows apache server?

    hope to get this work soon.. thanks in advanced.

  • @sadistic intent

    When I was getting the missing __token or __ts fileds error it was because I was using a stalk version of ffmpeg.  You should be able to check you fmmpeg settings with 'ffmepg --version'.  Open up a dos box and type that.  If it doesn't have the same fields as posted above, then you'll have to compile your own version.  To do that on windows, I think you'll need something like Cygwin: http://www.cygwin.com/

iZAP

We are leading elgg providers. We have implemented complex combination of applications like "elgg + elasticsearch + cloud infrastructure + comet server for active pages"

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2015-3-13
  • Downloads: 57832
  • Recommendations: 103

Other Projects

View iZAP's plugins