Site Access 2.6. Full working release for 1.7+ v2.6

Release Notes

In this release:

*Added direct email confirmation support (no more use of token or token errors during email confirm)

With Love,Uddhava dāsa

  • @Uddhava dasa

    Playing around with my Sherlock Holmes kit I have found that you expect the metadata "validated = 0" for items to show up in the list. Problem is that when a user requests a new password the function deletes metadata "validated".

    That is why it works on the profile, because there you do this:

    if (!$vars['entity']->validated)

    Actually it should do something like this on both the profile and the admin page:

    if (!$vars['entity']->validated || $vars['entity'] == '0')

    *keeping fingers crossed for a new release*

  • Hello Slyhne!

    That's cool! Thank you for your contribution, did add it to the task list for 2.7 release:

    http://community.elgg.org/mod/groups/topicposts.php?topic=461125&group_guid=184041/

    With Love,
    Uddhava dāsa

  • Hi,

    I tried this with some test user and everything works fine, except one thing: when I get the link to confirm my adress, I cklick this one and then I get the message again to co confirm my email, I get an email again with the link to confirm and this one doesn't work either and I get the next confirmation-email and so on.

    My settings:

    Allow account activation via email? no

    Auto activate account? (does not enforce email validation) no 

    Send join events to River Dashboard? yes

    Require invitation to register? no

    Require coppa to register? no

    Require site Password to register? no

    walledgarden: yes

    and is disabled captcha and uservalidation by mail.

    Any help, please?

  • hi, i install this plugin, and send the mail's but no active the accounts :S please help!!!

  • I have a number of users in "Users waiting to be activated" tab, each with "Emai: Not Validated". But there is no user in "Emails not validated" tab.

    Also I don't see any way to activate those users.

    Could some one point to the issue.

    Thanks

    Faisal

  • Hi Uddava.

    I have tried to install this plugin on elgg 1.7 and its failing to install?...Any courses?

  • I have a problem very much like Faisal's - and I hope there's a cure for it.

    When I create a user,  they appear in two tabs, "Users waiting to be activated", and "Emails not validated" - both tabs offer a 'validate and delete' command. -  If I validate the the user (which seems redundant if I've created the user) they still appear in the "Emails not validated" tab.  (If I've validated them why should I still be waiting for an email, but I digress)... 

       I mistakenly thought the 'delete' button would only delete the 'waiting for email' flag, but it actually deletes the entire user and account!

       I have seven 'validated users' listed in the "Awaiting for Email" tab -  How do I delete, "Just the flag"?

     

  • To fix the "Must be logged in to view this page" problem when validating an email, add this to the Walledgarden ACL for approved pages:

    pg/siteaccess/confirm

     

    They can now validate their email without the having to be logged in, however they are still not activated.

  • Thanks Vuulf, that helped!

    As I mainly use this plug-in for walled-garden - is there a way to avoid the activation by the admin, as I don't want the user to wait too long when I am off and not able to activate someone. I am sorry, I am a little bit confused by all the options.

  • In case this helps someone else, I needed to add a few more pages to the Access Control list to allow users to reset their own passwords (in Elgg 1.7.1)

    action/user/passwordreset
    pg/resetpassword
    pg/siteaccess/confirm

    The last line might not be needed by everyone - my accounts are created manually, so email addresses are not activated, and a first attempt to reset a password would attempt to confirm the account first.

  • Ok, I guess I just have to ask the 'direct' question to get an answer.

      If a user is 'Validated' but still showing up in the "Awaiting Email Validation",  how do you remove them from THAT list and not DELETE the user entirely?

  • create_metadata($guid, 'validated_email', true,'', 0, ACCESS_PUBLIC);
    in addition to
    set_user_validation_status($guid, true, 'admin');

     

  • I am experiencing the same problem, as posted on page 2:

    ---------
    umm all perfect but.. when a member use "invitefriends" and the new friend open the email,click,clack,cluck,etc.. well, then at the riverDB you can see(its an example):

    Snowball is now a friend with Mark

    ..but its not true; They arent really  friends, and if Snowball wants to be a friend with Mark, he need to send a friend request after the register process.. any idea to solve this?

    kikefrutas 71 days ago
    ----
    Can anybody advise how I can change things so that either an invited member automatically becomes friends with the person who invites, or change the settings so that the riverdashboard does not state that they are friends..

    Thanks

  • Hi Uddhava dāsa

    Looks like a great plugin, but can you provide a fix to the capthca issue - I cant get past the register page, without an "invalid securty code entered!" message.

    Thanks

    Newbrie

  • I'm not sure if you addressed this yet or not in all of the posts. But I just went to install this plugin. and basically it stated "this is a missconfigured plugin, please refer to elgg wiki regarding this issue"

    Any help or update would be appreciated.

     

    Thanks -

  • redonkuless: this is not a problem with the plugin but with how you have (incorrectly) installed it.

    See: http://docs.elgg.org/wiki/Misconfigured_plugin_error

  • Hey guys, yes I am new to ELGG. I relly love this concept for controlling access but have come to a road block. When someone try's to register they get this error

    Fatal error: Call to undefined function get_input() in /home/content/j/o/n/jonpayton1971/html/enfnc/account/register.php on line 14

    I have looked at line 14 but for the live of me I don't know why its a issue...

    $username = get_input('username');

    I am NOT a PHP guru, so if this is a simple thing please help.

    Jon

     

     

     

  • well. I have spent days trying to get this to work ( the problem with a validation e mail never arriving).. I have read every thread I can find and tried every trick I could find .

     

    so I settle with a member going active at registration with out a confirmation e mail ( the "no" "no" setting trick)

     

    BUT,,, what about "forgot password"???

    How do I manually interecept those requests so I can manually reset a persons password?.... is their a way to get rid of the " forgot password" link on the Registration page and replace it with a "Contact me" e mail link??

    if so, could some one point me in the right direction??

     

    I appreciate the help

  • I have been trying to install this on my test server. But i receive the following error.

     

    siteaccess is a misconfigured plugin. It has been disabled. Please see the Elgg wiki for possible causes.

  • A minor point but the  latest 2.6 plugin shows as version 2.4 when looking at the information section in tools administration. Just a note to elliminate confusion for othes.

  • Hi Uddhava,

    Great plugin!

    I am having a problem with walled garden enabled.  If I invite a new member and they click on the link to join, they go to the main page, not the registration page.  It says they have to be logged in to go to that page.   What should I add to the walled garden ACL pages to allow it to work?  I tried pg/register/, but that did not work.

    Thanks.

  • I found that the extra "/" was the problem.  "pg/register" works.

  • Has anybody managed to sort this little error, yet, please?

    - - - - - - - -

    I am experiencing the same problem, as posted on page 2:

    ---------
    umm all perfect but.. when a member use "invitefriends" and the new friend open the email,click,clack,cluck,etc.. well, then at the riverDB you can see(its an example):

    Snowball is now a friend with Mark

    ..but its not true; They arent really  friends, and if Snowball wants to be a friend with Mark, he need to send a friend request after the register process.. any idea to solve this?

    kikefrutas 71 days ago
    ----
    Can anybody advise how I can change things so that either an invited member automatically becomes friends with the person who invites, or change the settings so that the riverdashboard does not state that they are friends..

    Thanks

  • @ elggfan

    I do not have the problem on my site.  I am using 1.7.1

  • I require people requesting friends to be approved, but by default I believe with Elgg you can friend someone and that makes them your friend, but it doesn't make you their friend unless they go and friend you as well.

    Same here on the Elgg site with follwing and followers. Because you start following someone doesn't mean they automatically start following you.

Project Info

Stats

  • Category: User admin
  • License: FreeBSD license
  • Updated: 2014-11-17
  • Downloads: 9761
  • Recommendations: 15

Other Projects

View Uddhava dasa's plugins