Integrated Video gallery plugin (beta) v2.1

Release Notes

Hi all,

Took a while to upload the beta version. Hope you'd find it more useful.

New Features added are as follows:

  • Enables users to browse videos from youtube, metacafe and vimeo and embed them to their profile or groups.
  • Video tagging enabled.
  • Enabled for group videos.
  • Users can comment on videos.

Any suggestions and bug reporting is welcome.

 

Requirements : You need to have the php cUrl extension.

 

Credits : Adrian Rudnik at http://code.google.com/p/php5-simplevimeo/ for his vimeo search class.

Screenshots :

image

fig 1 : The video search Interface(youtube/metacafe/vimeo)

 

image

Fig 2 : Search results from youtube

 

image

Fig 3 : Search results from metacafe

image

Fig 4 : Group videos

 

Cheers

  • @hizaro //

    i had the same problem && this clear'd it up for me ::

    go to mod -> videolist (( or whatever you'v got the plugin label'd )) ->actions ->addvideo.php

    then delete the old strings for $buffer (( twice )), $vidDataTitle && $vidDataDesc ::

    $buffer = file_get_contents('http://gdata.youtube.com/feeds/api/videos/'.$videoid);

    and change

    $vidDataTitle = $xml_buffer->title;

    $vidDataDesc = $xml_buffer->content;

  • I've found a bug. When pressing the "add" button in the browsetube form in Explorer nothing happens. It works just fine on Firefox and Safari. Any idea why?

     

     

  • For some reason my videos arent being added to the respective group's video list when I add a video from the my videos page and select the group. It only works when I add a video from the group page. I am using 1.6.1

  • i tried in 1.7 and it shows missing token or ts fields

  • I got this working on version 1.7. Great plugin.

    I really wish this would be integrated with the file plugin and a picture gallery.  Would be great to manage all media from one central plugin.

  • Tengo un problema:

    Al agregar o buscar un video aparece el mensaje "Form is missing __token or __ts fields"

    Trabajo con Elgg 1.7

    Gracias por su ayuda.

  • scienide how did you make it work for 1.7?

     

  • How can you publish uploading activity in the dashboard??

  • missing token or field on elgg 1.7 when add video.
    Anyone can help me?

  • Thanks for this plugin. In views/default/forms/add.php you are using the view (add.php) as the form action, performing some business logic around validation, and then forwarding (not posting) to the addvideo action. This is poor form and not the elgg way. you could either do your validation in javascript and still do a submit to the action, or do validation in the action and forward back to the form setting the appropriate system error.

    For those of you trying to get this to work in 1.7 which requires token do the following. Edit mod/videolist/views/default/forms/add.php and on line 150 add:

    $body .= elgg_view('input/securitytoken');

    or if your line numers are a little different add it just under this line:

    $body .= elgg_view('input/hidden',array('internalname'=>'guid', 'value'=>$vars['guid']));

     

    Next, go up to about line 128. Near there find the line that looks like:

    forward('action/videolist/addvideo');

    Delete that line and in its place add these 3 lines:

    $token = get_input('__elgg_token');
    $ts = get_input('__elgg_ts');
    header("Location: {$vars['url']}action/videolist/addvideo?__elgg_token=$token&__elgg_ts=$ts");

     

    Cheers,

    Billy

  • Thanks for that code Divagater. Unfortunately it didn't work for me - I am still getting the 'form is missing _token or _ts fields'. Nice try though. For the meantime, I will go back to using the 1.5 version as, although the 'find video' search does not let me add any videos, it does not result in an error and users can still add their videos individually by URL. Generally speaking, it's a real shame that developers lose interest with their plugins. I have noticed this past week whilst researching plugins that sooner or later, developers just dissappear. I am sure the pressure of writing a popular plugin becomes too much to bear - perhaps they become victims of their own success!

  • To all others who have been waiting for an upgrade to this plugin, The next upgrade is due with elgg v1.8. Personally, I am elated for the fact that this plugin makes its way into the official release of elgg v1.8.

    @Cliff - I personally feel this forum should be used in a manner that is more decent.  Its a hard way but very effective one, If you want something urgently, start with understanding the code first and debugging it for yourself, rather than blaming and waiting for the developers to do it for you.

  • Hi Prateek, Great plugin, I am using it now instead of Izap as it is very lightweight in comparrison... if I ever have a need to upload real videos to my site, I might reconsider, but for now this is ACE!  Apart from one small thing... Version 1.5  I used before was fine, apart from poor formatting in the Group Video Widget...so I upgraded to 2.1 and when I activate the latest version in my 1.6.2 site my Vazco_mainpage looses its css entirely... any ideas please? 

  • Ah!  I tried rjcalifornia's version and it seems fine now.  Still a great plugin!

  • When I add a video I get this:

    Form is missing __token or __ts fields

    and when I use the Youtube search area too

  • I have the problem that Darwin had....when clicking on the tools and then videos, it takes me back to the homepage instead. I am new to elgg so have version 1.7 and have only added 3 plugins so far (which includes this one) My programming skills are basically nonexistent so hoping there is a simple fix for this... ? Any ideas?

  • Prateek, I tried using http://www.thebluegym.co.uk/pg/videolist?view=rss on twitterfeed.com, but it could not parse the feed... any ideas what is wrong?

    I do not understand RSS and I am no coder, but this is useful as I can feed my Facebook page and Twitter with such a feed.

  • Hello, this plugin is very good. however in the widget group does not show the videos even though they are there. group got the river and show the videos. except in the videos of the group ... thanks.

  • Hello! Great plugin! Thanks.

    It appears that in Internet Explorer 7 and 8 the inclusion of videos does not work. Have you noticed it too?

  • hi

    this is a great plugin but i am still having a problem with searching with youtube and vimeo.  when i try to search with nore than one word it just keeps searching. in other words, i can only use single words in my search and 'spaces' inbetween words cause the problem. i know it is probably something simple but i would appreciate it greatly if someone could tell me what is wrong.

    thanks kindy

  • Hi Prateek,

    The plugin installed ok but when I click submit I get the:

    Form is missing __token or __ts fields, error. I'm getting this error a fair  bit around the site.....

    No videos are listed afterwards.....

     

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 9045
  • Recommendations: 6

Other Projects

View Prateek's plugins