Release Notes

Updated to work with SMTP over a SSL connection

Thanks to Eros Pedrini for the SSL code.

  • Here is something new:

    [16-Jun-2010 23:53:54] PHP Warning:  fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://smtp.gmail.com:465 (Unable to find the socket transport &quot;ssl&quot; - did you forget to enable it when you configured PHP?) in C:\wamp\www\hai_community\www\mod\phpmailer\lib\class.smtp.php on line 122

    [16-Jun-2010 23:53:54] PHP Warning:  PHPMailer error: SMTP Error: Could not connect to SMTP host. in C:\wamp\www\hai_community\www\mod\phpmailer\mail.php on line 139

  • OK, sorry for the noise but I figured it out. You have to enable the openssl extension for it to work.

    :-)

  • Thanks Cash! The php mail() function is disabled in my server and this plugin was very useful.

  • @Eric Yes it works with 1.7.x

    @Cash. I am trying to use your plugin for invitefriend plugin because it seems it uses its own mail function. 

    So I tried to change the function

     mail($email, $subject, wordwrap($message), $headers);

    to 

    phpmailer_send($from_email{$header_eol}, $_SESSION['user']->name, $email, "", $subject, wordwrap($message));

    The full codes for invite.php is http://pastebin.com/4XrVUxg8

     

    It doesnt send the invitations.

    Something wrong with the function I changed but I dont know what.  Might need your help.

    Thanks

  • @elHayaze - Elgg 1.7.2 includes better email handling code and an invitefriends plugin that uses it. You won't need to change anything with that version.

  • @Cash Thanks I will try it. But is it ready for production site ?

  • If you have a test site, try it and if it checks out, you can use it in production. Otherwise, I would wait until the final release. My expectation is that there will be very few changes between the beta and final release. It is really more of a release candidate than a beta.

  • Hi
    The problem would be that the plugin works at Elgg 1.6.1 on the same server but no longer than 1.7.1.
    What may I send you log files that can be removed in error?
    The server is a basic debian ...
    Unfortunately, the service does not allow sending of emails on TCP port 25.
    Therefore, using your gmail plugins because they go out from the leaves.
    Yes, home server:).
    Sorry for my English because Google Translate ... :)

    post the document: If you are interested send the Hungarian translation of the plugin:)

  • @Antal - Nothing has changed in Elgg from 1.6.1 to 1.7.1 that should interfere with this plugin. In fact, I know of people using it on 1.7.1 without any problems. Are you sure something hasn't changed on your server?

  • @Cach - I am sure that it does not change anything because the server is currently running 1.6.1 and 1.7.1 is just another virtual host ... I tried to disable the plugin to 1.6.1 hoping it's wrong but it works at both high anyway: (
    There are currently trying with 1.7.2 but it is not working: (

  • I am testing PHPMailer and would like to know if my setup is wrong. Because only some of the core elgg plugins are working with my setup.

    Invite friends mail are sent, but notifications mail from wire post, message board updates, etc are not sent. Is it nessesary to change anything to make it work with these notification mails

    My smtp setup is ok.

  • @gillie - I actually haven't updated it yet to handle invitations. It only does notifications. This means your smtp settings are probably not working. Have you checked your server's error log? This plugin writes problems to it for debugging.

  • Oh, it was wrong and now it is working, thank you.

    I do not see the sender as PHPMailer though.

  • how to install ?

    any spical stapes ??

    tell me?

    can this plugin work with 1.7.3?

    i am install this plugin 1.7.3  but can't be install?

    ( linux hosting )

     

  • As mentioned before, yes it works with Elgg 1.7.x. No special installation instructions.

  • HI Cash,

    so if it is completely the wrong place to ask: we are using this plugin and everything worked fine but now the first user with a umlaut in his emailadress tried to register, but the validation mail couldn't be sent as the system changed the ö to something else just like his name in the mail. But there aren't any problems with his display and user name, so I don't know where to look at.  Our mail server is in ISO 8859-1, is that correct?

    Thanks!

  • @n_l1 - I didn't think that non-ASCII characters were supported in email addresses. I don't think the standard supports this and support is probably very sketchy.

  • Hi,

    I've been using this plugin in elgg 1.6 with any problem but in elgg 1.74, invite friend plugin ignores phpmailer, after debuging I solved inserting this code in mod/phpmailer/start.php file.

    function phpmailer_init() {
        if (get_plugin_setting('phpmailer_override', 'phpmailer') != 'disabled') {
            register_notification_handler('email', 'phpmailer_notify_handler');
            register_plugin_hook('email', 'system', 'phpmailer_hook');
        }
    }

    function phpmailer_hook($hook, $entity_type, $returnvalue, $params) {
        return phpmailer_send($params["from"], $params["from"], $params["to"], '', $params["subject"], $params["body"]);
    }

  • Is there any inviter that connects with PHPMailer?

  • At some point I will update this plugin to do that.

  • Found a bug in mod/phpmailer/mail.php

    On line 85 and 86, change "param" to "params",

    It seems like a typo.

    Other than that, great stuff.

    Thanks,

    Jin

  • Hey guys can you help me how this plugin works? Though i have installed it seems to be not working with respect to sending emails while registering users to gmail or any other for confirmation?

Stats

  • Category: Communication
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 17004
  • Recommendations: 38

Other Projects

View Cash's plugins