Mainpage widgets (vazco_mainpage) v1.05

Release Notes

CHANGES:

IN 1.05:

  • added possibility to display content in a brief way
  • added possibility to customize login box
  • a few new widgets
  • ability to upload background (full version only)
  • ability to display text for not-logged users under the login box
  • a few fixes
  • 3-column layout (commercial extension)

 

  • Mike,

    My request was accepted to join the group, but I do not see a "Buy Now" button on elgdev.com vazco_mainpage plugin group page.

    Where do I go to make the purchase?

    Thanks,

    Candid 

     

  • Candid, we were doing upgrade of Elgg on vazco.eu last Friday. Thank you for reporting this problem. You should be able to purchase plugin with PayPal button on this page now.

  • Okay, so I really need your help. I am not certain why the plugin won't work. I paid, downloaded what I thought was the latest version. and disabled the original widgets that came with the elgg software I downloaded just a few weeks ago, and now I can't get the mainpage settings to load the widgets. I am not sure what widgets I need to update...or even how to update them before this version can work. Can you help me out a little?

    Thank you. I appreciate your help.

    Candid

  • Candid, in case of problems with the plugin, please use forums on plugin's page or please contact me directly at info@elggdev.com. This forum is for GPL version of the plugin.

     

    I'm not sure what may have caused a problem you described (the plugin is a plug and play plugin). Could you send me login details to your site? I will be able to debug the plugin straight on your server then.

  • hello!

    The plugin is extremely useful but is there any way to disable the footer eliminate (spotligth)? "Excuse my English, I'm from Brazil"
    hug

  • Hi all - will there be a 1.8 compatible version of this plugin?

  • Gary, we're working on commercial version of this plugin for Elgg 1.8 (as well as 9 other of our plugins from vazco.eu). Once it's ready, we will publish GPL version as well.

  • Anybody can advise me? (esp. @VASCO),

    After I installed the plugin (copied the "vasco_mainpage" folder to the "mod" folder of Elgg 1.8.3, there are some error messages, basically issues of "deprecated". One of them says "Deprecated in 1.7: extend_view() was deprecated by elgg_extend_view()!" What kind of problem, and how should I solve this? Thanks

  • Unfortunately this plugin is not compatible with Elgg 1.8.3. It requires some work to make it compatible, we didn't work on upgrade yet due to lack of sponsors.

  • @Mike (vasco); thanks. You did great jobs, I hope there will be sponsors to support you and your team

  • @Mike: I thought you were already working on a new commercial version (as well as 9 other plugins as mentioned above)...

    Surely, upgrading takes time and I would understand the need to sell the 1.8-version separately instead of offering it as a free upgrade to buyers of the commercial version as the versions before. I just wonder if it's necessary to wait for a sponsor as I imagine you would also be able to earn money after the release (and the earlier you release the more money?).

    I admit I'm eagerly waiting for the mainpage plugin (+3 column extension) for Elgg 1.8. I'm just slightly hesitant in sponsoring an upgrade when the plugin might be available for less after it's done. Well, maybe one day the mainpage plugin will be the only blocker for upgrading my site to Elgg 1.8 and I have to re-consider.

  • iionly, we currently work on upgrade of approx. 15 plugins and 15 themes (they're already upgraded, they're being tested and we plan to release them soon, right now we wait for new shop platform we're mounting on vazco.eu to be ready). Unfortunately, vazco_mainpage is not in this bunch. It requires some significant modifications for Elgg 1.8, as the whole code which is used to implement HTML widgets and a few other widget types is gone. I would not want to release plugin with functionality lower than it's previous version (or version which implements hacks), that's why we delayed development of this one.

    We plan to release new version of vazco_mainpage at some point, although it's hard to predict when.

    ps. in case anyone would like to sponsor a plugin, we offer a discount for any future plugins released on vazco.eu after plugin earns amount for which it was funded, eg:

    cost of plugin: 10
    cost of development and sponsorship: 50
    after 4 or more people buy a plugin, we can offer a discount worth of 40

    This policy is valid for funding any plugins or upgrades.

  • Hi - this looks great and just what I need. But before I install, can anyone tell me if this plugin will work on 1.8?. Thanks, Billy.

  • @Billy: No it surely won't work on Elgg 1.8. Try the Widget Manager plugin instead: http://community.elgg.org/plugins/384604/4.7/widget-manager

Mike Zacher (vazco)

I'm an Elgg expert and CEO of vazco.eu - the first plugin store for Elgg. We focus on development of highly scalable and highly customized Elgg websites.

Stats

  • Category: Site admin
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 20537
  • Recommendations: 32

Other Projects

View Mike Zacher (vazco)'s plugins