Vanilla forum integration v0.5

Release Notes

This plugin allows Elgg to control login and logout of Vanilla forum (that is, single signon and sign out via Elgg), adds Vanilla forum to the Tools menu, and adds the Elgg topbar to Vanilla. Profile links in Vanilla are redirected to the Elgg profile. Discussions and comments posted in Vanilla appear in the Elgg activity river.

It includes a recent version of Vanilla forum (Vanilla 1.1.7) from

http://www.lussumo.com

Please read the included README.txt carefully for detailed installation instructions. Do not activate this plugin until you have followed the README instructions!

Note: this plugin requires the PHP Curl extension.

This plugin does not do anything to your Elgg install except add Vanilla events to your activity river. Nevertheless at this early stage it is probably best not used in a production site.

  • Thanks Kevin i'll do that

    If I under stand you right I assign the id as 4 I'll look at the present admin role_id and duplicate it for the accounts I need

  • Thanks Kevin i'll do that

    If I under stand you right I assign the id as 4 I'll look at the present admin role_id and duplicate it for the accounts I need

  • just looked at the source and the next step after logging the discussion is a JAVASCRIPT call ( href="javascript:history.back ). I suspect this is part of the javascript error issue mentioned previously in this plugin discussion.

  • Just to let you know that changind the role in the db worked

  • @NeilR - your issue has already been addressed earlier in this thread and in the initial article. You need to have the PHP Curl extension enabled to use this plugin.

    @Malaga Jack - glad to hear that this worked!

  • i have strange error. everything works fine, but with a small hiccup on my site. when i click the FORUM, it will give me bellow error in bold letter:

     

    A fatal, non-recoverable error has occured.

    Error Message: A database error occured while attempting to set a user icon.

    Affected Elements: Authenticator.CreateVanillaAccount(); The error occured on or near Table...etc

     

    But this is just a glitch because when I hit REFRESH button on my browser, it will be back to normal. Error message appear only on the initial click of the FORUM link. Any idea how to resolve it?

     

     

  • @batanggenyo - did you follow the instruction in the README stating that the Vanilla table prefix must be left as "LUM_"? If not you would get this error (and a number of others!).

  • im quite new to elgg and vanilla. im working on a networking site and vanilla will be aimed toward education in my case. im new to this my vanilla install was pretty flawless. but i can't change the order of categories, i get the 4 arrow 'move' icon when i hover over the groups but thats it, wont let me move them.(i want to have subcategories, or at least change the order and use dashes or spaces so it looks like ive got subcategories, ive tried all i can but havent gotten anything)

    ive read all these posts and it seems maybe it is a javascript error or something, so anyone who has fixed this problem or can help me fix it please, please get in touch with me.  i would greatly appreciate it if someone can tell me how to exactly fix this.

  • @Kevin ~ not sure if you remember my issue - When I click on the "Settings" tab and then select "Application Settings" I get the following error:

    Forbidden 403

    You don't have permission to access /mod/vanillaforum/vanilla/settings.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I did a fresh install of elgg and vanillaforum and the error continues.  I followed the instructions to the letter and I still get an error.  The action that is called when I click the "Application Settings" link is: http://www.illinilounge.com/mod/vanillaforum/vanilla/settings.php?PostBackAction=Globals

     

    Any ideas?  I have ran out things to try.

    Regards,

    Crusader

  • @Crusader - I've absolutely no idea. I can't fix an error that I can't reproduce.

    It looks like a server configuration error.

    So you have the usual four alternatives: a. uninstall the plugin, b. change your server, c. figure it out yourself  or d. wait until there is a fix from someone else. As no one else has reported this error, I'm afraid that it is not likely that someone else will fix it for you, especially because it seems very unlikely that this has anything to do with the plugin itself.

    Sorry.

  • No problem Kevin.  I'll choose option e. avoid this plugin (as elgg has a basic forum platform already integrated that accomplishes my needs at present).  Good luck with this plugin.  It is a great addition to Elgg.

     

    Peace,

    Crusader

  • @Crusader - I think that's the same as my option a.

    :)

    Sorry for not having a real option e. Server issues can get very weird ...

  • @Dhrup ~ That's what I was thinking.  Maybe I'll address the issue at a later date.  I am working on the my News plugin (with article rating ;-)  As usual, I am having an issue with a certain function. 

     

    Enough babbling - Vanilla is a great idea - should make many elgg'ers happy!

     

  • @Kevin,

    You mentioned earlier that the JS fix and (I think) frontpage fix will be in a new release next week. I was curious what other changes will be in the new release ('cause I can't really see too much wrong with it other than the JS Fix issue)? It's a rather good plugin...

  • @ Kevin ~ I finally figured out what my issue was with Vanilla - my host (hostgator.com).  I had to have the URL whitelisted.  A mod_security rule was triggering the 403 forbidden error.  

     

    I have updated to the newer version of your plugin, but I figured I would post the solution here to keep the "issue" local.

     

    Regards,

    Crusader

  • @Kevin,

    Upgraded to your newest version and it works like a charm. The JS fix works like a charm. Much appreciated!!!

  • Can anyone advise how to do the curl extention please?

    Thanks

    Tom

  • How do I change the name of the item in the tools menu?

  • Me too...I changed my folder name from "vanillaforum" to "forums".  I would like to know how to change the link as well as the text "Vanilla forum" in the topbar menu in Elgg.

    I have spent a couple of hours searching through all the files, but I don't know what I am looking for. I check js folders and files and conf folder, etc. I don't see it. Can someone please gve me a hint?

    Thanks!

  • Kevin, I have installed your plugin and it seems to work great except when I click on the post button I get a blank screen.  I am a Java developer who is learning PHP! Thanks.

  • Thank you Kevin.  This has resolved my plugin.

    I did read your installation instructions before I posted the last message and I did check that Curl was installed.  The problem was that I didn't enable the plugin in my PHP.ini file.  Thanks again.

  • Note the above should say "this resolved my problem".

Kevin Jardine

Elgg plugin developer

Stats

  • Category: Third Party integrations
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 8749
  • Recommendations: 6

Other Projects

View Kevin Jardine's plugins