Vanilla forum integration v0.5

Release Notes

This plugin allows Elgg to control login and logout of Vanilla forum (that is, single signon and sign out via Elgg), adds Vanilla forum to the Tools menu, and adds the Elgg topbar to Vanilla. Profile links in Vanilla are redirected to the Elgg profile. Discussions and comments posted in Vanilla appear in the Elgg activity river.

It includes a recent version of Vanilla forum (Vanilla 1.1.7) from

http://www.lussumo.com

Please read the included README.txt carefully for detailed installation instructions. Do not activate this plugin until you have followed the README instructions!

Note: this plugin requires the PHP Curl extension.

This plugin does not do anything to your Elgg install except add Vanilla events to your activity river. Nevertheless at this early stage it is probably best not used in a production site.

  • Hi Kevin, I have installed the plugin in my Elgg Network and at first it worked great!

    That was when I used the original adress of my hoster as Elgg Adress.

    But now I have changed my adress with c-name to an us.to subdomain and now it always gives me the following error message:

    Fatal error: Call to undefined function curl_init() in /users/supers/www/elgg/mod/vanillaforum/vanilla/library/People/People.Class.Authenticator.php on line 411

     

    Do you know how to resolve that problem?

    I would be very happy if you could help me!

  • Hi everybody!

     

    im using the VanillaForum plugin on my website. I have changed the subdirectory from Vanilla to another name.. i have turned the logout page off so i added that state on my front page for inserting the invisible logout check frame. im getting a "not found" error on my apache server log cuz the vanilla forum is not logging out. the error is generated cuz the system is looking in the old directory

    http://mysite.com/pg/vanillaforum/vanilla/  while mine is now http://mysite.com/pg/vanillaforum/new/

     

    how do i fix this error.

    I had also updated the vanilla in it but i did follow the instrutions in the readme file :)

     

    there is a plugin for vanilla at vanillaforums.org which makes vanilla URL very friendly, like elgg has, but it doenst seen to work here, instead screws up everything.. What can i do about that..

     

    thanks

    merry christmas

    waiting restlessly

    :)

  • Hi, I have recently migrated my website to another web server.  Now when I try to open a Forum, I get the following error: Warning: include_once({path to old elgg installation on old server}/mod/vanillaforum/vanilla/appg/headers.php) [http://www.my website.co.uk/mod/vanillaforum/vanilla/function.include-once" >function.include-once]: failed to open stream: No such file or directory in/home/eczederm/public_html/mod/vanillaforum/vanilla/appg/init_vanilla.php on line 17.  I have checked the MySQL database, but cannot find were the settings are stored.  Please would you advise? How do I change this path?

    Is a reinstall necessary?

    Thank you for your time.

  • Hi Ian,

    This information is stored by Vanilla, not Elgg. You will need to change it in the Vanilla settings.

    Kevin

  • Thanks Kevin.  I have two envionments.   I went to the Application Settings (in Vanilla) on my local PC and changed the web path to Vanilla and the Cookie path (changing them to the paths on my web server), however I now get the errors on my local PC and my web server!

    The error I get on my web server is: Warning: include_once(C:/Joomla/xampp/htdocs/elgg1.6/mod/vanillaforum/vanilla/appg/headers.php) [function.include-once]: failed to open stream: No such file or directory in /home/eczederm/public_html/mod/vanillaforum/vanilla/appg/init_vanilla.php on line 17

    C:/Joomla/xampp/htdocs/elgg1.6/mod/vanillaforum/vanilla/appg/headers.php should be /home/eczederm/public_html/mod/vanillaforum/vanilla/appg/headers.php

    Could you advise me how to either change the path (as stated in the above paragraph) or how to uninstall Vanilla (to reinstall). 

    Thanks again for your time.

  • I have uninstalled the plugin and reinstalled (deleting all database tables then recreating).  How the Plugin is working well except there is one post, which links to a page that says:

    Some problems were encountered
    The requested discussion could not be found.
    All the other forum entries work ok and I can create entries.  Any ideas how I can delete the corrupt forum entry from my widget? Thanks.
  • No idea how that was created. You could just wait and then after a few posts, this would not be displayed anymore.

  • Hi Kevin,

    Do you happen to know if there is a forum under development specifically for elgg?

     

  • A fatal, non-recoverable error has occurred

    Technical information (for support personel):

    Error Message
    The connection to the database failed:
    Affected Elements
    MySQL.OpenConnection();

    For additional support documentation, visit the Lussumo Documentation website at: lussumo.com/docs

  • Can we use the elgg framework existing theme for this vanilla forum? If we can use the existing dashboard theme structure, them this will be awesome.

  • venusaga,

    This plugin provides single login and some profile and widget integration. Vanilla remains a separate application and has its own separate theme system.

  • So can we use the code to customize the feature and use it in Elgg using external pages?

Kevin Jardine

Elgg plugin developer

Stats

  • Category: Third Party integrations
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 8769
  • Recommendations: 6

Other Projects

View Kevin Jardine's plugins