Big Brother v1.3

Release Notes

PLEASE double-check that your regexp filters are correct for this version!

Enables a word-based censor for all user input.  Optionally can report
offensive language via the Reported Content plugin.

Mal-formed word lists will have unexpected results!  Word lists *must* be
comma separated in one of the two formats:

Format 1:
word1,
word2,
word3

Format 2:
word1, word2, word3

The plugin will automatically convert all word lists into the first format
upon saving.  Extra whitespace will be trimmed.

As of 1.2, regexp is supported in the words list.  Words using regexp *must*
be a valid PHP regexp.  Examples include:
/word1/i,
/w[o]+rd2/i

When using regexp, it's best to separate each word by word boundaries:
/\bword1\b/i,
/\bw[o]+rd2/i

This avoids problems matching naughty words within other words.
/ass/i
Would match class, grass, assistant, etc.

/\bass\b/i
Would only match ass when separated by a word-boundary character.


** INSTALLATION **
    * Unzip the file to the elgg/mods/ directory.
    * Go to your Elgg tools administration section, find the new tool, and
      enable it.
    * Customize the settings if desired.  


** TODO **
    * Make the "visit reported link" link more accurate.


** CHANGES **

v1.3 (05/06/2009)
    * Now properly triggers a hook when adding reported content.
    * Added "content_owner" to reported content.  (Only visible in
    advanced reported content plugin).
    * Fixed typo in README.
    * Added elgg_version to manifest.xml.
    * Added explicit checking for objects during censor.
    * For non-regexp lists, escape regexp chars.
    * Different regexp'ing for standard lists.
    * Added notice for malformed regexp.

v1.2b2 (2/20/2009)
    * Added 'enabled_plugins' to list of ignored subtypes.
    * Reduced reported content width to 35 chars.

  • Not to sound stupid (I usually do anyway) but what is a regexp filter? and how do I check it? or if I don't have any, do i need them? and where would i get them ???????????? as you can see I'm a little confused But then this is nothing new for me as i am use to it

  • Regexp is short for regular expressions.  It's a very versatile way to match and mangle text strings.  If you're not sure what it is, make sure you've disabled it in the config!

    The warning was for those who use this plugin with "List is in RegExp" turned on...

  • Hi Brett.
    This plugin make something also in chat?

    Thanx a lot for your job! ;-)

  • @Erotomania,

    Here is a PhpFreeChat plugin that ties in to BigBrother.  This plugin is completely unsupported.  It needs to be copied to the src/proxies/bigbrother.class.php and requires changing your PFC config to include:

    $params['pre_proxies'] = array(
        'bigbrother'
    );

    in the list of params that are passed to the new phpFreeChat() instance.

    It also will likely require a rehash of the chat config.

     

    Brett

  • Um.... where would I put that:

    $params['pre_proxies'] = array(
        'bigbrother'
    );

    I mean which file, I'm using this: http://community.elgg.org/pg/plugins/Stahli/read/21653/chat-plugin

    Much thanks, and remember i'm a noob :)

  • @1gbram - It needs to be in mod/chat/index.php or mod/chat/pfc/index.php.  This isn't a newbie friendly hack, unfortunately, so YMMV....

  • Hi there, I'm using your BigBrother addon and it's working great until I also try to use CustomStyles addon.  I've already notified the CustomStyles developer.

    I'm not sure where the error is, but I wanted to notify you as well.

    TIA :-)

    details below for php log:

     

     *** FATAL EXCEPTION *** : exception 'InstallationException' with message 'Type  is not supported. This indicates an error in your installation, most likely caused by an incomplete upgrade.' in C:\wamp\www\elgg15\engine\lib\extender.php:52
    Stack trace:
    #0 C:\wamp\www\elgg15\engine\lib\metadata.php(58): ElggExtender->get('value')
    #1 C:\wamp\www\elgg15\mod\bigbrother\start.php(96): ElggMetadata->__get('value')
    #2 C:\wamp\www\elgg15\engine\lib\elgglib.php(1486): bigbrother_filter_entity('update', 'metadata', Object(ElggMetadata))
    #3 C:\wamp\www\elgg15\engine\lib\elgglib.php(1533): events('update', 'metadata', '', NULL, true, Object(ElggMetadata))
    #4 C:\wamp\www\elgg15\engine\lib\metadata.php(319): trigger_elgg_event('update', 'metadata', Object(ElggMetadata))
    #5 C:\wamp\www\elgg15\engine\lib\metadata.php(221): update_metadata('156903', 'body|background...', 'FFFFFF', 'string', 3, 2)
    #6 C:\wamp\www\elgg15\mod\customstyle\actions\savecolors.php(42): create_metadata('8058', 'body|background...', 'FFFFFF', 'string', '3', 2)
    #7 C:\wamp\www\elgg15\engine\lib\actions.php(65): include('C:\wamp\www\elg...')
    #8 C:\wamp\www\elgg15\engine\handlers\action_handler.php(19): action('customstyle/sav...')
    #9 {main}

  • @elgg_nood -- Yeah something is off.  It looks like these two plugins aren't compatible at least in your configuration.  One of your words could be filltering out something the other plugin needs.  You might try trimming down your word list some...

  • @Brett,  you still developing this plugin?

    I hope you are, it's awesome and very important to keep things on the up and up :-)

     

  • I found an error in your en.php (language file) it appears that around the example of style 1 there is no /code tag and it messes up my plugin page.. I fixed it on the copy I downloaded I just wanted to let you know.

  • Hi Brett, I'm using 1.7.6 and have custom_style installed. I'm getting the same error as elgg_newb error when changing colors:

    InstallationException


    Type is not supported. This indicates an error in your installation, most likely caused by an incomplete upgrade."

     

    My word list is only 4 long atm, just the rudest so I doubt it's that!

    It's definately caused by Big Brother because custom style works ok with it disabled. I'd really like to get both running if I can.

    Any ideas anyone ?

  • please make upgrade for elgg 1.8 its work but not shown message to user and report a content

  • @LiAng:

    • Has not been upgraded for (even) 1.7.X yet
    • Does create a Reported Content entry
  • LOLZ ;-P

    BB was written for Elgg.1.5 - What exactly is to be expected w/ Elgg.1.8 ?

     

  • thank you for this great plugin but does it have a baned word limit? I put about 110 words in and it didn't work but when I reduced the words to about 80 it started working again.

     

    Thanks

    Taner

Brett

Elgg Core Developer

Stats

  • Category: User admin
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 3661
  • Recommendations: 2

Other Projects

View Brett's plugins