Simple BlueWhite Theme v1.5

Release Notes

Updated theme to Elgg v1.5 ie. It requires Elgg version 1.5. If you are still running Elgg v1.2 please use the previous version of this theme.

It also includes css overrides for all the Elgg full-package plugins (blog, categories, custom_index, external pages, file, groups, members, notifications, profile, thewire, twitter etc.).

Once unzipped and copied to your /mod directory, log-in as Admin, go to Tool Administration, and use the controls to move the theme plugin to the bottom of the plugin list (so that it loads last). Making a change to the plugin list order will force the sites cache to be updated - so the new theme is displayed (or you can run upgrade.php to rebuild the sites cache).

 

simple elgg theme example

  • how to change the logo name...which file do i need to update with my new logo name...also what if my logo size is bigger the your example logo?

  • Hi, thanks for the great theme.

    One small concern when using file module, if i click on upload the file, it is destroying bottom spotlight structure, can you please guide be what i need to change so that it do not disturb that area?

  • @ankurdhoom view/default/page_elements/header_contents.php

    There is a minor bug in the main CSS file for this theme. Anytime the .clearfloat is used it seems to incorrectly add 1px of space where the element is in IE8. 

    .clearfloat {
     clear:both;
        height:0;
        font-size: 1px;
        line-height: 0px;
    }

    Change to:

    .clearfloat {
     clear:both;
        height:0;
        font-size: 1px;
        line-height: 1;
    }

     

     

  • no this css change did not helped.....any further suggestion plz...

  • Is there any way that I can just ad the profile part of the template to my site.....

  • hi! This is a very good theme. But using this in conjuction with 3 Colum River Dashboard, gives it a distorted layout. I have screenshot of the said problem, kindly look here: http://i33.tinypic.com/soakxw.jpg

    btw, im using ELG 1.6.1

    Other than the 3 colum rivedashboard problem, the theme works fine.

  • @Marc, Riverdashboard isn't a plugin included in the full elgg package - therefore this theme won't already have a css override for it. To add it to your theme bundle copy the riverdashboards css file from the plugin into your theme bundle and modify it from there.

  • why is it that every single theme i try to install (even on a fresh elgg install) gives me the "misconfigured plugin" error???

  • check your batteries oopsy.. check your typos that is.... ;-)

  • this is very nice. One question though. How do I change position of login box on index page?

  • much appreciated!  cheers :)

  • Is there a possibility to edit it with Custom Style plug-in?

  • Super Great Job. It works perfectly in 1.7

  • I download the file and tried to activate it but this is what I get:

     

    "simpleblue is a misconfigured plugin. It has been disabled. Please see the Elgg wiki for possible causes."

    What am I doing wrong?

  • "What am I doing wrong?"

    Answer - not checking the Elgg wiki before posting your problem :)  http://docs.elgg.org/

  • @tennisbumz

    check your batteries oopsy.. lolz ;-)

    hombre costello gives yew correct advize.. read up well ;-)

  • hey Cash,

    I did go the wiki  and found this:

     

    Misconfigured plugin error

    From Elgg Documentation

    -->

    -->

    Jump to: navigation, search

    --> <!-- start content -->

    If you enable a plugin and the see the error message "<plugin name> is a misconfigured plugin.", this means there is not a start.php file in that plugin's directory. If you are installing a plugin called "test", there will be a test directory under mod. In that test directory there needs to be a start.php file: /mod/test/start.php.

    If there is not a start.php file there, it could be caused by

    • installed plugin to the wrong directory
    • creating a directory under /mod that does not contain a plugin
    • bad ftp transfer
    • installing a language pack that creates directories under /mod

    If you are sure there is a start.php file in the correct directory, it is possible there is a permissions issue on the directory or files.

    You have three options for fixing this:

    • repair the problem (If permissions issue, fix permissions. If no start.php, put an empty start.php there.)
    • create an empty file called disabled in the /mod directory. This will allow you to disable the plugin through the Tools Administration page.
    • if all else fails, remove the problematic directory from /mod.

    I even deleted that file and re-installed it back into the mod, but stlll no luck. Any ideas?

     

  • I'm a newbie to elgg; so, this may be a simple question. I'm using eclipse as an IDE and having CSS problems.  I've changed the size of my logo because it has a different aspect ratio. The site name is now poorly placed. I've tried poking at the css that comes with this plugin and the default css.php. I'd appreciate any pointers on how to go about re-positioning the inside header (ie. the Site Name).

    Great plugin - thanks.

     

  • Hi, I'm using Elgg 1.7.3 ...so far evrything went fine with the theme but since i have enabled customspotlight and moved a couple of things around (plugins up and down) the links to site administartion and user adminstration do not work....i mean they work manually but the mouseover is gone!

    Does anybody know what's going o n?

  • In fact, most of the mouse overs do not work anymore...such as on the dashboard etc...any ideas?

  • @helkelo..  are you looking for professional consulting or freebie help ?"

  • Well, if you have a solution / idea it would be appreciated if you'd posted it here ;-)

  • I just installed this theme in 1.7.3 and it works fine ;-) The problem would therefore be unique to your site - finding a fix for that will take some valuable time/ hours of investigation and debugging ;-( you should try the other alternative ;-)

  • I actgually just deleted my installation and installed a new version of 1.7.3...now the theme works fine again...so probably the custom dashboard plugin is fuckin the installation ;-)

    DhrupDeScoop, thanks for your investigation!

  • so doan go arounnd installing
    all sorts of funky plugins
    coz they'll break your heart every time
    lozl ;-P

Stats

  • Category: Themes
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 29324
  • Recommendations: 21

Other Projects

View Pete Harris's plugins