CKEditor Extended v3.2.1

Release Notes

3.2.1 (2018-06-28):

  • fixed: only load view spec when not provided by system cache

3.2 (2018-06-15):

  • added: image2 ckeditor plugin

3.1 (2018-05-31):

  • added: CKEditor version selector for 4.6, 4.7, 4.8 and 4.9
  • changed: moved ckeditor files to version location
  • fixed: using required with Edge HTML 15 not working

3.0 (2017-05-11):

  • added: CKEditor 4.6
  • added: support for drag&drop images in editor
  • changed: increased minimal Elgg version to 2.3
  • Sir,

    I am using your CKEditor Extended v3.2.1 Plugin and chose  CKEditor version 4.80 with following presets

    @page { margin: 0.79in } p { margin-bottom: 0.1in; line-height: 115% }

    toolbar: [['Format'],['TextColor'],['BGColor'],['Bold'], ['Italic'], ['Underline'], ['Subscript'],['Superscript'],['Strike'],['NumberedList'], ['BulletedList'],['JustifyLeft'],['JustifyCenter'],['JustifyRight'],['JustifyBlock'],['Indent'],['Link'], ['Unlink'],['Image'],['leaflet'],['soundPlayer'],['Table'],['Flash'],['Smiley'],['SpecialChar'],['qrc'],['EqnEditor'],['ckawesome'],['Form'],['Button'],['Iframe'],['Blockquote'], ['Paste',], ['PasteFromWord'],['CopyFormatting'],['RemoveFormat'],['Undo'], ['Redo'],['Templates'],['Replace'],['Maximize']],

    // removeButtons: 'Subscript,Superscript', // To have Underline back

    allowedContent: true,

    baseHref: elgg.get_site_url(),

    removePlugins: 'uploadimage',

    extraPlugins: 'blockimagepaste,leaflet,soundPlayer,ckawesome,eqneditor,qrc,ajax,autogrow',

    defaultLanguage: 'en',

    language: elgg.get_language(),

    //skin: 'moono',

    //skin: 'moono_blue',

    //skin: 'moonocolor',

    skin: 'moono-lisa',

    uiColor: '#FFFFFF',

    contentsCss: elgg.get_simplecache_url('elgg/wysiwyg.css'),

    disableNativeSpellChecker: false,

    disableNativeTableHandles: false,

    // removeDialogTabs: 'image:advanced;image:Link;link:advanced;link:target',

    autoGrow_maxHeight: $(window).height() - 100

    Everything is working except ['ckawesome'] , I have uploaded the required dependency plugins including "Skins", but cant get the ['ckawesome'], fully working..

    When I click on it, it gives me a list of fa icons, but the size and color field is not working. 

    Please see the following pictures



     

    As you can see it allows me to select icon list but the next two field are not working.

    Could you help me to solve this problem?

    @page { margin: 0.79in }
    p { margin-bottom: 0.1in; line-height: 115% }

  • check if you see all js dependecies loaded in a network monitor (debug console of your browser).

Jeroen Dalsem

Owner of ColdTrick IT Solutions, developing social networking sites for the dutch market

Stats

  • Category: Tools
  • License: GNU General Public License (GPL) version 2
  • Updated: 2019-6-11
  • Downloads: 2602
  • Recommendations: 10

Other Projects

View Jeroen Dalsem's plugins