[Elgg 1.8-1.12 & 2.X & 3.X: hypeWall-iZAP Videos and Tidypics] v3.0.0

Release Notes

  • Updated for Elgg 3 and hypeWall release 6.2.0 (so you need both for this version),
  • Quicklink of the hypeWall plugin for adding videos to iZAP Videos is kept unchanged (no longer necessary to add an entry to the hypeWall input form to add videos),
  • Instead of the quicklinks of the hypeWall plugin for Tidypics to add albums (working) and photos (not working) a new quicklink is added to open the "Upload photos" popup of Tidpyics to select the album the photos should be uploaded to or to select the option to add a new photo album.

 

  • I get the following error when attempting to add a photo via tidypics

     You cannot access AJAX views directly

  • Which versions of Elgg, hypeWall, Tidypics and hypeWall-iZAP Videos and Tidypics are you using? Are you sure you use versions of the plugins compatible with the Elgg version? Have you tested if any other plugin might cause the problem (temporarily disabling other 3rd party plugins)?

  • HypeWall - 6.2.0
    TidyPics - 3.3.1
    iZAP videos iionly revised  - 3.3.2
    TidyPics iZAPvideo HypeWall - 3.0.0

    Stock Plugins only thus far other than these

    https enabled

    elgg v 3.3.13

     

    This is what I've got.  I am using IIS10, so it could be a complication of that.

  • It should work with these versions of Elgg and the plugins involved. I just re-tested once more and it works without any issue for me.

    Do you get this error only when selecting the "Upload photos" menu entry from the "Add content" dropdown menu of hypeWall or do you get the same error also when trying the same from any Tidypics related page via the "Upload photos" button in the title area? In the latter case it rather indicate a problem with Tidypics having any issue (that I can't reproduce either) and not necessarily within the "hypeWall-iZAP Videos and Tidypics" plugin. If the error is related to using IIS I'm afraid I can't test because I have no possibility to even try. Have you looked into the server's error log and/or the browser console? Are there maybe any error messages logged that contain additional info?

  • It's only from the drop down initially.  Not sure how I didn't notice before, but it's semi-working now.  I went to upload a photo normally (with HTML4/5 uploader enabled) and noticed I got an error referring to not enough support for HTML4/5 (happens with any browser ATM) so I disabled that and still got the AJAX error.  Then I created an album to test with, uploaded an image, now the drop down works, but now HTML uploader doesn't work.  That's where I stand at the moment. Sorry for the randomly changing details.

  • It seems to me that you get a lot of errors where you shouldn't get any. If you use any recent browser the html5 uploader you definitely work without errors. If it does not work for you with any browser and you also get errors for various other actions I'm afraid the problem might be with Elgg not fully working on IIS (even if it seems to work for others...) or you might not have correctly adapted Elgg's .htaccess file with the rewrite rules and other stuff it contains to work with IIS. I'm afraid I can't help you with that. Maybe you want to open a more general discussion asking for some general advice on how to get Elgg working on IIS (if anyone else uses such a setup anymore at all). Otherwise, you might try to use another webserver (e.g. XAMPP with Apache on Windows or directly Apache on Linux if that's any option).

Stats

  • Category: Media
  • License: GNU General Public License (GPL) version 2
  • Updated: 2020-9-1
  • Downloads: 3696
  • Recommendations: 12

Other Projects

View iionly's plugins