CKEditor with Image Upload v1.2

Release Notes

This is updated version of this plugin.

Just copy in the Mod and use it !!! Please let me know if any feedback..

I am happy to update or modify this plugin

Note :-  Just copy in the Mod and use it !!!  below steps does not required

Please see plugin start .PHP and find below URL please use the URL as per your server and give the path of your Dev environment

// Dev URL

//Production URL

I would Like to thanks @Matt Beckett  and @Paweł Sroka (vazco) who provided me the starting point to implement this plugin.

  • @rj and @Matt: +1!!

    I also think it would be nice to have "embedded" files separated from files that get uploaded via the files plugin. The embedded files could still be handled by the files plugin. But it would be nice to have them for example in a separate category listed (apart from "Your files" a "Your embedded files"). There would be no need for a river entry to be created for the embedded files and it would also not be necessary for any other users to be able to access these embedded files via the files section.

    Add to that: it would also be nice if group files would not be included in the general files section either but only via the group's file page. Even more: moving a file between groups (or to the general files section).

     

  • in the other hand - tinymce used to have an embedder 'tinybrowser' !;P which got dropped off b/c developer made it commercial. older tincymce versions would still have that. ckeditor has pkg`d plugins to handle similarly for almost all media content, including utube, vimeo.. if any-1 is interested in integrating for elgg ;)

  • @matt @iionly @Dhrup

    Well yeah, if only used for embedded files well no problem, but in most cases files is needed as well as embed and it generates unnecessary activity since you want attention to the blog. That's why I like this plugin. May be elgg could make the switch to CKeditor?

    @Dhrup the isolation of the river, I've did that this month on a very awesome project :)

  • Further to my earlier reply anyone who can fix the layout first please? :)

  • Hi
    I installed the plugin but conflicts with the default editor (TinyMCE 1.8).
    When I disable, the CKEditor does not appear.
    Elgg 1.8.13 

  • bende hata verdi 1.8.8.13 versiyonu kullanıyorum ve eklentide hata var etkinleştiremiyorum gereklilik bölümünde hata veriyor

  • this is not functioning with gallicomments - a ui error box is rendered as no comment is logged.

    http://community.elgg.org/plugins/881922/1.1/ajax-comments-for-elgg-18x

  • @Ura, I did not tested this with gallicomments as personally i am not using this plugin. Please take help from gallicomments team. maybe they can suggest something.

  • ok sure, i posted there too.
    i'm also seeing in chromium console:

    Uncaught TypeError: Cannot call method 'getData' of undefined  

    saveDraftCKE
  • i can upload images ok and they appear in the editor.. but when i send the comment to be saved in elgg there is no image being saved in the posted message.

  • @ ura, I am not able to understand your issue can you please explain more.

  • sure. i was tired when i wrote that there. ;)

    i am attempting to use ckeditor to upload images to text areas in elgg, such as comments/replies to entities (blogs/videos etc.).

    i insert an image in ckeditor and upload the file via the ckeditor ui.

    the image appears in the ckeditor textview area.

     when i send the form to elgg to be saved, the image is removed somehow.. maybe by htmlawed?

  • Can you please test this with default elgg installation as I have tested I don't have any such issue. you must be using some third party plugin for comments or theme

  • i was going to disable all the plugins except ckeditor in my test installation.. however, i now have another issue:

    the ckeditor produces the following console error in chromium and ckeditor does not render at all:
    Uncaught [CKEDITOR.editor] The instance "group_topic_post" already exists.

    i have deactivated, deleted and reuploaded the plugin and reactivated; cleared the cache and run upgrade.php; still no change. 

  • i'm not sure what caused that issue.. eventually 'something' cleared/changed and now the editor is rendered again.

    i have disabled all but a few basic plugins and i am seeing different errors when editing free_htm widget:

    Uncaught [CKEDITOR.editor] The instance "params[html_content]" already exists. ckeditor.js:22
    a.editor._init ckeditor.js:22
    a.editor ckeditor.js:7
    a.editor.replace ckeditor.js:7
    d ckeditor.js:8
    a.replace ckeditor.js:8
    (anonymous function) test.infiniteeureka.com:329
    Uncaught TypeError: Cannot call method 'init' of undefined test.infiniteeureka.com:740
    (anonymous function) test.infiniteeureka.com:740
    e.resolveWith jquery-1.6.4.min.js:2
    e.extend.ready jquery-1.6.4.min.js:2
    c.addEventListener.C jquery-1.6.4.min.js:2
    Resource interpreted as Image but transferred with MIME type text/html: "about:blank". ckeditor.js:15
    e.extend.getComputedStyle ckeditor.js:15
    j.load.a.status ckeditor.js:34
    (anonymous function) ckeditor.js:34
    (anonymous function) ckeditor.js:109
    Uncaught Error: SyntaxError: DOM Exception 12

     

  • does this plugin somehow leave a remnant that might change htmllawed in some way?

    i am seeing quite strange behaviour since installing it.. even after removal.

  • Hello,

    I´m an elgg newbie and not very good writing in English.

    I’m trying this plugin and having some errors in php_error_log file, especially when uploading images (for instance in blog posts). I’m running Elgg on Xampp with other sites (url: http://localhost/elgg/).

     

    When I save the blog post with uploaded image occur the error: PHP WARNING: "Missing argument 3 for uploadCK()" in file C:\xampp\htdocs\elgg\mod\CKEditor\start.php (line 13)

     

    When see the post as a logged user, only see a cross besides the image and got the following error: PHP WARNING: "Missing argument 3 for viewCK()" in file C:\xampp\htdocs\elgg\mod\CKEditor\start.php (line 73)

     

    If I see the post as anonymous, see a cross besides the image and got the following error: Exception #1362484707: exception 'InvalidParameterException' in C:\xampp\htdocs\elgg\engine\classes\ElggDiskFilestore.php:211

    Stack trace:

    #0 C:\xampp\htdocs\elgg\engine\classes\ElggFile.php(80): ElggDiskFilestore->getFilenameOnFilestore(Object(ElggFile))

    #1 C:\xampp\htdocs\elgg\mod\CKEditor\start.php(80): ElggFile->getFilenameOnFilestore()

    #2 [internal function]: viewCK(Array, 'CKEditorView')

    #3 C:\xampp\htdocs\elgg\engine\lib\pagehandler.php(53): call_user_func('viewCK', Array, 'CKEditorView')

    #4 C:\xampp\htdocs\elgg\engine\handlers\page_handler.php(46): page_handler('CKEditorView', NULL)

    #5 {main}

     

    Can someone help me?

  • This plug-in don't work whit Internet Exporer 10.

    The input field is not working (it's impossible to insert text).

    Has anyone else also problems with it?

  • I also get the message when leave a comment, that I must enter a message before it can be saved, even though I've done it.


    Only when the page is still loading, i can submit a comment.

    This problem is present in all browsers (Internet Explorer, Firefox and Chrome).

  • Hi Kooistragfakkel, This plugin require update for new version of elgg (but this is not the show stoper right now u still can use in the new verion). I have tested this plugin upto elgg 1.8.9. as still i am on elgg1.8.9  I do not have time to upgrate this plugin right now but soon I will be udating this plugin with latest version of elgg.

    I am not able to understand your issue i am using this in elgg 1.8.9 and its working fine for me.. I am not very sure about IE 10 issue please check in CKeditor support IE 10 or not.

  • Thanks for your anser.

    Glad you want to customize the plugin. Thanks for it.

     

    There is a problem with CKeditor. I've found this information on a website:

    CKEditor version 4 works fine in IE10, previous versions however do not. This problem is not related to IE10, it is related to CKEditor. If you equip your website with the latest version of CKEditor, you will be able to use it normally.

  • My problems are fixed. I don't now the reason, but it works at this moment fine after i fixet an other problem with this plugin.

  • Does someone know how can i fix the next error:

    PHP Fatal error:  Call to a member function getMimeType() on a non-object in /home/sitename/public_html/mod/CKEditor/start.php on line 84

  • Unfortunately, I'm just against (another) approached problem again.

     

    When I log in as an administrator, the uploaded pictures shown, but as a user, the following error message appears:


    Fatal error: Call to a member function getMimeType() on a non-object in /homedir/public_html/intranet/mod/CKEditor/start.php on line 84

Stats

  • Category: Tools
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 6279
  • Recommendations: 17

Other Projects

View saurabh's plugins