[Elgg 1.8-1.12 & 2.X - 4.X: Monolingual] v4.0.0

Release Notes

  • Requires Elgg 4.0 at minimum,
  • Updated for Elgg 4.

Suggestions

  • On Elgg 4.0 or newer uncomment the following line you find in elgg-config/settings.php

// $CONFIG->language_detect_from_browser = true;

and set it to

$CONFIG->language_detect_from_browser = false;

Otherwise it might happen that site visitors who are not logged in see your site in a language other than the language you've selected as site language in the admin area of your Elgg site. If you ask me, this behaviour would contradict the intention of using the Monolingual plugin in the first place.

  • On Elgg 4.1 or newer set the option "Who can change the language" to be found on the basic site settings page to "Everyone". Otherwise, the Monolingual plugin won't be able to restrict the option to change a language from the user settings page as it used to be able to pre- Elgg 4.1+. If the settings is set to "Everyone" the Monolingual plugin still takes care that non-admin users won't ne able to change the language they see the site in to something other than the selected site language).

Stats

  • Category: Misc
  • License: GNU General Public License (GPL) version 2
  • Updated: 2023-9-16
  • Downloads: 2779
  • Recommendations: 9

Other Projects

View iionly's plugins