Language Packs v1.0

Release Notes

  • exporting all languages files into a language pack
  • filter on export, so that only certain languages will be exported
  • importing a language pack into an installation

Please do not use this version if you plan to use the Elgg Language Portal. Use the latest version!

  • Muchas gracias por la colaboración.

    Mi pregunta es ¿luego de descomprimirlo, en que parte del arhivo elgg se instala?

    Por ahora voy a ponerno en languages aunque no me parece nada lógico.

    En el archivo no halle nada como "leame" 

    Favor poner un link directo a hackGlotpress 

     

    Muchas gracias nuevamente.

  • Hi there,

    I don't speak Spanish very well, I'm afraid...

    You need to decompress the archive into the mod directory, so for example if your elgg is in /var/www/elgg, then the plugin should end up under

    /var/www/elgg/mod/languagepacks

    The GlotPress hack is at this address http://elggtranslate.comze.com/

    Please note that it's still not complete, I only have Italian and Spanish there at the moment. I need to involve translators to add translations to it... Do feel free to use it though, and let me know whether it's clear how it works...

    Thanks

  • Hello Federico,

    at first thanks for the nice plugin. It is very useful.

    After installation i found an small problem on the Language Pack import/export page. After the 'languagepacks:intro' => 'You can import a language pack or export any currently installed ones' i see following things

    'language-selection', 'enctype' => 'multipart/form-data')); ?>

    'language-selection', 'enctype' => 'multipart/form-data')); ?>

    What i do wrong during installation? I have to install something additional?

    LG

    Wasserwolf

     

  • Hi there,

    Thanks for your message. I am not sure I understand where you're having this problem? Could you give me more detail please? Where do you see those strings?

    Once I understand what's going on I will try and work out a solution if I can ;-)

  • Hello Federico,

    i'm realy sorry. I try your plugin on my public server and it is working fine. The problem occurs only on my local server. That means it is not a problem with your plugin.

    LG

    Wasserwolf

     

  • Glad it's working... You might be interested to know that a new version is out which also allows you to view a list of users and from there links to translations by a specific user. You can then edit each translation by that user based on your authorisation level...

  • Hi Federico! I was at http://elggtranslate.comze.com/ but I could not find the link or how to download the pt-br (brazilian portuguese) pack... I can see here http://elggtranslate.comze.com/by-translation/locale/pt-br the status, but where can I download it?

     

    tks

  • Hello there,

    You can download language packs from the Tools menu, Elgg Export function (here http://elggtranslate.comze.com/tools/elgg-export). Please note that I'm in the process of upgrading the format, the site and the plugin. At the very moment it is NOT working, but it will be ready over the next couple of days.

    Please wait a little before trying to download the language pack ;-) I will write here when it is all ready or can send you a private message.

    Fed

    PS: Vi que vc é de São Paulo... Gosto muito da sua cidade! E tambem gosto muito da lingua portuguêsa (do Brasil, claro) :-))

  • Hi Fedelico,

    It's not working on local host. After installing this plugin, the same problem as Wasserwolf saying occured.

    Hello Federico,

    at first thanks for the nice plugin. It is very useful.

    After installation i found an small problem on the Language Pack import/export page. After the 'languagepacks:intro' => 'You can import a language pack or export any currently installed ones' i see following things

    'language-selection', 'enctype' => 'multipart/form-data')); ?>

    'language-selection', 'enctype' => 'multipart/form-data')); ?>

    What i do wrong during installation? I have to install something additional?

    LG

    Wasserwolf

    I found two problems on views/default/admin/administer_utilities/languagepacks.php and fixed them then now it works well.

    Line 58-63:

    <? echo elgg_view_form('languagepacks/export', array('class' => 'language-selection', 'enctype' => 'multipart/form-data')); ?>                              

    <p><br/><br/></p>                                                               

    <? echo elgg_view_form('languagepacks/import', array('class' => 'language-selection', 'enctype' => 'multipart/form-data')); ?>                              

    to

    <?php echo elgg_view_form('languagepacks/export', array('class' => 'language-selection', 'enctype' => 'multipart/form-data')); ?>                              

    <p><br/><br/></p>                                                               

    <?php echo elgg_view_form('languagepacks/import', array('class' => 'language-selection', 'enctype' => 'multipart/form-data')); ?>

    This is due to my php configuration that "<?" is ignored.

     

  • Hi Hirotaka,

    どうもありがとう!

    That was such a stupid mistake! My server is set up for short tags so I did not notice that!

    Federico

  • Can some 1 explain to me exactly how this plugin works?Does it enable site users select their preferred language to read site texts?

  • @kxx4

    No, it doesn't. This plugin helps you to manage your language packs.

    • You can add more languages to your Elgg installation by exporting them from this page of the Elgg Translation Portal and importing them via this plugin.
    • You can export all your language packs into a zip file for easier installation onto another Elgg product (for example, from test to production, and so on).
    • You can delete language packs from your Elgg installation.

    If you want to allow users to chose a language for their website, you can download a plugin called Language Selector.

Federico

Developer in PHP, iOS, Java, Android ~ Enjoys synchronised swimming as a hobby

Stats

  • Category: Third Party integrations
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 2231
  • Recommendations: 5

Other Projects

View Federico's plugins