Questions and Answers v1,0

Release Notes

  • compatibility for Elgg 1.8
  • added unimplemented best answer functionality
  • fixed notifications
  • I tested works fine but after choosing the best answer this question should close automatically. It is possible to make that?

     

     

  • Thanks for the plugin. When a question is added and I try to "add comment", I get the following error:

    atal Error.

    An unrecoverable error has occurred and has been logged. Contact the site administrator with the following information:

    Exception #1343741403.  

    int(766) int(767)      


    The comment is posted once the user hits the back button.

  • @kisssssss4ever: there is no possibility to close a question, as there's no functionality implemented. Maybe it will be added in a later release.

    @Starphysique: I tried it and I had no errors. Could comment as creator and as another user without any trouble. Maybe you could give me the output of your error_log file? Furthermore it should be better to post any issues at the issues tracker at github since I'm getting a notice if there's a problem ;-)

  • Thanks for the answer and need to wait for the later release, and other thing is Starphysique  is right I am getting the same error as he gets, maybe its our custom theme? I am using cool theme.

  • Get this email everytime I try to add a question: The action file for question/add was not found.

  • I've tried it again with 2 different Elgg-Version (1.8.0.1 and 1.8.8), cool theme on and off, Questions and Answers at the bottom or at the top of the plugins list... Everytime I could create questions and answers, comment on both and select the best answer without any problem or error (even tried different users for the actions). So I have absolutely no clue why it's not working for you guys.

    So I can't help you due to the lack of information. I would really appreciate if you may give me your output from the error_log files (refer to this article to get the output).

  • i'm getting no error in elgg 1.8.8 without themes.

    Thank you HalloWelt! - Medienwerkstatt for this update !

  • Hi.

    Thanks because of your functional and good plugin. That's very good.

    I use your plugin and everything is OK but when I change the group avatar or upload a photo the group avatar/photo not showing. In fact there is problem in loading the group avatar/photo. When I deactivate the plugin the photos/group avatars loading correctly. Do you know what is the problem?

  • I've tried to reproduce your problem without any success.

    Where does your problem occur? In group detail view (groups/profile/guid)?

    I've created a group without any profile picture. Afterwards I've created a group question. Viewing the question it just displays the users picture (as that's how it's supposed to be). After that I've changed the groups picture which showed up right after I've hit the save button. The groups question was displayed right in the profile page of the picture.

     

    Maybe you could send me an excerpt of your error_log? Furthermore try to move the Q&A-Plugin in plugin list from top to bottom and backwards, maybe this helps.

  • Hi Tobias! I really like this plugin - it could be perfect for our forthcoming school Elgg platform! :-) However, I don't seem to understand how to ask a group question. When I go to a group's page and choose Frage from the top tab row, the question I enter seems to listed under my personal questions. Besides, for most (all?) other Elgg entities it is possible to restrict their visibility to logged in users, friends (lists), group members etc. Why does Q&A lack that feature?

    Regards,

    Andreas.

  • Hi Andreas,

    glad you like the plugin.

    As I've just updated the plugin, there are just features implemented as there are in the original plugin (except for the best answer feature, which was just commented out). So the plugin itself doesn't provide the opportunity to set the access level. It would be possible to make it a new feature, maybe if there's time I could implement it (no promise ;-) ).

    Furthermore, group questions are just visible for members of the group. You can filter your questions by clicking the groups tab on the overview page. So group questions should be visible for group members only. The view you probably refer to as your questions are all questions you can see ("all" tab).

  • Btw, the problem with group pictures not appearing wasn't this plugin's fault ;-)

  • Hi , wonderful plugin and great work.

    However i got a fatal error when add to both questions and answers.

     

    Fatal Error.

    Redirect could not be issued due to headers already being sent. Halting execution for security. Search http://docs.elgg.org/ for more information.

    SecurityException Object
    (
    [message:protected] => Redirect could not be issued due to headers already being sent. Halting execution for security. Search http://docs.elgg.org/ for more information.
    [string:private] => exception 'SecurityException' with message 'Redirect could not be issued due to headers already being sent. Halting execution for security. Search http://docs.elgg.org/ for more information.' in /home2/animeomn/public_html/central/engine/lib/elgglib.php:151
    Stack trace:
    #0 /home2/animeomn/public_html/central/mod/answers/actions/addcomment.php(41): forward()
    #1 /home2/animeomn/public_html/central/engine/lib/actions.php(104): include('/home2/animeomn...')
    #2 /home2/animeomn/public_html/central/engine/handlers/action_handler.php(20): action('http://central....')
    #3 {main}

     

     

  • i meant when i add comment* to both questions and answers. sorry.

  • the comments are added though,  but it kept showing the fatal error when i click post.

  • And one more thing the vote up and down buttons plus mark this a correct answer buttons are not showing , just the vote count 0 is showing.

  • Fatal Error was fixed, for everyone else getting a fatal error after submitting a comment refer to this link

  • Hi,

    I have installed this plugin as our Startup's internal network and it works great. Thank you for the plugin! I am having one issue though.

    When someone comments on an answer, on Activity screen it shows the name of the person who actually provided the answer.

    Like, if A raises a question and B provides an answer to it, and later C comments on the answer, then instead of showing C's name it is showing B's name on the Activity screen.

    Could you please help me with this.

    Thanks. (BTW I had this Fatal Error issue too that got resolved after I referred to your link. Thanks!)

  • Hello,

     

    thanks for the info. There was an error getting the right user, but I fixed it.

    As there were plenty of changes and I think it's not that good if people have to edit the code I've uploaded a new release 1.0.1 with every current changes here

    Enjoy ;-)

HalloWelt! GmbH

Hallo Welt! has been founded to enable everyone to benefit from the technology and concepts of Wikipedia. This is why we build collaborative knowledge bases since 2007.

Stats

  • Category: Communication
  • License: GNU General Public License (GPL) version 2
  • Updated: 2014-11-17
  • Downloads: 3507
  • Recommendations: 14

Other Projects

View HalloWelt! GmbH's plugins