Elgg registration now working!

Last updated by kisssssss4ever Comments (8)

Hi friends

My friend wants to join this Elgg community but the registration page does not work. He fills all the fields and when finish the registration then site takes back him to the main home page. He does not get any email or confirmation on the site by saying his account has created. Then he called me and I tried as well to make an account for him but it did not work.

Appreciate if you can check this please.


  • After few days, still nor reply :(

    Anyone will reply here and help ??

  • What is the name of your site? I had the same problem and it was because the subject can't be longer than 80 characters. When the email was sent it included for the subject Display Name please confirm your email address for The Name Of The Site! If it is more than 80 characters it creates an error in the server log and the email isn't sent.

  • Works for me, I just registered this account to test...

  • The name of this community is very short so the subject would be less than 80 characters. Try changing the name of your site to Hello World and see if you get the registration emails.

    As an additional note, it might have been better for you to post your problem in the discussion area, not as a page.

  • @DanWestlake dear I am talking about this site the one we are ON now. Here my friend can not make account :)


    Thanks Matt Test I will tell him to try again and see again...

  • Possibly the validation email ended in the spam folder of your friends email account (if using any webmail client also check any spam folders online that the email could have moved into).

  • I am using elgg - 1.8.19 . I am facing the same problem . URL : www.safalaya.com

  • I doubt that you have the same problem. The problem here was about the validation email not being received when registering an account here at the Elgg community site. And this problem most likely has been fixed (if there even was an issue in the first place with the Elgg community server).

    Your problem is likely something else. Either the mailserver of your webhosting is not correctly configured to allow for email providers to check the senders credibility (i.e. your mailserver's credibility). I have already posted some hints about that in the past in several posts (e.g. at https://elgg.org/discussion/view/348933/registeration-validation-email-goes-to-spam-folder). In addition to the mailserver configuration you might also have to check if your mailserver is currently on some blocklists (e.g. due to the mailserver not being correctly configured and therefore reported by email providers). The only way to improve this situation is to fix the mailserver configuration in the first place if necessary to avoid any blacklisting and in case your server is blacklisted ask for removal from the list (if you don't fix the mailserver config it won't prevent getting blacklisted again soon). Best would be to ask the support of your webhost also about how to fix the mailserver config. Keywords here are: SPF (Sender policy framework), PTS record for reverse DNS lookups and DomainKeys/DKIM.

    Also, it most likely would really help to upgrade your Elgg version also at least to the latest 1.12 version (in the long run the latest 2.3 version).