404 error on upgrading from 1.7.8 to 1.8.8

I tried upgrading my site to latest Elgg version but 404 error

in place of indx page, A activity page is called. and results in 404 error. 

I tried it many times with fresh installation also. but same error,

tried over writing .htaccess didn't worked. 

On searching, i got this


when i place pg in url

domain.com/activity gives 404 error

but if i add domain.com/pg/activity     non-formatted, but works

same with admin link, it works on adding pg in link

It seems like issue with Elgg instllations in subdirectory.

Please tell, any solution to problem.

  • @Adoi

    Did you removed these folders before upgrading?

    * _css
    * account
    * admin
    * dashboard
    * entities
    * friends
    * search (may interfere with the search plugin so definitely important to delete)
    * settings
    * simplecache

    And did you also remove the views folder before upgrading, as specified in the elgg wiki?

    Rodolfo Hernandez

    Arvixe/Elgg Community Liaison

  • Amazingly, after renaming htaccess_dist 

    Everything working fine now.

    My first sucessful upgrade.

    I am still searching for the reason, which caused this. As it was only a test installation. and error occured 2 more times in earlier attempts.

    Thanks a lot Iionly, you made my day.

    @ Rjcalifornia, Yes i deleted all folders mentioned. 

    Problem seems to be solved.