InvalidParameterException All files must have an owner!

InvalidParameterException All files must have an owner!

Please helppppppppppppp  Im running nuts.

I deleted a user in the databse and i started getting this problem..this happened yesterday and since then, when i go to members or user administration, it gives me this error "InvalidParameterException All files must have an owner!...ive done everything in the blog about the solution ie starting the crontrigger and enabling the garbage collector for 1 week...its still not working.

is there any way i can manually turn on the garbage collector...cos 1 week is too long!

I need some help plssssssssssss

  • @zomaslaus - you haven't enough information to answer your question.

    How did you delete the user?

  • I started afresh and got a new database...ive learnt a lesson to be backing up my data every day.

    Hi all, the account activation email works only in gmail but not in yahoo whats wrong? my yahoo new users can sign in pls helppppppppppp.....

  • I messed this one up too. I deleted users straight from the users_entity table. It left me with the error message 'InvalidParameterException All files must have an owner!'. It meant I could no longer administrate my users, being in a school makes this rather important.

    After some digging, and crossed fingers I managed to fix it. Seeing as though it was my mistake by editing the database, I reasoned that the issue was that objects have been created by the removed users and that this is what it was referring to, so all I had to do was hunt for the objects and delete them so no reference was left by editing the same database. I too did not log what users I had deleted.

    Here is my solution...

    1) Run the following MySQL query on your database in order to find all the entries in the entities table that do not exist in the users_entity table.

    SELECT * FROM elggentities LEFT JOIN elggusers_entity

    ON elggentities.owner_guid = elggusers_entity.guid

    WHERE elggusers_entity.guid IS NULL

    ORDER BY elggentities.owner_guid DESC

    2) Look for many records with the same owner_guid and subtype as '3'. It is likely that these will be the ones you deleted. As they are users that have the plugins registered by default to them when they are created as a user.

    3) You need to delete from users_entity table the record with the offending guid and also the records that contain the same owner_guid.

    After I did that my Site Access came back and I could browse my members again.

    Before you try any of this, back up your db as what worked for me may not work for you :)

    Hope this helps.

  • I have the same problem even with out deleting any users, I have a doubt it's the facebook login plugin.. could this be the cause of the problem?

  • I just got the same problem.  Login page shows the "All Files Must Have An Owner" message.

    The only tricky thing I did today was rename a group and change the visibility of the pages and files in the group.  I did this all through the web pages --- no behind the scenes touching of the database.  I wonder if one of the objects did not get the message about the group changing.

    The other thing I did was add a new group --- perhaps with the same name as what the renamed group used to be.  I uploaded a new image file for the group.  The image file name was the same as the old one.

    More investigating...

    ... and I might try comparing today's database to yesterday's.

     

  • I checked my Apache error log and found the following:

    [Thu Jun 04 09:21:21 2009] [error] [client 10.123.10.108] *** FATAL EXCEPTION *** : exception 'InvalidParameterException' with message 'All files must have an owner!' in E:\\Apache2.2\\htdocs\\elgg-ltg\\engine\\lib\\filestore.php:244
    Stack trace:
    #0 E:\\Apache2.2\\htdocs\\elgg-ltg\\engine\\lib\\filestore.php(257): ElggDiskFilestore->getFilenameOnFilestore(Object(ElggFile))
    #1 E:\\Apache2.2\\htdocs\\elgg-ltg\\engine\\lib\\filestore.php(575): ElggDiskFilestore->exists(Object(ElggFile))
    #2 E:\\Apache2.2\\htdocs\\elgg-ltg\\mod\\groups\\start.php(482): ElggFile->exists()
    #3 E:\\Apache2.2\\htdocs\\elgg-ltg\\engine\\lib\\elgglib.php(1610): groups_groupicon_hook('entity:icon:url', 'group', false, Array)
    #4 E:\\Apache2.2\\htdocs\\elgg-ltg\\engine\\lib\\entities.php(2155): trigger_plugin_hook('entity:icon:url', 'group', Array, false)
    #5 E:\\Apache2.2\\htdocs\\elgg-ltg\\engine\\lib\\entities.php(586): get_entity_icon_url(Object(ElggGroup), 'small')
    #6 E:\\Apache2.2\\htdocs\\elgg-ltg\\mod\\groups\\views\\default\\groups\\icon.php(41): ElggEntity->getIcon('small')
    #7 E:\\Apache2.2\\htdocs\\elgg-ltg\\engine\\lib\\elgglib.php(321): include('E:\\Apache2.2\\ht...')
    #8 E:\\Apache2.2\\htdocs\\elgg-ltg\\mod\\groups\\views\\default\\groups\\grouplisting.php(19): elgg_view('groups/icon', Array)
    #9 E:\\Apache2.2\\htdocs\\elgg-ltg\\engine\\lib\\elgglib.php(321): include('E:\\Apache2.2\\ht...')

    ...

    I'm still new here, but it does look like the system is stressing on the group icon file. Since my custom index page shows recently added groups, it make sense that that page would blow up with the message.

    So that's what I'm going to pursue.  Maybe I can find a way to correct that particular file and give it a good owner. Guess it's time for a little education on the data model.

  • My problem turned out to be a group without an owner. I was able to go into MySQL and change the record for the group in the entities table.  I assigned it an owner_guid and a container_guid consistent with the other groups in the system.

    I still need to find out why those ended up with zero values.  I suspect that my session timed out while I was editing. So when I hit the save button, there was no user to get associated with the newly created group. I am using Elgg 1.5 with only a few changes (new TinyMCE, for instance).  I'm going to see if I can recreate the problem using original 1.5 code. 

     

  • Hi Bill,

    Definitely sounds like an Elgg bug. It should not be possible to create a group without an owner. If you can reproduce it (hmmm even if you can't), perhaps you could put it in trac.elgg.org ?

  • This has happened to me TWICE, on two different Elgg instances.  Both times it took the site down (with this error message) for users not already logged in.  Disabling the Groups plugin, manually deleting the group, then re-enabling the Groups plugin worked to restore service.

    In both cases, my users were creating the groups... So unfortunately I can't reproduce this reliably. The users both said that they went to create the group, filled out the form, and hit “Save,” followed by a blank screen.

    I don't know for sure, but I wonder if it's related to the “session” variables changing somehow … Like maybe I restarted Apache in the time between the user clicking “Create new group” and “Save.”

    I would like to help track this down … It's catastrophic failure when it happens, and I have two production Elgg sites.

  • I have had this happen 6 times. 

    Our site was so crippled in the end that we had to move our membership (with the wonderful help of Dhrup) to a brand new empty install. We lost over a 1,000 members 1,240 groups, 11,000 profiles, everyone's pages, photos, and blogs. As you can surmise it was not an easy decision to make.

     I'm just praying it doesn't happen again (I notice that this thread has a google rank)